Jump to content
TrinityCore

All Activity

This stream auto-updates     

  1. Past hour
  2. Yesterday
  3. https://www.onmsft.com/news/microsoft-beefs-up-github-with-pullpanda-acquisition-makes-code-review-tools-free more freebies added into github.
  4. Good, i need the same too, but for the moment you can look into C++ code to underestand this !
  5. Last week
  6. About the configuration, two topics below I answered how to configure the addresses to play in LAN. Try to see if it works for you. If it does not work, then the problem is connection blocked by a firewall or similar.
  7. I figured it out. I still had 127.0.0.1 set in a couple of places. I had to change the IP address in the following locations: Database: auth.realmlist.address and auth.realmlist.localaddress to 10.x.y.z bnetserver.conf: LoginREST.ExternalAddress=10.x.y.z LoginREST.LocalAddress=10.x.y.z Client: World of Warcraft\ _retail_\WTF\Config.wtf SET portal "10.x.y.z"
  8. I do not know, with arctiumlauncher works perfectly for me. Have you tried modifying the ip address in the file "WTF/Config .wtf" 127.0.0.1? What is your SO? Some ppl with Linux have the same problem.
  9. Hello all, I have stood up a Master server based on the 8.1.5 (30706 x64) retail client, but I cannot figure out how to connect to it. The installation documents say "you will need a custom client launcher (not provided) to connect to master branch server." but I'm stuck. I found the Arctium WoW Client Launcher but when I put it in the root directory and execute it, it launches the game client and get a "You have been disconnected" error when I type in my credentials. What am I doing wrong? What step(s) have I missed?
  10. --- Canned message start --- This thread does not belong in this section in its current form, and should be reposted in the tracker. Please read this thread to make your future help requests more effective. Read This too Search on tracker before posting any bug report. --- Canned message end ---
  11. Hello, I have been using TC for a few weeks now and have noticed a few issues. I am using TDB_full_735.00_2018_02_19 and loading the updates from the src folder ( As suggested from the database setup) 1. Cooking window shows 0/0 and will not allow me to update the skills 2. Unable to learn any cooking skills 3. After purchasing the fishing skill, logging out and coming back in. The Skill is removed from my professions and I cannot purchase it again 4. While fishing, the fishing bobber never plays the animation that a fish has landed. Any suggestions on what could be causing these issue? I have been digging around in the code looking into possible ways to fix it but am not sure where to start. I have read the documentation about contributing but still, there is a lot there. Also, is there any write up on how the database is setup or an explanation as to how the tables are structured? I would love to start contributing to this project. Seems like a fun/challenging process. Thank you, Chaz
  12. I know, the master branch is not the cleanest but I thought the number of failures was excessive, but if it is normal, there is nothing to worry about. Thanks, I'm more relaxed knowing that I was not the one who broke something.
  13. dbc/db2 locales doens't have nothing to do with dberrors, the amount of rows is "logical" because patch version change, master branch never will have clean startup error.
  14. nevermind. figured it out.
  15. TDB 735.00 + source updates included with the latest Master:6b29c4da76fbdcb55b4a89f485a5cff58c4296b9 Maybe with the client "engb" or "enus" when extracting the DBC files it gives less errors, but I do not have time to be testing and extracting.. I asked if it only happens for extracting DBCs from the client "eses" or its happening this to all.
  16. DBC complete load . Reply exctract dbc if you not , maps ,mmaps and vmaps disable . Server.log very clean ) How you update db ? TDB in source main and update all upload ? : Or TDB 735 + update in tdb source me Loading C++ scripts >> Loaded 91 C++ scripts in 8719 ms you Loaded 2731 C++ scripts in 634 ms Validating spell scripts... _SpellScript::ValidateSpellInfo: Spell 65219 does not exist. more more more)
  17. Yes, the IP configuration is the same for all servers including 3.3.5 or 8.1.5.
  18. Try this: In your bnetserver.conf LoginREST.ExternalAddress=192.x.x.x LoginREST.LocalAddress=192.x.x.x In the database (realmlist) address 192.x.x.x localAddress 127.0.0.1 And in the client files (WTF/Config.wtf) On your computer with server: SET portal "127.0.0.1" Others LAN clients: SET portal "192.x.x.x" That's how I play Lan with my girlfriend
  19. Hi! Can someone tell me if it's normal? I have some errors in Server.log file, but I think it's normal or acceptable. But in DBErrors.log it has too many errors (41410 lines ) and it does not seem normal. I'm using the latest: Master: 6b29c4da76fbdcb55b4a89f485a5cff58c4296b9 And I have generated the files dbc, cameras, gt, maps, mmaps and vmaps.. with 8.1.5.30706 client (esES), and of course I have set "DBC.Locale = 6" in to "worldserver.conf" Could it be that the problem is due to the language of the client and the extracted dbc? or have I done something wrong? Thanks
  20. Hi, I have master 8.0.1 running and would like the option to login via 127.0.0.1 and LAN IP. It varies depending on where I am located. Server runs on a laptop and can be part of LAN or solo. Presently I change the LoginREST.localaddress= 192.XXX.XX.XXX OR 127.0.0.1 and EDIT auth.realmlist.address either 192.xxx.xxx.xxx or 127.0.0.1. Of course I change the client wtf also. I presently just change the files and dbase record. 1. Is there a way or settings to allow both configurations to run? 2. Is there a way to make it so I only have to change just the realmlist ip and keep the client on 127.0.0.1 and allow the laptop client to log in for either local or LAN configuration? thanks for your thoughts.
  21. We're so damn close to getting this working. I've loaded into the database with HeidiSQL with my remote root account, and changed auth\realmlist\address to have the value of my server's IP. Clicked "Save". Edited the Data\enUS\realmlist.wtf file in my client (on my desktop pc) to the server's IP (don't have a domain yet): set realmlist *.*.***.*** With the *'s obviously being the numbers of my server's IP. I can log into the account I created in the WorldServer terminal, and the realm list shows the Trinity realm. And when I click on Okay, a window pops up saying: logging into game server That lasts for a couple seconds, before it returns back to the realm list. Edit: Found the solution. You also have to edit the first row on the realmlist's data tab in HeidiSQL, not just the table itself.
  22. thanks for fast reply, is there any solution to connect client to trinity core 8.1.5.30706?
  23. A'ight, gave it a go, now MySQL is refusing my password for trinity. Which is utterly bizarre. Changed the password to the exact same thing I set it to, now I can get into trinity. And now it works. For some bizarre reason, the password changed even though I explicitly kept a text file of it. After changing it to the same password, it now works? This is just bananas. Thanks for the help so far lads, I really appreciate it. Expect questions about accessing MySQL databases once I get started on making tools.
  24. I meant that I followed the guide, where it says to change the password in the .conf files. And it was as the user Trinity that I ran worldserver. I'll give that another go in a moment to see if it works now for some reason.
  1. Load more activity
  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up
×
×
  • Create New...