Jump to content
TrinityCore

Magnuss

Members
  • Content Count

    317
  • Joined

  • Last visited

  • Days Won

    16

Everything posted by Magnuss

  1. You didn't told that you want to going public in your post. In that case you have to open in router1 both ports and forward these ports to your gameserver (192.168.1.130). You should have a static WAN-IP. In your WoW realmlist set the server: Your WAN-IP or your domainname In your Auth database in table realmlist you have to enter in the field address your server ip: Your WAN-IP or your domainname But in general if you have problems with networking you should make at the first time your configuration as simple as possible, f.ex. a) Is everything working well just using local PC on 127.0.0.1? (server, client, database) b) Is everything working in 1 LAN? c) Working well with WAN and LAN? d) Working well with WAN, LAN1 and LAN2?
  2. Read for what a DNS (Domain Name Server) and host files are used. Than you understand why you don't need them as long your are connecting from IP to IP. IP binding to 0.0.0.0 in conf files (both auth and world) means the servers are listening on all IPs and that's fine for you. As I understand you have 2 LANs: WAN | WAN-IP to Router (192.168.1.1/255.255.255.0) | | ---- Gameserver (192.168.1.130/255.255.255.0) | LAN1-IP to Router (192.168.2.1/255.255.255.0) | | ---- PC (192.168.2.?/255.255.255.0) In this configuration you don't need port forwarding but you have to open in the firewall of the gameserver 2 ports 8085 and 3724 (or better switch off the firewall for testing) In your WoW realmlist set the server IP: 192.168.1.130 In your Auth database in table realmlist you have to enter in the field address your server ip: 192.168.1.130 That's all, I think.
  3. Well, never thought people really following the wiki exactly xD. For security reason you may will change later the default password for user trinity or never ever give other host rights than localhost. If you would give host right like % it's likely you will get hacked early or later. Atm, I don't know what the problem could be. You have a user trinity, that's good. The user trinity has permission to the 3 databases, that's also good. And as I understand you right you installed the mysql server and the trinity server on the same machine, so both are localhost. Last thing you may can try is to connect from Ubuntu terminal as user trinity: mysql -u trinity -p Enter password trinity and check if you can access.
  4. Now you have maybe more than you need ;-) If your databases are named auth, characters and world you can revoke rights to trinity_auth and so on. These was only example names to group trinity databases together. REVOKE ALL PRIVILEGES, GRANT OPTION ON trinity_auth.* FROM 'trinity'@'localhost'; REVOKE ALL PRIVILEGES, GRANT OPTION ON trinity_characters.* FROM 'trinity'@'localhost'; REVOKE ALL PRIVILEGES, GRANT OPTION ON trinity_world.* FROM 'trinity'@'localhost'; It seems you have a problem with your password or similar in your config file. Check this in your config file: LoginDatabaseInfo = "127.0.0.1;3306;trinity;trinity;auth" WorldDatabaseInfo = "127.0.0.1;3306;trinity;trinity;world" CharacterDatabaseInfo = "127.0.0.1;3306;trinity;trinity;characters" You have to replace the password with your own password for user trinity.
  5. What's now the output of SELECT Host, User from mysql.user and SELECT Host, Db, User FROM mysql.db
  6. The mySQL server is an independent piece of software. It even could run on a complete different hardware. And it has it's own user management separated from your OS Ubuntu. The idea is to add different new users to the mysql server with fine graduated rights. A mysql user can have access to everything, or just only to specific databases, or only to a table. If you have a webserver, you add a user just only for the webser. If you have a mail server, you add a mailserver user. If you have a trinity server, you add a trinity user. For security reasons root f.ex. never should have set host=%. Better add a new user like adminfity and give admin rights and set host to %. Additionally add a user trinity and give only rights to auth, character and world database. Example for such a 'superuser': CREATE USER 'adminfity'@'%' IDENTIFIED BY 'somepassword'; GRANT ALL ON *.* TO 'adminfity'@'%' WITH GRANT OPTION; Example for trinity user: CREATE USER 'trinity'@'localhost' IDENTIFIED BY 'anotherpassword'; GRANT ALL ON trinity_auth.* TO 'trinity'@'localhost'; GRANT ALL ON trinity_characters.* TO 'trinity'@'localhost'; GRANT ALL ON trinity_world.* TO 'trinity'@'localhost'; As you see I give the trinity user only access on localhost. You would remote access with your adminfity user. Be aware: Examples are out of my brain. And my brain is not allways correct ^^ Edit: Reading the Trinity wiki very exactly helps better: Creating the Trinity databases in MySQL For 3.3.x: https://github.com/TrinityCore/TrinityCore/blob/3.3.5/sql/create/create_mysql.sql For master: https://github.com/TrinityCore/TrinityCore/blob/master/sql/create/create_mysql.sql
  7. As you see, there is no user trinity ;-) Edit: Here's how to add users: https://dev.mysql.com/doc/refman/5.7/en/creating-accounts.html
  8. SELECT Host, User from mysql.user - It seems you don't have added a user trinity (following the posting in the other forum). Therefore you can't access to mysql with this username, even you have a local account on Ubuntu with the same name. And of course you can give every rights to an existing mysql user, but you shouldn't. You shout give only rights really needed. - There are good reasons to NOT allow external access for mysql user root ;-) - And as you was told it seem a problem with password.
  9. There is absolutely nothing wrong with mySQL. Have you switched off Ubuntu firewall? Often the user root is not planned to have remote access and has rights only on localhost. You can try to add another user and give them proper rights. Both (mysql server and user) must have the right to access from external (means setting the host ip to 0.0.0.0. or to your local network) If you have a GUI on your Ubuntu you also can install MySQL Workbench server which is similar to HeidiSql to manage the SQL server.
  10. Just some ideas: Spawn/despawn Change phase mask Change the the type_flags and make him a ghost.
  11. Be aware this may can be confusing for other players if a creature isn't available. And looking to the smartscript wiki page https://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130108/smart+scripts the event On Target Quest Accepted isn't implemented yet.
  12. Today I wanted to edit a wiki page with some small changes. But after saving the page it was fucked up. All internal links was replaced and a lot other stupid changes was made: https://trinitycore.atlassian.net/wiki/pages/diffpagesbyversion.action?pageId=2130261&selectedPageVersions=118&selectedPageVersions=117 I had to revert it to version 117. However I checked it with other pages -> same issue. I even don't need to do any single change. I can just click on page edit, than immediately on page preview and have tons of changes I never made. I hate Atlassian products!
  13. Question 1: The field RequestItemsText in the table quest_template is old and doesn't exist anymore. Replaced by: Table quest_request_items, Field CompletionText
  14. Don't know what you mean exactly. Sounds for me as if you want a custom frame inside the wow client. You can do that with programming a WoW addon with Lua. Trinity core supports addon communication with the server with a small lib: https://github.com/TrinityCore/LibTrinityCore-1.0 https://www.amazon.com/World-Warcraft-Programming-Reference-Creating/dp/0470481285 (Free but illegal PDF of the book in internet available) http://wowprogramming.com/ However for that you need good experience in programming.
  15. May there are commands for that, but I do it in the table auth->account_access. Insert a record with your account_id and a level between 1-3. (3 is admin)
  16. Table: quest_template, Field: RewardXPDifficulty You don't give XP points instead you give the quest a difficulty (mostly between 1-8) and according to this difficulty the player gets some XP points rewarded. https://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130261/quest+template#quest_template-RewardXPDifficulty
  17. The errors shows it's an issue with OpenSSLCrypto. So check if you have installed openssl well and if cmake can find it. And if it's the right version: 32 or 64 bit.
  18. You may have a wrong database version. Try to do exactly every step from the wiki. Source code and initial databases has to fit.
  19. TC doesn't have any problems with 192.168.1.x net range. But networks can make a lot of strange problems, you need good knowledge how it works and tons of tools to test them.
  20. For me it seems here it lacks a little bit of knowledge about networks. ;-) Guess your target is to open your TC server to public internet and you are on a 3.3.5 branch, windows OS and using a common router setting and LAN. 3 steps that you need to do: Step 1: WoW client and TC server on the same PC - Check in your router which IP range and mask your DHCP is using for local dynamic IPs and which range is free for local static IPs in your LAN. If your router uses the IP 192.168.1.1 I guess you are in this net: 192.168.1.0/255.255.255.0 - The DHCP server in your router will use some of the available IPs dynamically for your devices. For ex. maybe 192.168.1.50 up to 192.168.1.200 are dynamically. So you can use the range up to 49 and over 200 as a static IP for your server PC. Check and may change the setting for your needs. - Set the IP and mask of your TC server to an IP in the range for local static IPs., f. ex 192.168.1.8/255.255.255.0. (Check that no other device has the same static IP in your LAN) - Try to configure your server for this IP (192.168.1.8) in realmlist, auth database, config files as described in the wiki. - Run Wow Client and server, test everything. If it doesn't work, fix it. Don't go further to Step 2 :-) Step 2: WoW client and TC server on different PCs but in the same LAN - Use the WoW Client on a 2nd PC in your LAN. This PC can get a dynamically IP from DHCP, f.ex. 192.168.1.51/255.255.255.0 - The IP in the realmlist is the same as in step1 (f.ex. 192.168.1.8) - Run Wow Client and server, test everything. If it doesn't work, fix it. Don't go further to Step 3 :-) May you need to setup your Windows Firewall or switch it off. Step 3: Access TC server by public WAN IP - Be sure you got a static public IP from your ISP. - In your router you need port forwarding of port 3724 and 8085 to your TC server (192.168.1.8) - Change in auth DB in table realmlist the address to your public IP. - On your 2nd PC in the LAN, change in the wow realmlist the IP to your public IP. - Done, it should work now ;-) If not ask in the forum with exactly information where your stuck. (Sorry, if I have forgotten something basically)
  21. @Zaranthos From where you will get all the missing sniffed data for old expansions (in several languages)?
  22. I also have since long time such warnings. You may can ignore them.
  23. https://trinitycore.atlassian.net/wiki Official Trinity Wiki. Just only the link in the forum is wrong.
  24. The wiki tab in the left upper corner links to Nirvana. trinitycore.info is not anymore a valid link.
×
×
  • Create New...