Jump to content
TrinityCore

darkseid4nk

Plebs
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About darkseid4nk

  • Rank
    Newbie
  1. How do I get the make files to use the correct version. According to my OS 6.3.0 is what I have configured, as you can see with gcc and g++ version output. [email protected]:~/wow/TrinityCore/build# sudo update-alternatives --config gcc There are 2 choices for the alternative gcc (providing /usr/bin/gcc). Selection Path Priority Status ------------------------------------------------------------ * 0 /usr/bin/gcc-6 60 auto mode 1 /usr/bin/gcc-4.8 60 manual mode 2 /usr/bin/gcc-6 60 manual mode Press enter to keep the current choice[*], or type selection number: 2 [email protected]:~/wow/TrinityCore/build# gcc -v Using built-in specs. COLLECT_GCC=gcc COLLECT_LTO_WRAPPER=/usr/local/libexec/gcc/x86_64-pc-linux-gnu/6.3.0/lto-wrapper Target: x86_64-pc-linux-gnu Configured with: ./configure --disable-multilib Thread model: posix gcc version 6.3.0 (GCC) [email protected]:~/wow/TrinityCore/build# g++ -v Using built-in specs. COLLECT_GCC=g++ COLLECT_LTO_WRAPPER=/usr/local/libexec/gcc/x86_64-pc-linux-gnu/6.3.0/lto-wrapper Target: x86_64-pc-linux-gnu Configured with: ./configure --disable-multilib Thread model: posix gcc version 6.3.0 (GCC) [email protected]:~/wow/TrinityCore/build# cmake ../ -DCMAKE_INSTALL_PREFIX=/home/darkseid/server -- Detected 64-bit platform -- UNIX: Using default configuration directory -- UNIX: Using default library directory -- UNIX: Configuring uninstall target -- UNIX: Created uninstall target -- UNIX: Detected compiler: /usr/bin/cc CMake Error at cmake/compiler/gcc/settings.cmake:9 (message): GCC: TrinityCore requires version 6.3.0 to build but found 4.8.4 Call Stack (most recent call first): cmake/platform/unix/settings.cmake:29 (include) cmake/macros/CheckPlatform.cmake:13 (include) CMakeLists.txt:61 (include) -- Configuring incomplete, errors occurred! See also "/home/darkseid/wow/TrinityCore/build/CMakeFiles/CMakeOutput.log".
×