Jump to content
TrinityCore

onixiya

Plebs
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About onixiya

  • Rank
    Newbie
  1. I'm getting a error while make is attempting to link the worldserver. I'm on a macbook pro mid 2009 with osx 10.11.6. My revision of the source code is ec9d624aec9e0a39b1bcee7d4077f46be358faad. I'm also following the guide on the wiki Leos-MBP:build silentstorm$ make [ 3%] Built target g3dlib [ 3%] Built target Detour [ 4%] Built target Recast [ 5%] Built target fmt [ 5%] Built target gsoap [ 7%] Built target protobuf [ 9%] Built target casc [ 9%] Built target revision_data.h [ 13%] Built target common [ 15%] Built target database [ 20%] Built target proto [ 21%] Built target shared [ 22%] Built target bnetserver [ 47%] Built target game [ 97%] Built target scripts [ 97%] Linking CXX executable worldserver Undefined symbols for architecture x86_64: "boost::detail::set_tss_data(void const*, boost::shared_ptr<boost::detail::tss_cleanup_function>, void*, bool)", referenced from: boost::thread_specific_ptr<SFMTRand>::reset(SFMTRand*) in libcommon.a(Random.cpp.o) boost::thread_specific_ptr<SFMTRand>::~thread_specific_ptr() in libcommon.a(Random.cpp.o) ld: symbol(s) not found for architecture x86_64 clang: error: linker command failed with exit code 1 (use -v to see invocation) make[2]: *** [src/server/worldserver/worldserver] Error 1 make[1]: *** [src/server/worldserver/CMakeFiles/worldserver.dir/all] Error 2 make: *** [all] Error 2
×
×
  • Create New...