Jump to content
TrinityCore
Sign in to follow this  
victorqueiroz

[SOLVED]Missing worldserver.conf configurations?

Recommended Posts

--- Canned message start --- It appears the issue in the original post was solved, so this thread shall be closed. Should you encounter any other difficulties, please open a new thread. --- Canned message end ---

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
    • By Fyury
      When I run "worldserver.exe" it just crashes and I get this:
      TrinityCore rev. 084da48ba15a 2018-05-26 18:48:09 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
      <Ctrl-C> to stop.
       ______                       __
      /\__  _\       __          __/\ \__
      \/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
         \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
          \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
           \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
            \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                       C O R E  /\___/
      http://TrinityCore.org                    \/__/
      Using configuration file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf.
      Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.1e 11 Feb 2013)
      Using Boost version: 1.65.1
      Updating Auth database...
      >> Auth database is up-to-date! Containing 6 new and 115 archived updates.
      Updating Character database...
      >> Character database is up-to-date! Containing 3 new and 77 archived updates.
      Updating World database...
      >> World database is up-to-date! Containing 193 new and 2262 archived updates.
      Updating Hotfixes database...
      >> Hotfixes database is up-to-date! Containing 18 new and 130 archived updates.
      Realm running as realm ID 1
      Using World DB: TDB 735.00
      Using enUS DBC Locale
      Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
      Using DataDir ./
      WORLD: MMap data directory is: ./mmaps
      VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
      VMap data directory is: ./vmaps
      Missing name Guild.SaveInterval in config file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf, add "Guild.SaveInterval = 15" to this file
      Initialize PlayerDump...
      >> Initialized 370 PlayerDump ColumnDefinitions in 551 ms.
      Loading Trinity strings...
      >> Loaded 965 trinity strings in 32 ms
      Initialize data stores...
      Some required *.db2 files (2 from 230) not found or not compatible:
      ItemSearchName.db2
      WorldSafeLocs.db2
       
       
      ItemSearName.db2 & WorldSafeLocs.db2 dont exist but how can I get them
      When I start "mapextractor.exe" this happens:
       
      Unable to open file DBFilesClient\ItemSearchName.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\Unittest.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\WorldSafeLocs.db2 in the archive for locale enUS: FILE_NOT_FOUND
       
    • By Xzter
      Hello, before i was using trinity fine, everything working perfect. But now, im always getting the worldserver.exe crash.
      Here is log, if someone  can help me to fix it, please. Thanks

      Screenshoot where error always appear

      And, Error Log 
      b19413aaf21d_worldserver.exe_[22-4_11-51-42].txt
    • By cloudfox
      hi there
      i've met a strange problem on linux running TC worldserver.
      everything is ok when i direct type ./worldserver and don't close ssh window. the worldserver session only take 1% less cpu use.
      but when i try to use nohup or setsid to put worldserver backgroud.
      this world server instantly taking 100% cpu percent .no matter how long i wait,%cpu will not come down.
      i even try to use systemctl's service to made server run background,and i found server and systemctl still got 100% cpu use.
      i'm asking for help about how to run server background on ubuntu16.04,and not with 100%cpu use.
       
      thanks!!
×
×
  • Create New...