Jump to content
TrinityCore
Sign in to follow this  
Witam

Two realms on Ubuntu (second worldserver still uses the first worldserver.conf file)

Recommended Posts

Hiho. I'm trying to open a new realm. Copied world, auth, configs to a new folder, but it doesn't work. The default path by 'make install' in ubuntu is usr/bin for binaries and usr/etc for confs, so i thought to make a new 'make install' with a path: 

make install DESTDIR=/blahblah

It installed correctly, I have bin and etc folders within the blahblah folder, but IT STILL USES THE OLD PATH (usr/etc).

Do you have any ideas how to solve this? Thank you!

Share this post


Link to post
Share on other sites

Without any additional parameters right? 

Just a ../configure, make install DESTDIR

Sorry. cmake ../ and make install destdir

Nvm, everything is on wiki.
Thanks!

cmake ../ -DCMAKE_INSTALL_PREFIX=/home/<username>/server -DWITH_WARNINGS=1

Edited by Witam

Share this post


Link to post
Share on other sites

Okay, it totally doesn't work. Made clean cmake, cmake with a path, install with a path - it still runs without renaming conf.dist (runs the first config)

+ it shows the new path in the CMAKE, so SOMETHING is really wrong.

Edited by Witam

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...