Jump to content
TrinityCore
jududdar

Regarding deprecated quests

Recommended Posts

In looking through the database and testing quests, I've found a few that are deprecated (and labelled as such).  Are these outdated quests being left in the database for a reason, or just doesn't help anything to remove them?  Simply wondering whether I should report these or just leave them be.  Thanks!

Share this post


Link to post
Share on other sites

If a quest giver offers you a deprecated quests, that sounds like a bug that should be reported in the tracker.

Share this post


Link to post
Share on other sites

No no, quest givers aren't handing them out.  They're simply still there in the database - I didn't know if they were being left there for posterity's sake, or if they were planning to remove them at some point.  They're not hurting anything at all, just appearing as I was doing some lookups and making lists of quests to test.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Selune
      Hi !
      I'm using last version of 3.3.5 TC branch (with TDB 335.19061), and we have an issue with the mage lvl 20 class quest (Investigate the Alchemist Shop).
      This bug has been reported and partially fixed by different people, as seen on this github page : https://github.com/TrinityCore/TrinityCore/issues/18997
      I tried to re-apply this :
      https://github.com/TrinityCore/TrinityCore/commit/aadd58284e94bc70c96244b61c3933db2211fed1
      The ghosts are now selectable but the box cannot be placed neither.
      Conclusion : at the moment, this quest is supposed to be fixed in #9717, but there are still problems with it. A c++ rewrite has even be proposed in 2014. This seems to be tricky though.
      Anyone here could maybe help me about it ?
      I'm trying to fix it for 3 days by myself, and quite confused now...
      Thanks in advance
       
    • By Hesione
      I'm having a problem with a number of factions not getting the flag "at war" in the reputation tab, and this is unable to be selected by the player. Currently, this is with The Oracles, as my character has their reputation with Frenzyheart. The problem occurs when one of two opposing factions is chosen as the positive reputation one. That said, Bloodsail Buccaneers seems to work fine.
      I did a search on how to fix this, and found this on the TrinityCore issues tracker: https://github.com/TrinityCore/TrinityCore/issues/9469 (specifically https://github.com/TrinityCore/TrinityCore/issues/9469#issuecomment-78925130)
      Do I just go into the ReputationManager.cpp file and edit it directly? I don't understand how the dbc/cpp files are used. Are they called by the client each time the client is started up?
      I found the code for ReputationManager.cpp here: https://github.com/TrinityCore/TrinityCore/blob/master/src/server/game/Reputation/ReputationMgr.cpp
      I don't understand how the fix goes into this code. I can see a Git pull (push?) whereas I thought I could just edit ReputationManager.cpp directly. If so, which lines do I replace (if any)? Otherwise, where should I insert the fix?
       
    • By calaluis
      Hello Community,
      Through this channel, I would like to report an error finding of the emulator, for which I would like to know the real cause of the error.
      I leave the screenshot of the windows server 2012 R2 event viewer.
       

      Nombre de la aplicación con errores: worldserver.exe, versión: 0.0.0.0, marca de tiempo: 0x5b14917c
      Nombre del módulo con errores: worldserver.exe, versión: 0.0.0.0, marca de tiempo: 0x5b14917c
      Código de excepción: 0xc0000005
      Desplazamiento de errores: 0x00000000014afabc
      Identificador del proceso con errores: 0xe4c
      Hora de inicio de la aplicación con errores: 0x01d406690386550f
      Ruta de acceso de la aplicación con errores: C:\WoWEmulator\worldserver.exe
      Ruta de acceso del módulo con errores: C:\WoWEmulator\worldserver.exe
      Identificador del informe: 2f24513a-7cb9-11e8-80ba-dc706f4dc3b8
      Nombre completo del paquete con errores: 
      Identificador de aplicación relativa del paquete con errores: 
      That record has left the server. Stay tuned.
       
       
       
    • By Katria
      I am currently trying to add another realm to my server.
      I have set up 2 new world and characters DB and copied SQL tables over from the first realm. I copied the first realm files (/server) and made a new folder called (/server2). I changed the worldserver.conf to new ports 8086 and added the new dbs to it. I've also tried to change the SOAP port from 7878 to 7879 and turning it off. When I turn on the worldserver for the second realm, it crashes and tells me it can't bind to port 7878 since it's in use from the first realm.
      I run auth and worldserver from the first server folder. I then try to run worldserver for the second realm and the error persists. I am running TC on latest SSL/TC core on Ubuntu 18
      ----------------------------------------------------------------------------------------------------------------------------------------------------------------
      I have also tried to cmake into the second realm folder (/server2) and I get greeted with this error:
      [email protected]:~/TrinityCore/build# make
      [  4%] Built target g3dlib
      [  4%] Built target Detour
      [  5%] Built target Recast
      [  6%] Built target fmt
      [  9%] Built target jemalloc
      [  9%] Built target gsoap
      [ 10%] Built target mpq
      [ 10%] Built target revision_data.h
      [ 14%] Built target common
      [ 14%] Building CXX object src/server/database/CMakeFiles/database.dir/Database/Implementation/CharacterDatabase.cpp.o
      fatal error: file '/usr/include/linux/limits.h' has been modified since the
            precompiled header
            '/root/TrinityCore/build/src/server/database/cotire/database_CXX_prefix.hxx.pch'
            was built
      note: please rebuild precompiled header
            '/root/TrinityCore/build/src/server/database/cotire/database_CXX_prefix.hxx.pch'
      1 error generated.
      src/server/database/CMakeFiles/database.dir/build.make:427: recipe for target 'src/server/database/CMakeFiles/database.dir/Database/Implementation/CharacterDatabase.cpp.o' failed
      make[2]: *** [src/server/database/CMakeFiles/database.dir/Database/Implementation/CharacterDatabase.cpp.o] Error 1
      CMakeFiles/Makefile2:1124: recipe for target 'src/server/database/CMakeFiles/database.dir/all' failed
      make[1]: *** [src/server/database/CMakeFiles/database.dir/all] Error 2
      Makefile:129: recipe for target 'all' failed
      make: *** [all] Error 2
      [email protected]:~/TrinityCore/build#
    • By krokogames
      Hi guys i need help with Pandaria quests 
      quests no show i create new char and 0 quests
      here game screen: Screen
       
      thanks for reply and sorry
×
×
  • Create New...