Jump to content
TrinityCore

Recommended Posts

I use TC335 core on a Windows 8.1 without any problem. Now I have setup a Windows 10 Build 1803 system and got different problems.

CMake produces different errors, it doesn't recognize well Boost and OpenSSL. It finds the Boost root folder and I set manually the openssl root and include folder. It find something but not all libraries.

But looking into the log I found the line 'Detected 32-bit platform'. That's definitely wrong. I guess CMake is looking for 32bit libs now. But I have everything in 64bit.

I use: CMake 3.11.3 / VS Community 2017 Ver. 15.7.3 / OpenSSL 1.1.0h / Boost 1_66_0 or 1_67_0

CMake Log (Debug Mode): https://pastebin.com/Et54UWG5

Any ideas ?

 

EDIT:

Found the problem. On a completely new system you need not only to choose the right compiler, you also need to choose the right complier for 64bit ;-)

Share this post


Link to post
Share on other sites
On 6/14/2018 at 4:59 PM, Magnuss said:

EDIT:

Found the problem. On a completely new system you need not only to choose the right compiler, you also need to choose the right complier for 64bit ;-)

Hey could you please clarify this or take a screenshot of those settings what we need to specify

Share this post


Link to post
Share on other sites
10 minutes ago, Untechie said:

Hey could you please clarify this or take a screenshot of those settings what we need to specify

image?token=eyJhbGciOiJIUzI1NiJ9.eyJpc3M

Share this post


Link to post
Share on other sites

Hey Aokromes, I tried to make a fresh compile today, pulled trinity master to c:/trinity, dl-ed newest cmake specified that ⌃⌃ from the tutorial screenshot native compilers etc. and everythings working up until Visual studio builds it, I get this message 

d83664890001bfa133a8cd9e10fb0519.png

and D:\Build\bin\RelWithDebInfo looks like this its missing bnetserver.exe bnetserver.pdb bnetserver.conf.dist bnetserver.cert.perm bnetserver.key.perm

431b871be75ab97a09ab1224cf9b9563.png

EDIT: this solved, had old boost installed

Edited by Untechie

Share this post


Link to post
Share on other sites
4 hours ago, Untechie said:

Hey Aokromes, I tried to make a fresh compile today, pulled trinity master to c:/trinity, dl-ed newest cmake specified that ⌃⌃ from the tutorial screenshot native compilers etc. and everythings working up until Visual studio builds it, I get this message 

d83664890001bfa133a8cd9e10fb0519.png

and D:\Build\bin\RelWithDebInfo looks like this its missing bnetserver.exe bnetserver.pdb bnetserver.conf.dist bnetserver.cert.perm bnetserver.key.perm

 

you need to scroll to find real error.

Share this post


Link to post
Share on other sites
5 minutes ago, Aokromes said:

you need to scroll to find real error.

hmm then when i run it again i'll check that out, but tell me another thing please if the current retail wow isn't 7.3.5.26654 like trinity master where is the best place to download client, yesterday i dl-ed from some private servers google drive but it wasnt compatible with trinity extractors

Share this post


Link to post
Share on other sites
8 minutes ago, Untechie said:

hmm then when i run it again i'll check that out, but tell me another thing please if the current retail wow isn't 7.3.5.26654 like trinity master where is the best place to download client, yesterday i dl-ed from some private servers google drive but it wasnt compatible with trinity extractors

Client requirement was updated to 7.3.5.26822  yesterday.

  • Like 1

Share this post


Link to post
Share on other sites

Hey I'm trying to configure hot reloading that Naios (Denis Blank) implemented a while ago to speed up development. The step I am confused at which is probably really easy and really trivial is when he says to make sure to change the target to the install target in visual studio to install to the CMAKE_INSTALLPREFIX location. Can anyone clarify this? Screenshot provided below and highlighted with red border its step 2 I'm confused with 

Capture.PNG

Share this post


Link to post
Share on other sites

Just use any new folder you want but NOT the build folder.

(And also NOT c:/program files/something because they are write protected.)

This configuration is the same for static or dynamic linking.

 

Share this post


Link to post
Share on other sites
2 minutes ago, Magnuss said:

Just use any new folder you want but NOT the build folder.

(And also NOT c:/program files/something because they are write protected.)

This configuration is the same for static or dynamic linking.

 

Yeah thanks so much forgot to mention that I solved it. Yeah just built the install folder and it built out to the folder I specified with the prefix. It works great for the ashmancore btw!

Share this post


Link to post
Share on other sites


Hello. There was a problem in the compilation "master (legion client)" on OC Debian 9.x.
I really need your help, since I am not experienced enough in this direction, so I will only study this direction and I will be very grateful if, there is an opportunity to help in this decision!

I use the instructions for removing this link : https://trinitycore.atlassian.net/wiki/spaces/tc/pages/10977288/Linux+Requirements

Error compiling:
 

 No Boost libraries were found.  You may need to set BOOST_LIBRARYDIR to the
  directory containing Boost libraries or BOOST_ROOT to the location of
  Boost.  If you still have problems search on forum for TCE00020.
Call Stack (most recent call first):
  dep/boost/CMakeLists.txt:43 (find_package)


CMake Error at /usr/share/cmake-3.7/Modules/FindPackageHandleStandardArgs.cmake:                                  138 (message):
  Could NOT find ZLIB (missing: ZLIB_LIBRARY) (found version "1.2.8")
Call Stack (most recent call first):
  /usr/share/cmake-3.7/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_F                                  AILURE_MESSAGE)
  /usr/share/cmake-3.7/Modules/FindZLIB.cmake:114 (FIND_PACKAGE_HANDLE_STANDARD_                                  ARGS)
  dep/zlib/CMakeLists.txt:13 (find_package)


-- Configuring incomplete, errors occurred!
 

Initially I used the default setting of parameters, there was no error, and after prompted to extract maps,mmaps, dbc files.. 
you must specify the parameters needed.That's actually in this error and it turns out ... and it still can not be solved ...

 

Edited by Crystal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
       
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
       
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
    • By Wark
      I'd just like to get a little insight to why so much of the current Trinitycore code doesn't match up to a few years ago.
      Now I know I'm not a pro at coding on Trinitycore and I understand that the core is open sourced but these just seem so significant and doesn't seem right to remove this stuff.
       
      Let me give an example. Lets say I'm watching this tutorial to get a little information about classes and methods that I can use when making a script. (I've also been using the Trinitycore Code Documentation as reference as well but it also seems to show the same issues)
      Although the tutorial is a little out of date, I don't see why OnGossipSelect doesn't exist anywhere in CreatureScript and that when I try to link the script to the core code it spits out this error.
      object of abstract class type "GossipTeleporter" is not allowed:
      pure virtual function "CreatureScript::GetAI" has no overrider
      The DEFINES of "ADD_GOSSIP_ITEM" and many more don't exist either.
       
      Am I missing something? All I want to know is if the core is mean't to be this way and if not should I download an older version of the core before I put to much working into my current core.
      (I downloaded my core right from the Trinitycore website tutorial)
       
      I'm currently trying to write a simple gossipteleporter that will let you talk to an npc and teleport to the given location. It's very hard to do this when so many things just don't exist within my core.
       
      EXTRA: I pasted this into a new custom script just to see if I would get errors and I got a lot of different errors: http://pastebin.com/raw/G62e0t49
      This was obtained from here: http://www.ac-web.org/forums/showthread.php?129885-Request-Teleporter-NPC-for-TrinityCore
      By no means am I looking to copy the code from the two links above, I was using them as a test to see if my core accepted them.
       
      Thanks,
      Wark
    • By Cantte
      Well ... today I was about to compile the trinity core version for WoW 4.3.4 of this repository "https://gitlab.com/trinitycore/TrinityCore_434". Download them and when you use the cmake, I generate the solution correctly. When I began to compile this went well until I got to the last step, when I was 90% practically.
      This was the error:
      Main.obj: error LNK2019: external symbol SSLeay_version unresolved referred to in the function "public: void __cdecl <lambda_4a2d53ce610f18dba0b4b4d6532c13a7> :: operator () (void) const" (?? R <lambda_4a2d53ce610f18dba0b4b4d6532c13a7> @@ QEBAXXZ)
      25> scripts.lib (cs_server.obj): error LNK2001: external symbol SSLeay_version unresolved
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_num external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_value external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_pop_free external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: outer symbol OPENSSL_add_all_algorithms_noconf unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_load_error_strings unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved external SSLv23_method symbol referenced in the ssl_auth_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_library_init unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_state unresolved referenced in the tcp_connect function
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_num_locks unresolved referred to in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_set_locking_callback unresolved referred to in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_THREADID_set_numeric unresolved referred to in the function "void __cdecl threadIdCallback (struct crypto_threadid_st *)" (? ThreadIdCallback @@ YAXPEAUcrypto_threadid_st @@@ Z)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_THREADID_set_callback unresolved referenced in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (ARC4.obj): error LNK2019: external symbol EVP_CIPHER_CTX_init unresolved referred to in the function "public: __cdecl ARC4 :: ARC4 (unsigned int)" (?? 0ARC4 @@ QEAA @ I @ Z)
      25> common.lib (HmacHash.obj): error LNK2019: unresolved HMAC_CTX_init external symbol referenced in the "struct hmac_ctx_st * __cdecl HMAC_CTX_new (void)" function (? HMAC_CTX_new @@ YAPEAUhmac_ctx_st @@ XZ)
      25> common.lib (HmacHash.obj): error LNK2019: unresolved HMAC_CTX_cleanup external symbol referenced in the "void __cdecl HMAC_CTX_free (struct hmac_ctx_st *)" function (? HMAC_CTX_free @@ YAXPEAUhmac_ctx_st @@@ Z)
      25> E: \ Server-Wow \ TrinityCore_434-4.3.4 \ Build \ bin \ RelWithDebInfo \ worldserver.exe: fatal error LNK1120: 16 external unresolved
      25> Compilation of the "worldserver.vcxproj" project completed - ERROR.
      26> ------ Compile operation started: project: ALL_BUILD, configuration: RelWithDebInfo x64 ------
      26> Building Custom Rule E: /Server-Wow/TrinityCore_434-4.3.4/CMakeLists.txt
      26> CMake does not need to re-run because E: /Server-Wow/TrinityCore_434-4.3.4/Build/CMakeFiles/generate.stamp is up-to-date.
      ========== Compile: 23 correct, 3 incorrect, 0 updated, 0 omitted ==========
       
      And this is the original error in Spanish (since I use the compiler in Spanish)
       
      Main.obj : error LNK2019: símbolo externo SSLeay_version sin resolver al que se hace referencia en la función "public: void __cdecl <lambda_4a2d53ce610f18dba0b4b4d6532c13a7>::operator()(void)const " (??R<lambda_4a2d53ce610f18dba0b4b4d6532c13a7>@@QEBAXXZ)
      25>scripts.lib(cs_server.obj) : error LNK2001: símbolo externo SSLeay_version sin resolver
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_num sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_value sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_pop_free sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo OPENSSL_add_all_algorithms_noconf sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_load_error_strings sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSLv23_method sin resolver al que se hace referencia en la función ssl_auth_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_library_init sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_state sin resolver al que se hace referencia en la función tcp_connect
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_num_locks sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_set_locking_callback sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_THREADID_set_numeric sin resolver al que se hace referencia en la función "void __cdecl threadIdCallback(struct crypto_threadid_st *)" ([email protected]@[email protected]@@Z)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_THREADID_set_callback sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(ARC4.obj) : error LNK2019: símbolo externo EVP_CIPHER_CTX_init sin resolver al que se hace referencia en la función "public: __cdecl ARC4::ARC4(unsigned int)" ([email protected]@[email protected]@Z)
      25>common.lib(HmacHash.obj) : error LNK2019: símbolo externo HMAC_CTX_init sin resolver al que se hace referencia en la función "struct hmac_ctx_st * __cdecl HMAC_CTX_new(void)" ([email protected]@[email protected]@XZ)
      25>common.lib(HmacHash.obj) : error LNK2019: símbolo externo HMAC_CTX_cleanup sin resolver al que se hace referencia en la función "void __cdecl HMAC_CTX_free(struct hmac_ctx_st *)" ([email protected]@[email protected]@@Z)
      25>E:\Server-Wow\TrinityCore_434-4.3.4\Build\bin\RelWithDebInfo\worldserver.exe : fatal error LNK1120: 16 externos sin resolver
      25>Compilación del proyecto "worldserver.vcxproj" terminada -- ERROR.
      26>------ Operación Compilar iniciada: proyecto: ALL_BUILD, configuración: RelWithDebInfo x64 ------
      26>Building Custom Rule E:/Server-Wow/TrinityCore_434-4.3.4/CMakeLists.txt
      26>CMake does not need to re-run because E:/Server-Wow/TrinityCore_434-4.3.4/Build/CMakeFiles/generate.stamp is up-to-date.
      ========== Compilar: 23 correctos, 3 incorrectos, 0 actualizados, 0 omitidos ==========
       
       
      Thanks.
    • By Fyury
      When I run "worldserver.exe" it just crashes and I get this:
      TrinityCore rev. 084da48ba15a 2018-05-26 18:48:09 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
      <Ctrl-C> to stop.
       ______                       __
      /\__  _\       __          __/\ \__
      \/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
         \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
          \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
           \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
            \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                       C O R E  /\___/
      http://TrinityCore.org                    \/__/
      Using configuration file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf.
      Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.1e 11 Feb 2013)
      Using Boost version: 1.65.1
      Updating Auth database...
      >> Auth database is up-to-date! Containing 6 new and 115 archived updates.
      Updating Character database...
      >> Character database is up-to-date! Containing 3 new and 77 archived updates.
      Updating World database...
      >> World database is up-to-date! Containing 193 new and 2262 archived updates.
      Updating Hotfixes database...
      >> Hotfixes database is up-to-date! Containing 18 new and 130 archived updates.
      Realm running as realm ID 1
      Using World DB: TDB 735.00
      Using enUS DBC Locale
      Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
      Using DataDir ./
      WORLD: MMap data directory is: ./mmaps
      VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
      VMap data directory is: ./vmaps
      Missing name Guild.SaveInterval in config file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf, add "Guild.SaveInterval = 15" to this file
      Initialize PlayerDump...
      >> Initialized 370 PlayerDump ColumnDefinitions in 551 ms.
      Loading Trinity strings...
      >> Loaded 965 trinity strings in 32 ms
      Initialize data stores...
      Some required *.db2 files (2 from 230) not found or not compatible:
      ItemSearchName.db2
      WorldSafeLocs.db2
       
       
      ItemSearName.db2 & WorldSafeLocs.db2 dont exist but how can I get them
      When I start "mapextractor.exe" this happens:
       
      Unable to open file DBFilesClient\ItemSearchName.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\Unittest.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\WorldSafeLocs.db2 in the archive for locale enUS: FILE_NOT_FOUND
       
×