Jump to content
TrinityCore

Recommended Posts

From what I can read on the web it seems like your glibc version is too old.

http://manpages.courier-mta.org/htmlman2/mremap.2.html

Debian Etch comes standard with libc : libc6 2.2.3

Try updating. As far as I can see that in itself will be a problem. Repo no longer available @ http://ftp.debian.org/dists/

Link to comment
Share on other sites

Running a console only server does not require much. It depends on the amount of players connecting to it.

As for upgrade. What are the specifications?( CPU, RAM, HDD, Optical Drive type)

This looks good. http://www.go2linux.org/upgrading-debian

It does not rely on using etch repo. The system should have internet access to do it.

Link to comment
Share on other sites

My Hostsystem has the Virtuozzo-Version "Virtuozzo release 3.0.0 ". The Hostsystem need "Virtuozzo 4" for Debian 5.0. Server4You is a bad Host.

I asked the support. Actually, should the host system a long time "Virtuozzo 4" However there are problems. I've just created a ticket and ask it how long it takes until about Debian 5.0 is possible. I hope it takes not so long.

Link to comment
Share on other sites

Server4You is something totally real slow. For the first 5.0 Offers you have taken nearly 5 months after 5.0 came out.

Thank you for your hope. I hope that Server4You help me in any way.

Is it possible to somehow fiddle to the core so that it goes well with 4.0? At that time it went it.

Is my Google Translator English O.K?

Link to comment
Share on other sites

I think your problem is not server4you, your problem is that you use vServer.

The server i have worked for is from server4you but a root server, there where no problem to upgrade form debian etch to debian lenny.

BTW we are going more and more offtopic.

Edited by Maxx
Link to comment
Share on other sites

Maxx,

I have just learned from Server4You that it can be updated in theory already on Debian 5.0. Even if you virtouzzo 3 The problem with the whole thing is then in Plesk. Plesk requires more than 8.4 virtouzzo 4 and the host system from my virtual Server has virtouzzo 3.

Your root server has probably already virtouzzo 4 and, therefore, could you Easy on Debian Lenny.

Link to comment
Share on other sites

Hi,

i have a Linux Debian 4.0 Plesk 8.4 64 Bit vServer machine...

cmake was successful.

This cmake Code i have use:

cmake ../TrinityCore -DPREFIX=/home/TrinityCore/build

in the build directory.

lol,

You should have made a build directory outside of the source.

Like this:

~/TrinityCore - source

~/build - build directory

~/server - server directory (Note: this is made during make)


cd ~/build
cmake ../TrinityCore/ DPREFIX=/home/<username>/server
make -j 4
sudo make install

Link to comment
Share on other sites

OK besides the fact of being lazy, and not knowing what you are doing, why are you using Plesk in the first place? it can all be done manually, and then you don't have to pay 20-50 per 30-100 user license per month. Second, if you are still on debian 4 it is time to upgrade. I don't have any of these problems on debian 5 64bit with or without plesk.

I would guess it isn't server4you it is most likely a pebcac error.

At least in this post you are providing a little more information... unlike your last.

Link to comment
Share on other sites

Hi everyone ..

i just download trinity core in https://github.com/TrinityCore/TrinityCore.git.. when compile using cmake everything look fine nothing erorr message found. But when i try to run the trinitycore.sln file i found an erorr like this ..

17>------ Build started: Project: worldserver, Configuration: Release Win32 ------

17>Compiling...

17>worldPCH.cpp

17>Compiling...

17>WheatyExceptionReport.cpp

17>Master.cpp

17>Main.cpp

17>WorldRunnable.cpp

17>TCSoap.cpp

17>RASocket.cpp

17>RARunnable.cpp

17>CliRunnable.cpp

17>Compiling resources...

17>Microsoft (R) Windows (R) Resource Compiler Version 6.1.6723.1

17>Copyright (C) Microsoft Corporation.  All rights reserved.

17>Performing Pre-Link Event...

17>Linking...

17>LINK : fatal error LNK1181: cannot open input file '..\game\Release\game.lib'

17>Build log was saved at "file://d:\Game\TBuild\src\server\worldserver\worldserver.dir\Release\BuildLog.htm"

17>worldserver - 1 error(s), 0 warning(s)

18>------ Skipped Build: Project: INSTALL, Configuration: Release Win32 ------

18>Project not selected to build for this solution configuration 

========== Build: 15 succeeded, 2 failed, 2 up-to-date, 1 skipped ==========

it says "cannot open input file '..\game\Release\game.lib" ..where should i find this file (game.lib) Pls help me .. i've been trying to compile this core day and have no luck..

thanks and sorry for bad english grammar

Link to comment
Share on other sites

Hello all.

I have a question.

I want use all legan software, VS2010 Ultimate is expensive, and i don`t like crack it, but when i try to use VS2010 Express i get following problem:

I can`t compile trinity sources under x64

because x64 compilers are not supported native in Express edition

As i understand need to download extensions, but ... i was download frameworks install and nothing =/

May be someone know what need to download and install to

http://www.microsoft.com/express/Downloads/#2010-Visual-CPP

All - Offline Install ISO image file ?

OS: Windows x64 Enterprise

Edited by Sun
Link to comment
Share on other sites

download and install this (someone sent me link on IRC yesterday):

http://gitextensions.googlecode.com/files/GitExtensions209SetupComplete.msi

after installing create new folder, right click Git Extensions -> Clone

Repository to clone: https://github.com/TrinityCore/TrinityCore.git

hit clone button and wait...

when you get the source you should already know what to do with it :)

if you want to update that source, enter your folder, right click

on TrinityCore subfolder -> Git Extensions -> Pull

... let there Remote: origin, just hit pull button, that's all

LihO

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
       
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
       
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
×
×
  • Create New...