Jump to content
TrinityCore

Recommended Posts

Hi,

 

I successfully compiled the latest TrinityCore without any Errors, but I cant start mapextractor, authserver or worldserver.

No Repack only Trinity-Software and Tutorials. Pulled the Core 2 times and compiled it 4 times, always the same Problem. 

 

Ubuntu 12.04.2 LTS 32bit Server Version

335.52 DB

 

 

If I start the mapextractor "normal" I get:

$ /home/<user>/server/bin/mapextractor

Map & DBC Extractor
===================
 
Detected locale: deDE
Ungültiger Maschinenbefehl (Speicherabzug geschrieben)
$
 
If I start it with sudo I get:
$ sudo /home/<user>/server/bin/mapextractor
Map & DBC Extractor
===================
 
Detected locale: deDE
$
 
Similar Problem with authserver and worldserver. And yes the configs are set up correct.
 
$ ./authserver
Ungültiger Maschinenbefehl (Speicherabzug geschrieben)

$
 

$ sudo ./authserver

$

 

Any Ideas?
Thx for the answers

Link to comment
Share on other sites

Hello,

 

I am trying to set a new server but I encounter an error in CMake: "Error in configuration process, project files may be invalid"

The C compiler identification is MSVC 16.0.30319.1
The CXX compiler identification is MSVC 16.0.30319.1
Check for working C compiler using: Visual Studio 10
Check for working C compiler using: Visual Studio 10 -- broken
CMake Error at C:/Program Files/CMake 2.8/share/cmake-2.8/Modules/CMakeTestCCompiler.cmake:61 (message):
  The C compiler "C:/Program Files/Microsoft Visual Studio
  10.0/VC/bin/cl.exe" is not able to compile a simple test program.

  It fails with the following output:

   Change Dir: D:/Build/CMakeFiles/CMakeTmp

  

  Run Build Command:C:WindowsMicrosoft.NETFrameworkv4.0.30319MSBuild.exe
  cmTryCompileExec2318216209.vcxproj /p:Configuration=Debug
  /p:VisualStudioVersion=10.0

  Microsoft (R) Build Engine version 4.0.30319.17929

  [Microsoft .NET Framework, version 4.0.30319.17929]

  Copyright (C) Microsoft Corporation.  All rights reserved.

  

  Build started 8/11/2013 6:59:42 PM.

  Project "D:BuildCMakeFilesCMakeTmpcmTryCompileExec2318216209.vcxproj"
  on node 1 (default targets).

  PrepareForBuild:

    Creating directory "cmTryCompileExec2318216209.dirDebug".
    Creating directory "D:BuildCMakeFilesCMakeTmpDebug".

  InitializeBuildStatus:

    Creating "cmTryCompileExec2318216209.dirDebugcmTryCompileExec2318216209.unsuccessfulbuild" because "AlwaysCreate" was specified.

  ClCompile:

    C:Program FilesMicrosoft Visual Studio 10.0VCbinCL.exe /c /Zi /W3 /WX- /Od /Ob0 /Oy- /D WIN32 /D _WINDOWS /D _DEBUG /D "CMAKE_INTDIR="Debug"" /D _MBCS /Gm- /RTC1 /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Fo"cmTryCompileExec2318216209.dirDebug" /Fd"D:/Build/CMakeFiles/CMakeTmp/Debug/cmTryCompileExec2318216209.pdb" /Gd /TC /analyze- /errorReport:queue testCCompiler.c
    Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 16.00.30319.01 for 80x86
    Copyright (C) Microsoft Corporation.  All rights reserved.
    
    cl /c /Zi /W3 /WX- /Od /Ob0 /Oy- /D WIN32 /D _WINDOWS /D _DEBUG /D "CMAKE_INTDIR="Debug"" /D _MBCS /Gm- /RTC1 /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Fo"cmTryCompileExec2318216209.dirDebug" /Fd"D:/Build/CMakeFiles/CMakeTmp/Debug/cmTryCompileExec2318216209.pdb" /Gd /TC /analyze- /errorReport:queue testCCompiler.c
    
    testCCompiler.c

  ManifestResourceCompile:

    C:Program FilesMicrosoft SDKsWindowsv7.0Abinrc.exe /nologo /fo"cmTryCompileExec2318216209.dirDebugcmTryCompileExec2318216209.exe.embed.manifest.res" cmTryCompileExec2318216209.dirDebugcmTryCompileExec2318216209_manifest.rc 

  Link:

    C:Program FilesMicrosoft Visual Studio 10.0VCbinlink.exe /ERRORREPORT:QUEUE /OUT:"D:BuildCMakeFilesCMakeTmpDebugcmTryCompileExec2318216209.exe" /INCREMENTAL /NOLOGO kernel32.lib user32.lib gdi32.lib winspool.lib shell32.lib ole32.lib oleaut32.lib uuid.lib comdlg32.lib advapi32.lib /MANIFEST /ManifestFile:"cmTryCompileExec2318216209.dirDebugcmTryCompileExec2318216209.exe.intermediate.manifest" /MANIFESTUAC:"level='asInvoker' uiAccess='false'" /DEBUG /PDB:"D:/Build/CMakeFiles/CMakeTmp/Debug/cmTryCompileExec2318216209.pdb" /SUBSYSTEM:CONSOLE /TLBID:1 /DYNAMICBASE /NXCOMPAT /IMPLIB:"D:/Build/CMakeFiles/CMakeTmp/Debug/cmTryCompileExec2318216209.lib" /MACHINE:X86 cmTryCompileExec2318216209.dirDebugcmTryCompileExec2318216209.exe.embed.manifest.res
    cmTryCompileExec2318216209.dirDebugtestCCompiler.obj  /machine:X86 /debug 

  LINK : fatal error LNK1123: failure during conversion to COFF: file invalid
  or corrupt
  [D:BuildCMakeFilesCMakeTmpcmTryCompileExec2318216209.vcxproj]

  Done Building Project
  "D:BuildCMakeFilesCMakeTmpcmTryCompileExec2318216209.vcxproj" (default
  targets) -- FAILED.

  

  Build FAILED.

  

  "D:BuildCMakeFilesCMakeTmpcmTryCompileExec2318216209.vcxproj" (default
  target) (1) ->

  (Link target) -> 

    LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt [D:BuildCMakeFilesCMakeTmpcmTryCompileExec2318216209.vcxproj]

  

      0 Warning(s)
      1 Error(s)

  

  Time Elapsed 00:00:00.37

  

  

  CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
  CMakeLists.txt:12 (project)


Configuring incomplete, errors occurred!

I am running it on Windows 7.

I have installed OpenSSL 1_0_1e

I have installed Microsoft Visual 2010 and tried with 2012 too.

I've runned as administrator all the programs.

I've searched on the forum but I can't find any solution to solve this problem.

 

I am looking forward for you help,

 

Thank you

Edited by tybyrysk
Link to comment
Share on other sites

I've installed all service packs and updates for visual studios 2010 but the error still persist( http://pastebin.com/i1Vn4pvk )

I've tryed to skip this step but now, after building process I have no BIN -> RELEASE folder in D: Build ( http://pastebin.com/fWLXUzYG )

 

I have no idea how to solve this problem so I am very thankful for your future help.

Link to comment
Share on other sites

hello, i have the following error:

/opt/trinity2/TrinityCore/src/server/shared/Cryptography/BigNumber.cpp: In member function âACE_Auto_Array_Ptr<unsigned char> BigNumber::AsByteArray(int32, bool)â:
/opt/trinity2/TrinityCore/src/server/shared/Cryptography/BigNumber.cpp:189:43: error: no matching function for call to âACE_Auto_Array_Ptr<unsigned char>::ACE_Auto_Array_Ptr(ACE_Auto_Array_Ptr<unsigned char>)â
/opt/trinity2/TrinityCore/src/server/shared/Cryptography/BigNumber.cpp:189:43: note: candidate is:
In file included from /usr/include/ace/Service_Gestalt.h:25:0,

 libace-6.0.3

 

It is a debian 7 Server.

 

I hope you can help me.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
       
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
       
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
×
×
  • Create New...