Jump to content

Recommended Posts

No patches, nothing fancy. I ran "hg pull" then "hg update." I run "hg summary," which tells me "parent: 10868:2279a6653bea tip"

I use this command for cmake:

cmake ../ -GXcode \

-DMYSQL_ADD_INCLUDE_PATH=/usr/local/mysql \

-DREADLINE_INCLUDE_DIR=/opt/local/include \

-DREADLINE_LIBRARY=/opt/local/lib/libreadline.dylib \

-DACE_INCLUDE_DIR=/opt/local/include \

-DACE_LIBRARY=/opt/local/lib/libACE.a \

-DPREFIX=/opt/trinitycore \

and then open the xcode solution and type command-B to compile. After a few minutes we've got an error: File:
Line 101:
sLog->outString("%s (realm-daemon)", _FULLVERSION);
expected `)' before 'Debug'

I suspect this might be the dreaded gd3 bug... I know someone on the gd3 should fix this "soon" , but until then is there something I can hack together that will make TC compile? I love this project, and I want to keep using it...

Link to comment
Share on other sites

compile trinity on mandriva 2009.0, gcc 4.3.2

have error

CMakeFiles/authserver.dir/Realms/RealmList.cpp.o: In function `RealmList::UpdateRealms(bool)':

RealmList.cpp:(.text+0xfb5): undefined reference to `__sync_fetch_and_sub_4'

I know that can be solved by cpp flag -march=i686


cmake ../ -DCMAKE_C_FLAGS="-O3 -pipe" -DCMAKE_CXX_FLAGS="${CMAKE_C_FLAGS} -march=i686" -DDO_RA=1 -DLARGE_CELL=1 -DPREFIX=~/release

but that is not working

Link to comment
Share on other sites

I assume the hack for this is still on the wiki in the mac install guide.

I'll take a look. I also missed the part where the repo switched over to git. I switched over and am now on commit 8d59953f9372c6876e0cd8078b44de6893082cbe. (How do I get the version number from git? I think this commit is version 11009, but I'm not 100% sure).

Interestingly, my build still fails, but I get a different error:


Undefined symbols:

  "_Gestalt", referenced from:

      G3D::System::init()    in libg3dlib.a(System.o)

      G3D::System::init()    in libg3dlib.a(System.o)

     (maybe you meant: typeinfo name for ACE_Intrusive_Auto_Ptr<ACE_Service_Gestalt>, 

ld: symbol(s) not found

collect2: ld returned 1 exit status

This is definitely the dreaded G3D bug. I'll try applying my trusty mac patch now, and see if it builds.
diff -r cbe929b901f8 dep/g3dlite/include/G3D/platform.h

--- a/dep/g3dlite/include/G3D/platform.h	Wed Aug 25 23:21:53 2010 +0300

+++ b/dep/g3dlite/include/G3D/platform.h	Thu Aug 26 02:14:42 2010 +0200

@@ -51,7 +51,7 @@

 #elif defined(__linux__)

     #define G3D_LINUX

 #elif defined(__APPLE__)

-    #define G3D_OSX

+    #define G3D_LINUX

Link to comment
Share on other sites


I have the following problem when compiling the core ( The logs is in the attachement of the topic )

The results of this solution are 13 corrects 2 failed etc etc.

The failed are the Authserver and worldserver

I use Win7/x32, OpenSSL 1.0.0c, Cmake 2.6, GIT installed, Net 4.0, Visual 2009

Hopefully someone can help me .. thank you very much

PD: Sorry for my english



Edited by Spring
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
    • By 939h

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
  • Create New...