Jump to content

Recommended Posts

hello, i have the following error:

/opt/trinity2/TrinityCore/src/server/shared/Cryptography/BigNumber.cpp: In member function âACE_Auto_Array_Ptr<unsigned char> BigNumber::AsByteArray(int32, bool)â:
/opt/trinity2/TrinityCore/src/server/shared/Cryptography/BigNumber.cpp:189:43: error: no matching function for call to âACE_Auto_Array_Ptr<unsigned char>::ACE_Auto_Array_Ptr(ACE_Auto_Array_Ptr<unsigned char>)â
/opt/trinity2/TrinityCore/src/server/shared/Cryptography/BigNumber.cpp:189:43: note: candidate is:
In file included from /usr/include/ace/Service_Gestalt.h:25:0,



It is a debian 7 Server.


I hope you can help me.

Update OpenSSL to 1.0 or newer

Link to comment
Share on other sites



I don't compile TrinityCore.

Last rev.


Debian 6.



[  8%] /root/avakecore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:34: error: variable or field ‘threadIdCallback’ declared void
/root/trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:34: error: ‘CRYPTO_THREADID’ was not declared in this scope
/root/trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:34: error: ‘id’ was not declared in this scope
/root/trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp: In function ‘void OpenSSLCrypto::threadsSetup()’:
/root/trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:46: error: ‘threadIdCallback’ was not declared in this scope
/root/trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:46: error: ‘CRYPTO_THREADID_set_callback’ was not declared in this scope
/root/trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp: In function ‘void OpenSSLCrypto::threadsCleanup()’:
/root/trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:53: error: ‘CRYPTO_THREADID_set_callback’ was not declared in this scope

Please, help me(

Edited by Neket007
Link to comment
Share on other sites

well I guess you still have some thing messed up .


cmake  in the errors you were posting can not find the build , also visual c++  complains about this


I would suggest scrapping all and restarting , read the wiki twice maybe even three times , you made your compile difficult for your self as you are using two  

different hard drives with the directory's . would hazard a guess C: has the visual C++ and cmake on it and your build and source are on D:


if you are new to this project I would suggest sticking to the wiki and not adding complications like extra directory's

  • Upvote 1
Link to comment
Share on other sites

Hello everybody,


I have this error while compiling :

[  9%] Building CXX object src/server/shared/CMakeFiles/sharedPCH.cpp_dephelp.di r/PrecompiledHeaders/sharedPCH.cpp.o
Linking CXX shared module libsharedPCH.cpp_dephelp.so
[  9%] Built target sharedPCH.cpp_dephelp
Scanning dependencies of target generate_sharedPCH.cpp
[  9%] Generating sharedPCH.h.gch
[  9%] Built target generate_sharedPCH.cpp
Scanning dependencies of target shared
[  9%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Configuration /Config.cpp.o

c++: internal compiler error: segmentation fault (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.

make[2]: *** [src/server/shared/CMakeFiles/shared.dir/Configuration/Config.cpp.o ] Error 4
make[1]: *** [src/server/shared/CMakeFiles/shared.dir/all] Error 2
make: *** [all] Error 2




Ace Version is 6.0.3

Openssl Version is  1.0.1e

System is: Linux Debian 7  64 bits

Gcc Version: (Debian 4.7.2-5) 4.7.2



Thank you for your help.

Edited by Ins4n3
Link to comment
Share on other sites

Same error on Ubuntu 13 64bits, gcc 4.7.3, Ace 6.03, OpenSSL 1.0.1c

Trying in Ubuntu 12 64 bits, gcc 4.7.2, Ace 6.03, OpenSSL 1.0.1c, same error

Trying in Ubuntu 13 64 bits , gcc 4.8,1, Ace 6.03, OpenSSL 1.0.1c, same error

Trying in Debian 6 64 bits, gcc 4.6.3, Ace 5.7.8, OpenSSL 1.0.0, same error


Any idea, the error is this:

Linking CXX static library libg3dlib.a
[ 10%] Built target g3dlib
[ 10%] Generating worldPCH.h.gch
[ 11%] Built target generate_authPCH.cpp
[ 11%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Configuration/Config.cpp.o

c++: error interno del compilador: Violación de segmento (programa cc1plus)
Por favor envíe un reporte completo de bichos,
con el código preprocesado si es apropiado.

make[2]: *** [src/server/shared/CMakeFiles/shared.dir/Configuration/Config.cpp.o] Error 4
make[1]: *** [src/server/shared/CMakeFiles/shared.dir/all] Error 2
make[1]: *** Se espera a que terminen otras tareas....
[ 11%] Built target generate_worldPCH.cpp
[ 11%] Built target generate_gamePCH.cpp
[ 11%] Built target generate_ScriptPCH.cpp
make: *** [all] Error 2

more info:


if compile using flag -DUSE_COREPCH=0 the server continu compiling until this error.


[ 32%] Built target collision
[ 33%] Built target authserver
[ 33%] Built target ScriptPCH.cpp_dephelp
[ 34%] Built target generate_ScriptPCH.cpp
[ 34%] Building CXX object src/server/scripts/CMakeFiles/scripts.dir/Spells/spell_shaman.cpp.o

c++: internal compiler error: segmentation fault (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.

make[2]: *** [src/server/scripts/CMakeFiles/scripts.dir/Spells/spell_shaman.cpp.o] Error 4
make[1]: *** [src/server/scripts/CMakeFiles/scripts.dir/all] Error 2
make: *** [all] Error 2


Edited by magoxxx
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
    • By 939h

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
  • Create New...