Jump to content
TrinityCore

Recommended Posts

We will get mingw working -- that is one of the major points of using Cmake .. so that we can support pretty much any compiler out there.

I will help you get it working, just keep posting errors.

We may have to add some compiler specific settings though (look in cmake/compiler/* for examples).

-- Brian

Link to comment
Share on other sites

Hi, what i have to do for when i compile i can view the revision typing server info, actually i only see trinitycore revision: 0!!

i compile the core with visual c++ 2008 express edition, generating the solution with cmake. and i download the core from the actually repository (githug.com/trinitycore/trinitycore)

i've installed mysql (last version) complete and openssl (last version)

Link to comment
Share on other sites

I've been going over the Windows install instructions on the wiki and slowly transforming it into easier, generalized, step-by-step instructions that will reduce the need to update it as frequently. I came to the Compiling the Extractors section and I noticed the information there is outdated. There are no longer .sln's for anything but the main project. I also noticed that the main project already compiles mapextractor.exe, vmap3assembler.exe, and vmap3extractor.exe in the same folder beside the worldserver/authserver.

My question is, because these map tools appear to be the "final" version based on the commit made in July last year, is it true that there is no longer any need for new users to download or compile these extractors, and can simply use the ones provided in the build\bin\Release folder?

If so, I'll update that section of the wiki to reflect these changes.

Link to comment
Share on other sites

I did everything the Wiki has directed me to do, and made sure i downloaded the full MySQL package, and when i compile, i get this.

Please and thank you for any help you can give me. :)

1>------ Build started: Project: ZERO_CHECK, Configuration: Release Win32 ------

1>  Checking Build System

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/dep/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/dep/acelite/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/dep/acelite/ace/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/dep/mysqllite/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/dep/bzip2/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/dep/zlib/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/dep/g3dlite/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/dep/gsoap/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/src/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/src/genrev/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/src/server/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/src/server/shared/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/src/server/game/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/src/server/collision/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/src/server/authserver/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/src/server/scripts/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/src/server/worldserver/CMakeFiles/generate.stamp is up-to-date.

1>  CMake does not need to re-run because C:/Users/Dad/Desktop/Build/sql/CMakeFiles/generate.stamp is up-to-date.

2>------ Build started: Project: zlib, Configuration: Release Win32 ------

3>------ Build started: Project: ace, Configuration: Release Win32 ------

4>------ Build started: Project: revision.h, Configuration: Release Win32 ------

5>------ Build started: Project: gsoap, Configuration: Release Win32 ------

3>  Building Custom Rule C:/Trinity/dep/acelite/ace/CMakeLists.txt

2>  Building Custom Rule C:/Trinity/dep/zlib/CMakeLists.txt

3>  CMake does not need to re-run because C:\Users\Dad\Desktop\Build\dep\acelite\ace\CMakeFiles\generate.stamp is up-to-date.

2>  CMake does not need to re-run because C:\Users\Dad\Desktop\Build\dep\zlib\CMakeFiles\generate.stamp is up-to-date.

4>  

4>  

4>  -- WARNING - Missing or outdated git - did you forget to install a recent version?

4>  -- WARNING - Observe that for revision ID/hash to work you need at least version 1.7

4>  -- WARNING - Continuing anyway, but setting the revision-ID and hash to Rev:0 Hash: Archive








6>c:\trinity\src\server\game\calendar\CalendarMgr.h(37): error C2065: 'itemId' : undeclared identifier

6>c:\trinity\src\server\game\calendar\CalendarMgr.h(39): error C2440: 'return' : cannot convert from 'const CalendarInvite *' to 'CalendarInvite *'

6>          Conversion loses qualifiers

6>c:\trinity\src\server\game\calendar\CalendarMgr.h(50): error C2440: 'return' : cannot convert from 'const CalendarEvent *' to 'CalendarEvent *'

6>          Conversion loses qualifiers

6>..\..\..\..\..\..\..\Trinity\src\server\game\Calendar\CalendarMgr.cpp(38): error C3861: 'GetGUID': identifier not found

6>..\..\..\..\..\..\..\Trinity\src\server\game\Calendar\CalendarMgr.cpp(62): error C3861: 'GetGUID': identifier not found

6>..\..\..\..\..\..\..\Trinity\src\server\game\Calendar\CalendarMgr.cpp(64): error C2039: 'event_id' : is not a member of 'CalendarInvite'

6>          c:\trinity\src\server\game\calendar\Calendar.h(62) : see declaration of 'CalendarInvite'

6>..\..\..\..\..\..\..\Trinity\src\server\game\Calendar\CalendarMgr.cpp(66): error C2039: 'event_id' : is not a member of 'CalendarInvite'

6>          c:\trinity\src\server\game\calendar\Calendar.h(62) : see declaration of 'CalendarInvite'

6>..\..\..\..\..\..\..\Trinity\src\server\game\Calendar\CalendarMgr.cpp(74): error C2039: 'event_id' : is not a member of 'CalendarInvite'

6>          c:\trinity\src\server\game\calendar\Calendar.h(62) : see declaration of 'CalendarInvite'







13>LINK : fatal error LNK1181: cannot open input file '..\game\Release\game.lib'

15>------ Build started: Project: ALL_BUILD, Configuration: Release Win32 ------

15>  Building Custom Rule C:/Trinity/CMakeLists.txt

15>  CMake does not need to re-run because C:\Users\Dad\Desktop\Build\CMakeFiles\generate.stamp is up-to-date.

========== Build: 13 succeeded, 2 failed, 0 up-to-date, 0 skipped ==========

Edited by detour
Link to comment
Share on other sites

I did everything the Wiki has directed me to do, and made sure i downloaded the full MySQL package, and when i compile, i get this.

Please and thank you for any help you can give me. :)

14>LINK : fatal error LNK1181: cannot open input file '..\game\Release\game.lib'

15>------ Build started: Project: ALL_BUILD, Configuration: Release Win32 ------

15>  Building Custom Rule C:/Trinity/CMakeLists.txt

15>  CMake does not need to re-run because C:\Users\Dad\Desktop\Build\CMakeFiles\generate.stamp is up-to-date.

========== Build: 13 succeeded, 2 failed, 0 up-to-date, 0 skipped ==========

from this we can see only that 2 projects failed and 1 of them was game project...

... copy errors or full output here

Link to comment
Share on other sites

I would like to thank you three for your help. I solved the issue by doing the following;

In GIT install, i switched from "Use Git Bash only" to "Run Git from the Windows Command Prompt"

Changing the Branch from Calendar to Master.

Edited by detour
Link to comment
Share on other sites

I was trying to update tirnitycore version, i got some compilations errors:

cmake ../../TrinityCore -DPREFIX=/home/desarrollo

make -j 8

Scanning dependencies of target revision.h

Scanning dependencies of target shared_pch_dephelp

Scanning dependencies of target game_pch_dephelp

Scanning dependencies of target jemalloc

Scanning dependencies of target collision_pch_dephelp

Scanning dependencies of target gsoap

Scanning dependencies of target g3dlib

Scanning dependencies of target authserver_pch_dephelp

[  1%] [  1%] [  1%] [  2%] [  2%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/extent.c.o

Building CXX object dep/gsoap/CMakeFiles/gsoap.dir/soapC.cpp.o

Building CXX object src/server/collision/CMakeFiles/collision_pch_dephelp.dir/collision_pch_dephelp.cxx.o

Building CXX object src/server/shared/CMakeFiles/shared_pch_dephelp.dir/shared_pch_dephelp.cxx.o

[  2%] [  2%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/AABox.cpp.o

Building CXX object src/server/game/CMakeFiles/game_pch_dephelp.dir/game_pch_dephelp.cxx.o

Building CXX object src/server/authserver/CMakeFiles/authserver_pch_dephelp.dir/authserver_pch_dephelp.cxx.o

[  2%] Built target revision.h

[  2%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/huge.c.o

[  2%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/chunk_dss.c.o

[  2%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/mutex.c.o

[  2%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/ckh.c.o

[  2%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/chunk_mmap.c.o

Linking CXX static library libcollision_pch_dephelp.a

[  2%] Building CXX object dep/gsoap/CMakeFiles/gsoap.dir/stdsoap2.cpp.o

[  2%] Built target collision_pch_dephelp

[  2%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Any.cpp.o

[  2%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/chunk_swap.c.o

Linking CXX static library libshared_pch_dephelp.a

[  2%] Building CXX object dep/gsoap/CMakeFiles/gsoap.dir/soapServer.cpp.o

[  2%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/base.c.o

[  2%] Built target shared_pch_dephelp

[  2%] [  3%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/BinaryFormat.cpp.o

Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/stats.c.o

Scanning dependencies of target scripts_pch_dephelp

Linking CXX static library libauthserver_pch_dephelp.a

[  4%] Scanning dependencies of target worldserver_pch_dephelp

Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/BinaryInput.cpp.o

[  4%] Built target authserver_pch_dephelp

Scanning dependencies of target pch_Generate_shared

[  4%] Generating sharedPCH.h

[  4%] [  5%] [  5%] Building CXX object src/server/worldserver/CMakeFiles/worldserver_pch_dephelp.dir/worldserver_pch_dephelp.cxx.o

Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/ctl.c.o

[  5%] Generating sharedPCH.h.gch/shared_Release.gch

Building CXX object src/server/scripts/CMakeFiles/scripts_pch_dephelp.dir/scripts_pch_dephelp.cxx.o

[  5%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/arena.c.o

Linking CXX static library libworldserver_pch_dephelp.a

[  5%] Built target worldserver_pch_dephelp

[  5%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/BinaryOutput.cpp.o

[  5%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/jemalloc.c.o

[  5%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Box.cpp.o

[  5%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/chunk.c.o

In file included from /home/desarrollo/TrinityCore/src/server/scripts/PrecompiledHeaders/ScriptPCH.h:8,

                 from /home/desarrollo/TrinityCore/build/src/server/scripts/scripts_pch_dephelp.cxx:1:

/home/desarrollo/TrinityCore/src/server/game/Scripting/ScriptMgr.h: In static member function 'static void ScriptMgr::ScriptRegistry<TScript>::AddScript(TScript*)':

/home/desarrollo/TrinityCore/src/server/game/Scripting/ScriptMgr.h:1010: error: 'sObjectMgr' was not declared in this scope

[  5%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/tcache.c.o

[  5%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/prof.c.o

[  5%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/rtree.c.o

Linking CXX static library libgame_pch_dephelp.a

[  5%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/hash.c.o

[  5%] Built target pch_Generate_shared

[  5%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Capsule.cpp.o

[  6%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/mb.c.o

Linking C static library libjemalloc.a

Scanning dependencies of target pch_Generate_collision

[  6%] Generating collisionPCH.h

[  6%] Generating collisionPCH.h.gch/collision_Release.gch

[  6%] Built target game_pch_dephelp

[  6%] [  6%] Built target jemalloc

Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/CollisionDetection.cpp.o

[  6%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/CoordinateFrame.cpp.o

Scanning dependencies of target pch_Generate_worldserver

[  6%] Generating worldPCH.h

[  6%] Scanning dependencies of target pch_Generate_authserver

Generating worldPCH.h.gch/worldserver_Release.gch

[  6%] Generating authPCH.h

[  6%] Generating authPCH.h.gch/authserver_Release.gch

[  6%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Crypto.cpp.o

[  6%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Cylinder.cpp.o

[  6%] Built target pch_Generate_collision

[  7%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/debugAssert.cpp.o

Scanning dependencies of target shared

Scanning dependencies of target pch_Generate_game

[  7%] Generating gamePCH.h

[  7%] Generating gamePCH.h.gch/game_Release.gch

make[2]: *** [src/server/scripts/CMakeFiles/scripts_pch_dephelp.dir/scripts_pch_dephelp.cxx.o] Error 1

make[1]: *** [src/server/scripts/CMakeFiles/scripts_pch_dephelp.dir/all] Error 2

make[1]: *** Waiting for unfinished jobs....

[  7%] [  7%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/FileSystem.cpp.o

Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/fileutils.cpp.o

[  7%] Built target pch_Generate_worldserver

[  7%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/format.cpp.o

[  8%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Configuration/Config.cpp.o

[  8%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/g3dfnmatch.cpp.o

[  8%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/g3dmath.cpp.o

[  8%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Line.cpp.o

[  8%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Cryptography/SHA1.cpp.o

[  8%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Cryptography/Authentication/AuthCrypt.cpp.o

[  8%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/LineSegment.cpp.o

[  8%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Cryptography/HMACSHA1.cpp.o

[  8%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Log.cpp.o

[  8%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Cryptography/BigNumber.cpp.o

[  9%] [  9%] Built target pch_Generate_authserver

[  9%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Matrix3.cpp.o

Building CXX object src/server/shared/CMakeFiles/shared.dir/Cryptography/ARC4.cpp.o

[  9%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/MySQLConnection.cpp.o

[  9%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Matrix4.cpp.o

[  9%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/DatabaseWorker.cpp.o

[  9%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/MemoryManager.cpp.o

[  9%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/PhysicsFrame.cpp.o

Linking CXX static library libgsoap.a

[  9%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/QueryHolder.cpp.o

[ 10%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/Transaction.cpp.o

[ 10%] Built target gsoap

[ 10%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Plane.cpp.o

[ 10%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/prompt.cpp.o

[ 10%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/Field.cpp.o

[ 10%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/Implementation/CharacterDatabase.cpp.o

[ 10%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/Implementation/LoginDatabase.cpp.o

[ 10%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Quat.cpp.o

[ 10%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Random.cpp.o

[ 10%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/Implementation/WorldDatabase.cpp.o

[ 11%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Ray.cpp.o

[ 11%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/ReferenceCount.cpp.o

[ 11%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/QueryResult.cpp.o

[ 11%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/RegistryUtil.cpp.o

[ 11%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Sphere.cpp.o

[ 11%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/stringutils.cpp.o

[ 11%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/SQLStorage.cpp.o

[ 11%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/AdhocStatement.cpp.o

[ 11%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/System.cpp.o

[ 12%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/PreparedStatement.cpp.o

[ 12%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/TextInput.cpp.o

[ 12%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/TextOutput.cpp.o

[ 12%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Triangle.cpp.o

[ 13%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/uint128.cpp.o

[ 13%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Vector2.cpp.o

[ 13%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/UprightFrame.cpp.o

[ 13%] Building CXX object src/server/shared/CMakeFiles/shared.dir/DataStores/DBCFileLoader.cpp.o

[ 13%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Logging/Log.cpp.o

[ 13%] Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Vector3.cpp.o

[ 13%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Threading/Threading.cpp.o

[ 13%] [ 13%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Threading/DelayExecutor.cpp.o

Building CXX object dep/g3dlite/CMakeFiles/g3dlib.dir/source/Vector4.cpp.o

[ 13%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Utilities/EventProcessor.cpp.o

[ 13%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Utilities/Util.cpp.o

[ 13%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Utilities/ServiceWin32.cpp.o

[ 13%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Common.cpp.o

[ 13%] Built target pch_Generate_game

Linking CXX static library libshared.a

Linking CXX static library libg3dlib.a

[ 13%] [ 13%] Built target shared

Built target g3dlib

make: *** [all] Error 2

Just using normal libraries i didnt have any problem compiling before.

Thank you very much for help

PD: Also make a ticket on bug tracker but it says about runtime errors and any about compilations errors, i'm not sure if is about me or about trinity. Thanks and I'm sorry if wrong section.

Edited by academo
Link to comment
Share on other sites

Hey guys, i recently posted about cmake but now im haveing a new problem. After compileing the core and such I can't run the server at all. Both server programs state that there non win32 programs and crash instantly. Also while recompileing to fix this error my computer just crashes out of no where. I have never had this happen before and wondering if anyone else has had this problem other then me. If so how do I fix this? Cmake makes the compile files just fine and it compiles but does give off errors. I hope someone can help me =/.

::EDIT::

Heres a list of errors thats going on after compile

1>------ Build started: Project: revision.h, Configuration: Release Win32 ------

1>Build log was saved at "file://c:\Users\Steven\Desktop\Trinity\Build\src\genrev\revision.h.dir\Release\BuildLog.htm"

1>revision.h - 0 error(s), 0 warning(s)

2>------ Build started: Project: authserver, Configuration: Release Win32 ------

3>------ Build started: Project: worldserver, Configuration: Release Win32 ------

2>Linking...

3>Linking...

2>   Creating library C:\Users\Steven\Desktop\Trinity\Build\src\server\authserver\Release\authserver.lib and object C:\Users\Steven\Desktop\Trinity\Build\src\server\authserver\Release\authserver.exp

2>LINK : fatal error LNK1104: cannot open file 'C:\Users\Steven\Desktop\Trinity\Build\src\server\authserver\Release\authserver.lib'

2>Build log was saved at "file://c:\Users\Steven\Desktop\Trinity\Build\src\server\authserver\authserver.dir\Release\BuildLog.htm"

2>authserver - 1 error(s), 0 warning(s)

3>   Creating library C:\Users\Steven\Desktop\Trinity\Build\src\server\worldserver\Release\worldserver.lib and object C:\Users\Steven\Desktop\Trinity\Build\src\server\worldserver\Release\worldserver.exp

3>LINK : fatal error LNK1104: cannot open file 'C:\Users\Steven\Desktop\Trinity\Build\src\server\worldserver\Release\worldserver.lib'

3>Build log was saved at "file://c:\Users\Steven\Desktop\Trinity\Build\src\server\worldserver\worldserver.dir\Release\BuildLog.htm"

3>worldserver - 1 error(s), 0 warning(s)

4>------ Skipped Build: Project: INSTALL, Configuration: Release Win32 ------

4>Project not selected to build for this solution configuration 

========== Build: 1 succeeded, 2 failed, 16 up-to-date, 1 skipped ==========

Edited by Mellic
Link to comment
Share on other sites

Received a failure while compiling.

18>  WheatyExceptionReport.cpp

18>LINK : fatal error LNK1181: cannot open input file '..\..\..\dep\mysqllite\Release\libmysql.lib'

19>------ Build started: Project: ALL_BUILD, Configuration: Release Win32 ------

19>  Building Custom Rule C:/Trinity/CMakeLists.txt

19>  CMake does not need to re-run because C:\Build\CMakeFiles\generate.stamp is up-to-date.

========== Build: 13 succeeded, 6 failed, 0 up-to-date, 0 skipped ==========

I noticed another post about installing MySQL using the "Complete" option, and this didn't fix it.

Any suggestions?

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
       
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
       
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
×
×
  • Create New...