Jump to content
TrinityCore
bbgun21

Executables won't run properly ?

Recommended Posts

Hey everyone.

I've got a problem concerning my compiled executable files not running properly.

These are:
-Authserver.exe
-Worldserver.exe
-mapextractor.exe
-mmaps_generator.exe
-vmap4extractor.exe
-vmap4assembler.exe

After running any of these files none of them open properly.

What I mean by this is that when I double-click on a file, nothing happens, there is no window popup or anything for me to see.

What I do see however is in my Task Manager processes of these files being there (2 or 3 from just one opening) that can't be terminated and these processes now block me from trying again launching the applications without restarting my PC.

I've noticed that after I recompile the my things again through Visual Studio that the .exe files work once or twice (I tested only Authserver and Worldserver and they opened normally and were running normally), but after a few time same problem is there (the above mentioned one).

I don't know is this because I'm trying to compile it in x64 bit, because when I try x32 bit, errors appear because MySQL is x64 bit.

Thanks in forward.

 

EDIT: I followed everything by the letter in the guide(s) here:

https://trinitycore.atlassian.net/wiki/display/tc/Requirements

 

EDIT 2:

My PC:

CPU: i5 2500K @ 4.5Ghz

GPU: GTX 980 Ti

SSD: Samsung 850 EVO

RAM: Patriot 8GB (2x4GB) 1600 MHz

Edited by bbgun21

Share this post


Link to post
Share on other sites

There are a few AntiVirus software packages that will lock the TrinityCore exeutables in a sandbox of some kind, but never let them out again because they trigger some kind of heurisitics in the AV software package. I can only suggest that you try without AV software installed, because I haven't seen that problem myself, neither on Windows 7 nor Windows 10.

Edited by tkrokli

Share this post


Link to post
Share on other sites

What happens if you start the executables from the command line console?

Share this post


Link to post
Share on other sites

On those requirements, did you happen to do any of the optional part (namely the first optional item)? Meaning, do you have the appropriate redist package for the Visual Studio version you're running? You say other, already compiled versions do the same thing, suggesting a missing/bad DLL file is involved. Reinstallation of the compiler and the appropriate redist package(s) would be my first suggestion. Does anything else behave wrong on your system?

Share this post


Link to post
Share on other sites

Well nothing is wrong on my system so maybe it is the compiler only, and no I did not do any of the optional steps as I already have the redistributable packages , but I will try to reinstall and post the results again, thanks for the suggestion Kylroi.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
    • By Fyury
      When I run "worldserver.exe" it just crashes and I get this:
      TrinityCore rev. 084da48ba15a 2018-05-26 18:48:09 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
      <Ctrl-C> to stop.
       ______                       __
      /\__  _\       __          __/\ \__
      \/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
         \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
          \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
           \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
            \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                       C O R E  /\___/
      http://TrinityCore.org                    \/__/
      Using configuration file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf.
      Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.1e 11 Feb 2013)
      Using Boost version: 1.65.1
      Updating Auth database...
      >> Auth database is up-to-date! Containing 6 new and 115 archived updates.
      Updating Character database...
      >> Character database is up-to-date! Containing 3 new and 77 archived updates.
      Updating World database...
      >> World database is up-to-date! Containing 193 new and 2262 archived updates.
      Updating Hotfixes database...
      >> Hotfixes database is up-to-date! Containing 18 new and 130 archived updates.
      Realm running as realm ID 1
      Using World DB: TDB 735.00
      Using enUS DBC Locale
      Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
      Using DataDir ./
      WORLD: MMap data directory is: ./mmaps
      VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
      VMap data directory is: ./vmaps
      Missing name Guild.SaveInterval in config file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf, add "Guild.SaveInterval = 15" to this file
      Initialize PlayerDump...
      >> Initialized 370 PlayerDump ColumnDefinitions in 551 ms.
      Loading Trinity strings...
      >> Loaded 965 trinity strings in 32 ms
      Initialize data stores...
      Some required *.db2 files (2 from 230) not found or not compatible:
      ItemSearchName.db2
      WorldSafeLocs.db2
       
       
      ItemSearName.db2 & WorldSafeLocs.db2 dont exist but how can I get them
      When I start "mapextractor.exe" this happens:
       
      Unable to open file DBFilesClient\ItemSearchName.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\Unittest.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\WorldSafeLocs.db2 in the archive for locale enUS: FILE_NOT_FOUND
       
    • By Xzter
      Hello, before i was using trinity fine, everything working perfect. But now, im always getting the worldserver.exe crash.
      Here is log, if someone  can help me to fix it, please. Thanks

      Screenshoot where error always appear

      And, Error Log 
      b19413aaf21d_worldserver.exe_[22-4_11-51-42].txt
×
×
  • Create New...