Jump to content

[SOLVED]Client CAS System Problem


Recommended Posts

I was able to patch both my mac and windows clients successfully and push it back from my ubuntu server installation.  Now whenever I try to open the either patched client I get the following error.

The CAS system was unable to initialize: ClientHandler: initialization error: failed fetching the CDN configuration file

tact::ClientHandler::Create failed: E_NOT_AVAILABLE
[20160530T14:18:08] {70949} ERR: [R5kD:5] HTTP error; (/tpr/wow/config/a4/3d/a43dd04a6cb386038cdd094dfa44f1e4), ver=1.1, code=404
[20160530T14:18:08] {70949} INF: Got bad content response: i

Is there something I missed in the setup that should redirect away from that ip address?  I modified the bnetserver.conf and worldserver.conf on my server.  And modified the config.wtf file on the client to my lan server ip for the portal.

This appears to be a host that is serving the file.  Is this a file I need to serve on my wowserver?  Or am I suppose to edit my hosts file to redirect away from it?  The ip address resolves to blzddist1-a.akamaihd.net... not sure if that helps.

I also did a wireshark capture that shows a 404 response from the server telling me the file doesn't exist.  Can someone confirm that actually belongs to blzddist1-a.akamaihd.net... or is my isp doing something that is screwing something up and I need to hard code an entry in my hosts file.

And can anyone confirm they have gotten to load successfully?


Edited by Dipdill
Link to comment
Share on other sites

Got it working... The versi file hosted on the trinity6.github.io was giving me the wrong cdn hash.  I just added the file to my own web server with the correct hash from a wire shark capture I got from the unpatched client.  Not sure if my versi file needed is different due to patching a version downloaded from bnet.  When I get a chance I will upload a copy of it in case someone else comes across the same issue.

Link to comment
Share on other sites

here is the contents of my versi file


Link to comment
Share on other sites

This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Frik24
      Hello TrinityCore members,

      I wanted to mess around with 6.2.4a build 21742,
      I've downloaded/compiled the trinitycore TrinityCore-6.2.4-21742 from github

      I've got connection_patcher.exe among other files in my release build

      I've got client with same patch TrinityCore-6.2.4-21742

      I patched the client(all successful) with patcher i've got from compiling source.

      When i run WoW_Patched.exe i get error message https://imgur.com/a/ZZQI3J9
      can anyone help me i'd appreciate it a lot!
  • Create New...