Jump to content
TrinityCore
Aidoboy

[SOLVED]Fresh install worldserver error

Recommended Posts

Create the auth, characters and world db manually.

Import https://github.com/TrinityCore/TrinityCore/blob/3.3.5/sql/base/auth_database.sql to the auth DB.

Import https://github.com/TrinityCore/TrinityCore/blob/3.3.5/sql/base/characters_database.sql to the characters DB.

Import https://github.com/TrinityCore/TrinityCore/releases/tag/TDB335.61 to the world DB.

And then start worldserver normally. It should automatically apply the SQL updates it needs from now on.

P.S Trinity3?

  • Upvote 1

Share this post


Link to post
Share on other sites

The same thing happened to me over and over. Are you pulling your libmysql.dll from your MySQL/lib folder? 

Share this post


Link to post
Share on other sites
On 6/1/2016 at 10:09 AM, Nay said:

Create the auth, characters and world db manually.

Import https://github.com/TrinityCore/TrinityCore/blob/3.3.5/sql/base/auth_database.sql to the auth DB.

Import https://github.com/TrinityCore/TrinityCore/blob/3.3.5/sql/base/characters_database.sql to the characters DB.

Import https://github.com/TrinityCore/TrinityCore/releases/tag/TDB335.61 to the world DB.

And then start worldserver normally. It should automatically apply the SQL updates it needs from now on.

P.S Trinity3?

Woohoo, that worked! I didn't realize I needed to make them manually.

Share this post


Link to post
Share on other sites

It isn't supposed for you to create them manually but there's a bug somewhere that doesn't let mysql create the databases or import big-ish files.

Manually importing those files is just a workaround until we find the cause of the problem.

Share this post


Link to post
Share on other sites
21 hours ago, Nay said:

It isn't supposed for you to create them manually but there's a bug somewhere that doesn't let mysql create the databases or import big-ish files.

Manually importing those files is just a workaround until we find the cause of the problem.

Ah, ok.

20 hours ago, Aokromes said:

I didn't import either, but it seems to be working now.

 

Also on a unrelated not, should the death knight initiates in the starting area be attacking the scarlet crusaders? They just seem to walk around nonchalantly.

Edited by Aidoboy

Share this post


Link to post
Share on other sites

--- Canned message start --- It appears the issue in the original post was solved, so this thread shall be closed. Should you encounter any other difficulties, please open a new thread. --- Canned message end ---

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By leandrod
      Hello guys,
      I was wondering that would be nice if i can active the flying mounts in Azeroth allowing the players to use it in Orgrimmar for example.
      So, here's my question: is there any way to do that in the server core side? I know that the game doesnt support flying mounts in Azeroth in the retail but i would like to do it (if its possible).
      I've serched in the forum for it and didn't find anything about it.
      Thanks for the help!
    • By Billy
      Placed several items in the AH today with the 24 hour setting to check with, restarted both world and auth servers, and the items placed in AH were no longer there, nor was there any mail for items sold or returned.
      TrinityCore rev. 59682bbd9b33 2019-02-09 21:06:09 +0100 (3.3.5 branch) (Unix, RelWithDebInfo, Static) (worldserver-daemon)
       
    • By kepo
      I made 2 realms, one for 2.4.3, one for 3.3.5 but for some reason when I try to connect to the 3.3.5 realm I'm getting this error in the cosole: 
      WorldSocket::HandleAuthSession: Client *my home pc's ip is here* requested connecting with realm id 22 but this realm has id 2 set in config. I also get this in-game: 
      The game server you have chosen is currently down. Use the Change Realm button to choose another Realm. The Auth.exe that I use is by OregonCore 2.4.3 for both, but Oregon is 50-60% TrinityCore. When I use the auth.exe by TrinityCore the same problem occurs in the 2.4.3 realm but the 3.3.5 starts working. I don't have any other errors like DB & etc. That's the only problem. 
      I checked the DB auth > realmist and everything looks fine. Here's a picture: http://prntscr.com/mhpbmr
      I have also opened all the needed ports.
      Also - worldconfig for 3.3.5:
      LoginDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;auth" WorldDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;world2" CharacterDatabaseInfo = "127.0.0.1;3306;mysql user;mysql pass;characters2" RealmID = 2 WorldServerPort = 8086 and for 2.4.3
      LoginDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;auth" WorldDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;world" CharacterDatabaseInfo = "127.0.0.1;3306;mysql user;mysql pass;characters" RealmID = 1 WorldServerPort = 8085 Also I checked the AuthSocket.cpp and realmlist.cpp, it looks like there is a code or whatever is called for 3.3.5:
      AuthSocket.cpp
          case 8606:                                          // 2.4.3     case 10505:                                         // 3.2.2a     case 11159:                                         // 3.3.0a     case 11403:                                         // 3.3.2     case 11723:                                         // 3.3.3a     case 12340:                                         // 3.3.5a realmlist.cpp
      static RealmBuildInfo ExpectedRealmdClientBuilds[] = {     {12340, 3, 3, 5, 'a'},                                  // highest supported build, also auto accept all above for simplify future supported builds testing     {11723, 3, 3, 3, 'a'},     {11403, 3, 3, 2, ' '},     {11159, 3, 3, 0, 'a'},     {10505, 3, 2, 2, 'a'},     {8606,  2, 4, 3, ' '},     {6005,  1,12, 2, ' '},     {5875,  1,12, 1, ' '},     {0,     0, 0, 0, ' '}                                   // terminator }; My account's gmlevel in account_access is set to '3' and 'RealmID: is 2', since the max rank level in 2.4.3 (RealmID: 1) is '5'.
      Oh, almost forgot... I modified accounts table, also fusioncms recognize the realm: http://prntscr.com/mhpf3f // trinity is fresh-compiled soo... it's latest version, oregon is 2017 rev since we did tons of custom changes (it's fun server) but hey.. oregon is ded - latest rev is 1 year ago. ;c
    • By Billy
      I just pulled an update this morning and done the compile works, but when I started the worldserver up I got these messages immediately after the server booted up.
      Anybody know what this might mean?

    • By Billy
      Players are logging off while at one location, but when they re-login their character is not where it was when they log off.
      Has happened to me as well. Was in the rest area in Astranaar, went to log back in and was at the Flight master at Astranaar instead.
      When this happens, the rest state does not properly shutdown. Have to go back into the rest area then leave before it shuts down the rest state. In other words, I can run all over the place, go into combat and finish, and still be gaining rest state.
      Edit:
      Forgot to add rev of core...sry.
      TrinityCore rev. 41982aa30026 2018-08-12 14:17:26 +0200 (3.3.5 branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
×
×
  • Create New...