Jump to content

[6.X] Dreanor Spawns & Sniffer Questions


Recommended Posts

(sorry for bad english)
i was trying out the 6.X Core and there was no Spawns in Dreanor.
So i want to Sniff them from Live and add them my Self. If i manage to get it to work i will share my Work.

I need some help.
Im complete new to sniffing/parsing. And the last time i was setting up a Privatserver is some years ago.
Some month ago i made my degree in Software dev. so i got "some" C# & SQL knowledge.

Im compiling the Core and Parser myself.

My sniffing attemps
I was walking around in Dreanor/Gorgrond for testing to get some spawns.
I got a 2MB .pkt Package and try to parse the creatures and i got some data out that looks not correct to me.

- The names of the creatures not working, looks like some utf-8 problem.
- The data dont look correct, and dont match the TDB tables. for example:
[...] modelid1=32784, modelid2=117440512, name='�', rank=1852130080, family=1851877746, type=1866932324 [...]

The parsed SQL is producing errors like this:
Out of range value for column 'modelid2' at row 1
Out of range value for column 'rank' at row 1
Out of range value for column 'family' at row 1

Can you help me getting this to work?

See attachments.

- FreddyLIE




Edited by FreddyLIE
add more Tags
Link to comment
Share on other sites

Question is what is your computers default input output language?
This MIGHT be your conflict as your char set may be different and could render SQL improperly
Also you also may want to check your charset on your db and make sure it is utf8

This is all i can come up as to possible issues..
I hope this points you to the issue :-)  
Ill try to replicate the issue and if I can Ill know what your error is.
What is your native language so i can set my pc to it? and try to parse


Link to comment
Share on other sites

Thats a good point. I was thinking the same. But i Switches only the Game client language.

After i saw the column "name" with this weird UTF-8 stuff i switched my Game client to English. With the same output.
I tried with x64 and x32 client and with both x64 and x32 sniffer and i tried crossing them -> x64 client with x32 sniffer.
When i Open the SQL file with Notepad++ i tryed to convert the file to ANSI, UTF8, [..]
My Windows is German.
My WoW is English.
The Databases are in UTF-8.

Can a wrong charset/system language explain these big numbers in the columns "rank", "family", "type" ?
And what tables i need to config to "true" in the Packet Parser to get only the Spawns?
I dont want Quests, Items ... i just want to export the Creature spawns. All i get from the Parser is the Table "creature_template" is this the right table?

- FreddyLIE

Link to comment
Share on other sites

Little update.

I think it is my compiled Parser...
I downloaded the Release "Nightly build" from the bottom of this page:

And i put my Config in it. And now i get working results. The area i was sniffing is now Spawned.
Some of the NPC got waypoints and moving correct... not bad. Even the Flypoint NPC is working.

Now i got a other question
The "guid" column in the SQL file got these entries "@CGUID+0", "@CGUID+1", "@CGUID+2" [...].
How can i automatically fill this to match my DB after the last guid to count on?
For testing i replaced "@CGUID+" -> "5000".
The table "creature_template_addon" in the output is filled with "UNKNOWN" and gives me errors. What to do with this?

I put my SQL in the attachments
The spawns are in Gorgrond south. I walked from south Gorgrond "Beastwatch" to north to the Flypoint "Breaker's Crown, Gorgrond".
And the Fly point NPC at "Breaker's Crown, Gorgrond" is working :-)

- Freddy G.


Link to comment
Share on other sites

4 hours ago, FreddyLIE said:

Now i got a other question


The "guid" column in the SQL file got these entries "@CGUID+0", "@CGUID+1", "@CGUID+2" [...].
How can i automatically fill this to match my DB after the last guid to count on?
For testing i replaced "@CGUID+" -> "5000".
The table "creature_template_addon" in the output is filled with "UNKNOWN" and gives me errors. What to do with this?

Do you find any solution ?

Link to comment
Share on other sites

I got the  @CGUID thing to work.

This is a Variable, its need to be set at the beginning.
Look in your Database for the highest guid to set this Variable.
For example your highest guid is 5999999 you set "@CGUID" to 6000000...

At the top of the SQL file the variable need to be set for example like this:
SET @CGUID := 6000000;

With this line the other lines will be calculated automatically:
@CGUID+1 = 6000001
@CGUID+2 = 6000002
@CGUID+3 = 6000003

But there is a Problem/Bug
The apostrophes need to be removed in each line:

Change every line from this:
('@CGUID+0', 88999, 1116 ...
('@CGUID+1', 88999, 1116 ...
('@CGUID+2', 88999, 1116 ...
To this (no apostrophes around variable):
(@CGUID+0, 88999, 1116 ...
(@CGUID+1, 88999, 1116 ...
(@CGUID+2, 88999, 1116 ...

My Fixed Test-SQL file in attachments
(Some Spawns in south Gorgrond, see my last post)

- Freddy G.


  • Upvote 1
Link to comment
Share on other sites

  • 3 weeks later...
On 6/17/2016 at 11:44 AM, Expery said:

Yeah, what about "Hotfixes" ? how I can dump them ?

I will be watching also to see response as Hotfixes are a bit of an unknown for me


@FreddyLIE Sorry I was away to long to provide you help
But i see you got a bit of it sorted 
Ok yes SET @CGUID 12345  and SET @OGUID 12345  tell where to start with the batch into your creature and object tables Without this it would just write over what you have in your spawns 

Putting the guids up say 10000 past last spawn gives you room to work and apply new spawns from TC Generally this is what i do when testing a fix but i keep the sql so i can delete or remove so im back to a fresh TDB when things dont match up or cause more errors in logs

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Frik24
      Hello TrinityCore members,

      I wanted to mess around with 6.2.4a build 21742,
      I've downloaded/compiled the trinitycore TrinityCore-6.2.4-21742 from github

      I've got connection_patcher.exe among other files in my release build

      I've got client with same patch TrinityCore-6.2.4-21742

      I patched the client(all successful) with patcher i've got from compiling source.

      When i run WoW_Patched.exe i get error message https://imgur.com/a/ZZQI3J9
      can anyone help me i'd appreciate it a lot!
    • By darki73
      So i guess it is pretty obvious about what am i going to ask =)
      Problem is, previousle we could just sha1 username and password separated by colon and here is the sha_pass_hash.
      The problem i am facing right now, is that according to https://github.com/TrinityCore/TrinityCore/blob/86b98686a95e23247ecb774fb23ecd5b8d94b97b/src/server/game/Accounts/BattlenetAccountMgr.cpp#L177 Trinity now uses SHA256, so the hashes do not match anymore. The thing is, password length in database is 40 symbols (exactly as many as in sha1 hash), but sha256 hash length is 64 characters long. I am confused...
      I've tried to recreate whole "Cryptography" thing on PHP but, guess what, failed.
      Can somebody explain me how the password is generated nowadays?
      Thank you for your attention. 
    • By HolyNitzan
      Hey Guys,
      I'm  using the last build of TrinityCore for WoD, currently using latest TDB release, I noticed that there are no spawns in Draenor, I would like to konw how could I solve it? is the TDB not populated with Draenor mobs/npc spawns?
    • By Shinzon
      I have searched all over the forums and can't find anything that exactly matches this. 
      I can connect fine to the server using my windows client, but when I try to connect using my mac client it immediately bounces back stating "You have been disconnected from the server". 
      I have the correct IP address in the config.wtf (And realmlist in the DB) but still can't connect. 
      I of course can't apply the connection patcher, because the EXE isn't mac compatible. 
      Is there something else I need to do to connect with mac?
      Here is my connection.log if it helps (NOTE that the ".logon.battle.net" I can't get rid of... there is no where config.wtf that has that).
      3/14 13:10:21.966  Login program=WoW platform=Mc64 locale=enUS 3/14 13:10:22.097  Component WoW.Mc64.20886 3/14 13:10:22.097  Component WoW.base.20726 3/14 13:10:22.099  Battle.net is Component Bnet.Mc64.37165 3/14 13:10:22.099  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK  3/14 13:10:22.145  Failed to resolve “”.logon.battle.net 3/14 13:10:22.145  LOGIN: state: LOGIN_STATE_FAILED result: DISCONNECTED  3/14 13:10:22.145  Login program=WoW platform=Mc64 locale=enUS 3/14 13:10:22.145  Component WoW.Mc64.20886 3/14 13:10:22.145  Component WoW.base.20726 3/14 13:10:22.154  Battle.net is Component Bnet.Mc64.37165 3/14 13:10:23.298  Client Disconnect due to reason:8 3/14 13:12:54.053  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK  3/14 13:12:54.073  Failed to resolve “”.logon.battle.net 3/14 13:12:54.151  LOGIN: state: LOGIN_STATE_FAILED result: DISCONNECTED  3/14 13:12:54.151  Login program=WoW platform=Mc64 locale=enUS 3/14 13:12:54.173  Component WoW.Mc64.20886 3/14 13:12:54.173  Component WoW.base.20726 3/14 13:12:54.308  Battle.net is Component Bnet.Mc64.37165 3/14 13:12:54.309  Client Disconnect due to reason:8  
    • By daz39
      hello can someone help me please i need a tool with the source that can parse and update values in navicat db from these packets http://pastebin.com/xVixYuLQ but not having any luck hex 04C2 from 22nd packet, byte is 1218 model the next byte is scale 37 =55, next byte is level 02 ,next byte from paste bin packet is 42 faction 66 these values change in the packets so need it to update the values ,so need a tool with source that can do this i have attached a pic to show the reversed data out come in navicat db

  • Create New...