Jump to content
TrinityCore

Server Stuck, some problems i don't know how to explain...


cyberpro98
 Share

Recommended Posts

I am using 2.4.3 Core 

So  i am getting the erros while some players are playing normal and server stucks .. after it  i get disconect, so when i try to login it stays on " CONNECTED " 
and if i press cancel i will get a window to choose realm and i choose it again .. but nothing same sh!t .. 

 

 

Those are the rashes -> 

SERVER_CRASH.png


OR LINK - > https://s17.postimg.org/3yogz1827/SERVER_CRASH.png


And i copied them - > 

curtime 60495296 unsigned int
- this 0x10303d80 {m_loops=0 m_lastchange=0 w_loops=88026 ...} FreezeDetectorRunnable *
- ACE_Based::Runnable {m_refs={value_=2 } } ACE_Based::Runnable
- __vfptr 0x01d694d0 {blizzlike-core.exe!const FreezeDetectorRunnable::`vftable'} {0x01061af5 {blizzlike-core.exe!FreezeDetectorRunnable::`vector deleting destructor'(unsigned int)}, ...} void * *
[0] 0x01061af5 {blizzlike-core.exe!FreezeDetectorRunnable::`vector deleting destructor'(unsigned int)} void *
[1] 0x010616ea {blizzlike-core.exe!FreezeDetectorRunnable::run(void)} void *
- m_refs {value_=2 } ACE_Atomic_Op<ACE_Thread_Mutex,long>
value_ 2 volatile long
m_loops 0 unsigned int
m_lastchange 0 unsigned int
w_loops 88026 unsigned int
w_lastchange 60480062 unsigned int
_delaytime 15000 unsigned int


In MASTER.CPP
it show me an arrow and i get this code -> https://s10.postimg.org/wk1x4tont/server1.png


Threading.cpp -> https://s15.postimg.org/8eqezk4uj/threading.png

OS_Thread_Adapter.cpp - > https://s15.postimg.org/6vs1cyjez/os_thread.png

Base_Thread_Adapter.cpp -> https://s10.postimg.org/tsgl4y5o9/base_thread.png

 

 

 

I Have really no idea, if anyone of you can help me ? 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kepo
      I made 2 realms, one for 2.4.3, one for 3.3.5 but for some reason when I try to connect to the 3.3.5 realm I'm getting this error in the cosole: 
      WorldSocket::HandleAuthSession: Client *my home pc's ip is here* requested connecting with realm id 22 but this realm has id 2 set in config. I also get this in-game: 
      The game server you have chosen is currently down. Use the Change Realm button to choose another Realm. The Auth.exe that I use is by OregonCore 2.4.3 for both, but Oregon is 50-60% TrinityCore. When I use the auth.exe by TrinityCore the same problem occurs in the 2.4.3 realm but the 3.3.5 starts working. I don't have any other errors like DB & etc. That's the only problem. 
      I checked the DB auth > realmist and everything looks fine. Here's a picture: http://prntscr.com/mhpbmr
      I have also opened all the needed ports.
      Also - worldconfig for 3.3.5:
      LoginDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;auth" WorldDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;world2" CharacterDatabaseInfo = "127.0.0.1;3306;mysql user;mysql pass;characters2" RealmID = 2 WorldServerPort = 8086 and for 2.4.3
      LoginDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;auth" WorldDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;world" CharacterDatabaseInfo = "127.0.0.1;3306;mysql user;mysql pass;characters" RealmID = 1 WorldServerPort = 8085 Also I checked the AuthSocket.cpp and realmlist.cpp, it looks like there is a code or whatever is called for 3.3.5:
      AuthSocket.cpp
          case 8606:                                          // 2.4.3     case 10505:                                         // 3.2.2a     case 11159:                                         // 3.3.0a     case 11403:                                         // 3.3.2     case 11723:                                         // 3.3.3a     case 12340:                                         // 3.3.5a realmlist.cpp
      static RealmBuildInfo ExpectedRealmdClientBuilds[] = {     {12340, 3, 3, 5, 'a'},                                  // highest supported build, also auto accept all above for simplify future supported builds testing     {11723, 3, 3, 3, 'a'},     {11403, 3, 3, 2, ' '},     {11159, 3, 3, 0, 'a'},     {10505, 3, 2, 2, 'a'},     {8606,  2, 4, 3, ' '},     {6005,  1,12, 2, ' '},     {5875,  1,12, 1, ' '},     {0,     0, 0, 0, ' '}                                   // terminator }; My account's gmlevel in account_access is set to '3' and 'RealmID: is 2', since the max rank level in 2.4.3 (RealmID: 1) is '5'.
      Oh, almost forgot... I modified accounts table, also fusioncms recognize the realm: http://prntscr.com/mhpf3f // trinity is fresh-compiled soo... it's latest version, oregon is 2017 rev since we did tons of custom changes (it's fun server) but hey.. oregon is ded - latest rev is 1 year ago. ;c
    • By Hydra_Btforce
      Just finished download & compile fresh trinitycore 4.3.4  From : https://gitlab.com/trinitycore/TrinityCore_434/tree/4.3.4
       
      Creating World database from : https://github.com/TrinityCoreLegacy/TrinityCore/releases
      Downloading the lasted one & create new database named World
      Navigate to my repo applying sql/updates/world/4.3.4
      Trying to apply all updates but an error occurred while applying updates
      And if i don't apply all updates the world is totally bugged and items/creature are missing.
       
      Please help
    • By Nercc
      Blink teleports through walls.
      Mage "Blink" Spell Bugged - Spell Behavior:
      -Goes through landhills, bumps in the ground or upward hill-climb. The player ends up falling down under/behind the map.
      -Generating & Replacing old Cameras, maps, vmaps & mmaps did not help fix the issue.
      -Does NOT go through objects, wall-objects, etc.
      -When cast at a long staircase, the spell casts itself with the visual effect, and the player gets re-oriented one tiny micro-step backwards. (I assume this is normal behavior).
      On a final note.. Blink was bugged around february, got fixed when i merged with Eluna at around March 9, 2018, and broke again on my second merge on July 29, 2018. Many spells got fixed (Mind control used to crash server, eye of kilrogg as well, hunter disengage spell was totally broken and had zero functionality), however, blink broke once again.
      Any takes?
      Thank you,
      Kind Regards,
      Nerc
    • By WauMPTV
      Hello! Whenever I want to open authserver or worldserver (I'm at 335 branch) it automatically closes but before that showing some error like Cannot open ...
      My files: 
    • By Brmbulka
      i dont know how to resolve this, i think i did everything as it was written in the installation tutorial and also i tried disabling firewall and antivirus 


×
×
  • Create New...