Jump to content
TrinityCore

TrinityCore 4.3.4.15595


petartri
 Share

Recommended Posts

  • 1 month later...

AUTHSERVER

Using configuration file /home/cataclysm/server/etc/authserver.conf.
Using SSL version: OpenSSL 1.0.1f 6 Jan 2014 (library: OpenSSL 1.0.1f 6 Jan 2014)
Using Boost version: 1.54.0
Opening DatabasePool 'auth'. Asynchronous connections: 1, synchronous connections: 1.
MySQL client library: 5.5.43
MySQL server ver: 5.5.43-0ubuntu0.14.04.1
Connected to MySQL database at 127.0.0.1
In mysql_stmt_prepare() id: 89, sql: "UPDATE battlenet_accounts SET v = ?, s = ? WHERE email = ?"
Table 'auth.battlenet_accounts' doesn't exist
In mysql_stmt_prepare() id: 90, sql: "UPDATE battlenet_accounts SET sessionKey = ?, online = ? WHERE id = ?"
Table 'auth.battlenet_accounts' doesn't exist
In mysql_stmt_prepare() id: 96, sql: "UPDATE battlenet_accounts SET failed_logins = failed_logins + 1 WHERE email = ?"
Table 'auth.battlenet_accounts' doesn't exist
In mysql_stmt_prepare() id: 97, sql: "UPDATE battlenet_accounts SET last_ip = ?, last_login = NOW(), locale = ?, failed_logins = 0, os = ? WHERE id = ?"
Table 'auth.battlenet_accounts' doesn't exist
In mysql_stmt_prepare() id: 99, sql: "INSERT INTO battlenet_accounts (`email`,`sha_pass_hash`) VALUES (?, ?)"
Table 'auth.battlenet_accounts' doesn't exist
In mysql_stmt_prepare() id: 102, sql: "UPDATE battlenet_accounts SET v = '', s = '', sha_pass_hash = ? WHERE id = ?"
Table 'auth.battlenet_accounts' doesn't exist
In mysql_stmt_prepare() id: 103, sql: "SELECT 1 FROM battlenet_accounts WHERE id = ? AND sha_pass_hash = ?"
Table 'auth.battlenet_accounts' doesn't exist
In mysql_stmt_prepare() id: 104, sql: "UPDATE battlenet_accounts SET locked = ? WHERE id = ?"
Table 'auth.battlenet_accounts' doesn't exist
In mysql_stmt_prepare() id: 105, sql: "UPDATE battlenet_accounts SET lock_country = ? WHERE id = ?"
Table 'auth.battlenet_accounts' doesn't exist
DatabasePool auth NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors. Read wiki at http://collab.kpsn.org/display/tc/TrinityCore+Home
Cannot connect to database
[email protected]:/home/cataclysm/server/bin#

 

WORLDSERVER

Using configuration file /home/cataclysm/server/etc/worldserver.conf.
Using SSL version: OpenSSL 1.0.1f 6 Jan 2014 (library: OpenSSL 1.0.1f 6 Jan 2014)
Using Boost version: 1.54.0
In mysql_stmt_prepare() id: 68, sql: "UPDATE creature SET zoneId = ?, areaId = ? WHERE guid = ?"
Unknown column 'zoneId' in 'field list'
In mysql_stmt_prepare() id: 69, sql: "UPDATE gameobject SET zoneId = ?, areaId = ? WHERE guid = ?"
Unknown column 'zoneId' in 'field list'
DatabasePool cworld NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors. Read wiki at http://collab.kpsn.org/display/tc/TrinityCore+Home
Cannot connect to world database 127.0.0.1;3306;root;heuheuh' --' help;cworld
[email protected]:/home/cataclysm/server/bin#

 

Link to comment
Share on other sites

There's no "official" repository, thus no official support for 4.3.4, but there are some forum users still able to spot issues which could happen for all supported versions. Case in point, the database errors look like incomplete or improperly created base databases (sql/create/create_mysql.sql, sql/base/auth_database.sql, sql/base/characters_database.sql, followed by http://community.trinitycore.org/files/file/9-legacy-tdb-full-434/). Another possible issue is that you created everything properly, but used a different mysql user than what the server(s) are trying to use. If that was the case, you could be getting denied access to the tables which are being accessed. Of course, not having access would likely be part of the improperly created databases option.

I hope that helped point you in the direction of fixing your issue.

Link to comment
Share on other sites

There's no "official" repository, thus no official support for 4.3.4, but there are some forum users still able to spot issues which could happen for all supported versions. Case in point, the database errors look like incomplete or improperly created base databases (sql/create/create_mysql.sql, sql/base/auth_database.sql, sql/base/characters_database.sql, followed by http://community.trinitycore.org/files/file/9-legacy-tdb-full-434/). Another possible issue is that you created everything properly, but used a different mysql user than what the server(s) are trying to use. If that was the case, you could be getting denied access to the tables which are being accessed. Of course, not having access would likely be part of the improperly created databases option.

I hope that helped point you in the direction of fixing your issue.

GRANT USAGE ON * . * TO 'trinity'@'localhost' IDENTIFIED BY 'trinity' WITH MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 ;

That should give you an idea of what you are saying, of course if you use create_mysql.sql, then you have to be consequent with what user you are telling to auth and world, either that, or just create manually and apply *_database.sql manually also :)

That's also why trinity with pass trinity is the default on config.

Anyway, a little of knowledgement is required to run TC, if an user is getting access errors and he does not know how to look on google, or how to fix it, it is not a TC issue/bug.

EDIT: Did not wanted to sound harsh, but we can't make it without expecting a little user knowledge regarding external TC things, like how a database is setup and little about database maintenance.

Edited by StormByte
Link to comment
Share on other sites

  • 1 month later...

Simple fix 

"

Table 'auth.battlenet_accounts' doesn't exist

- Create the table matching the Trinity Wiki which shows the columns in tables, or open your auth file with notepad++ and check if it is meant to create the table.

Cannot connect to world database 127.0.0.1;3306;root;heuheuh' --' help;cworld

Like somebody said, use the correct details for your database, Seen as its not connecting to the "world database" double check you have the world database name correctly in the worldserver.conf or double check your details are correct.

 

 

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...
2 hours ago, Magnuss said:

I'm surprised but happy to see there is still a active development. But why than everybody told this version is run out of development ?

The gitlab project isn't an official Trinity project. Certain Trinity devs are still working on it, though.

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...