Jump to content
TrinityCore
Sign in to follow this  
bomrox

Two IP-address for one realm

Recommended Posts

How to make access to one realm on different IP addresses?

My server two IP address for access from different local networks (10.111.0.1 and 10.101.17.231) and a shared host wow.tgwnet.ru who write in realmlist.wtf, but to run the server only or on this IP address 10.111.0.1 or 10.101.17.231, players can go with either one network or the other and not simultaneously obtained.

1.jpg

 

In worldserver.conf you can specify a value RealmID = 1 or 2 (but not both simultaneously)

 

the problem can be solved if the table realmlist in the address line enter wow.tgwnet.ru but then does not start the server error: Could not resolve address wow.tgwnet.ru for realm.

 

Help to solve this problem!

Edited by bomrox

Share this post


Link to post
Share on other sites

Only one address for one realm.

Your ports need to be different, also not sure why your localadress is in the 5.x.x range. it should be 127.0.0.1. Your lan address' are correct. You need to configure and whitelist the 8085 and set your realmid 2  to 8086 in your .conf for your second realm

Share this post


Link to post
Share on other sites

I need all the players on one realm was not different, in the table realmlist in the address to allow to register not only IP address but the hostname and when it starts worldserver.exe not give an error: Could not resolve address wow.tgwnet.ru for a realm.

Share this post


Link to post
Share on other sites

Are you trying to create 2 realms? I see 2 realms in your realmlist where they need separate ports. The 2 realms can be on the same server or on separate servers.

You can not occupy one realm with 2 addresses or 2 ports.

Share this post


Link to post
Share on other sites

I need to different IP addresses came on one of the gaming world.

my problem can be resolved to register in the row address (tabitsa realmlist) wow.tgwnet.ru but then when you start authserver.exe in the log writes an error:

TrinityCore rev. 8d2f2f8f0603 2017-02-10 19:37:54 +0000 (3.3.5 branch) (Win64, Release, Static) (authserver)
<Ctrl-C> to stop.

Using configuration file C:/TrinityCore_server/authserver.conf.
Using SSL version: OpenSSL 1.0.2j  26 Sep 2016 (library: OpenSSL 1.0.2j  26 Sep 2016)
Using Boost version: 1.60.0
Automatic database updates are disabled for all databases!
Opening DatabasePool 'auth'. Asynchronous connections: 1, synchronous connections: 1.
MySQL client library: 5.5.54
MySQL server ver: 5.5.5-10.1.20-MariaDB 
Connected to MySQL database at 127.0.0.1
MySQL client library: 5.5.54
MySQL server ver: 5.5.5-10.1.20-MariaDB 
Connected to MySQL database at 127.0.0.1
DatabasePool 'auth' opened successfully. 2 total connections running.
Started auth database connection pool.
Could not resolve address wow.tgwnet.ru for realm "TGW Норком+CKC" id 2
Removed realm "TGW Норком+CKC".

 

The creators of TrinityCore, please make a resolution to enter into a string address (tabitsa realmlist) hostname and not just IP address.

 

Share this post


Link to post
Share on other sites

but you CAN put in the string in realmlist, the catch is that the machine that runs your authserver must be able to resolve that address to ip (you cant send the string to client)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...