Jump to content
TrinityCore
MDK

Client stuck at logging into server

Recommended Posts

Hi there,

Currently I'm testing with 7.2.0 and so far it has worked fine. However after the last time I've killed the worldserver and started it up again, my client doesn't want to move to the character selection screen. It is connected, because it has updated the user connection date and time in the auth database. Has anyone got experience what to look for in solving this issue? I'm running the server and client on my laptop and is using default config of 127.0.0.1.

i've deleted client cache ánd in c:\programdata the blizzard entertainment folder.

If I restore the database back to an older version, it'll connect and move through to the character selection screen, however after closing worldserver I have the same problem again.

Also I'd like to add, that I'm very impressed with the work that has been done to emulate the backend of Wow!

 

Edited by MDK

Share this post


Link to post
Share on other sites

I know one thing for sure to make a more secure connection when connecting you always want to use the IP address and the port number together or it has a chance of being picky and not always allowing connection so make sure it looks something like this when dealing with the config.wtf file 192.168.1.100:1119 your IP and port followed closely together. Also when it comes to updating the server especially the auth database it doesn't always update the hash all the time so that is why when you reload the database it works and when you retry it doesn't. I have been working with a solution on this issue for a while now which is close to being done.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi codeman8214!

Thanks for replying! So basically if I update config.wtf with my ip-adress and update this in the auth database as well, it should work better? Also in worldserver.config and bnetserver.config update with my ip-adres (192.168.x.x)?

Edited by MDK

Share this post


Link to post
Share on other sites

Well see the port makes the authserver connection stronger but the code I have done makes the socket stronger so when the client and server communicates it looks for a stronger socket connection using the IP and port together which changes the structure altogether. Much better authentication for authserver, which I plan to release to TrinityCore once I am done so it can be committed

  • Upvote 1

Share this post


Link to post
Share on other sites

Ah ok, that's good news! I'll edit the config.wtf so that it'll use my local ipaddress with port 1119. Also do I need to update this as well in the auth database or only the config.wtf?

Edited by MDK

Share this post


Link to post
Share on other sites

For now only the config.wtf file but after the changes have been made to the correct files it will require the database to also change with an update to a sql file.

  • Upvote 1

Share this post


Link to post
Share on other sites

Ok thanks! I'll give it a go and report back in with the results. This will be in about 3 hours since I'm not at home currently.

Share this post


Link to post
Share on other sites

Ok, I've tried to following without any results unfortunately:

  • changed in config.wtf set portal = "127.0.0.1" to set portal = "192.168.x.x" -> started Wow Client and stuck at logging into server
  • changed in config.wtf set portal = "127.0.0.1" to set portal = "192.168.x.x:1119" -> started Wow Client and stuck at logging into server

What can I do to make the connection work?

Share this post


Link to post
Share on other sites

I think so, I've got windows defender turned off. Is there another place I should check or look for?

Share this post


Link to post
Share on other sites

Also turned Windows Firewall off. Retested with set portal = "192.168.x.x:1119" still stuck on logging into game server

Share this post


Link to post
Share on other sites

Before you set the IP address did you delete cache, logs & wtf folder to let the client rebuild the files by itself then exit the client again then set the IP address after that run world of warcraft. Take a screen shot & also give me the error number if you would thanks

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi codeman!

Thanks for replying. I'll follow your instructions step by step and produce the results in screenshots when I'm at home. I only deleted the client cache and serverside the DBError.log and Server.log I didn't delete the logs, gt and wft folder and then set the ip-address. To be continued!

 

 

Edited by MDK

Share this post


Link to post
Share on other sites

First steps:

1.) Deleted Client cache, logs and WTF folder

2.) Deleted Server gt, log files.

 

wowclient_server.png

Share this post


Link to post
Share on other sites

Step 3: starting the client (without the server). Needed to select language setting and the cinematics of Wow legion were played. Exited the wow client.

Then there's now a clean wtf folder with account folder and config.wtf in it. set portal = "US" is now the content.

 

 

wowclient_wtf.png

Share this post


Link to post
Share on other sites

Step 5: starting the server. Both bnetserver and worldserver start up. I deleted the gt folder serverside before, but that one needs to be in the server folder so I copied that one back in from a backup I made.

The servers have started up and are running.

 

Share this post


Link to post
Share on other sites

Step 6: Starting up the client for the first time, with the set portal setting set to 127.0.0.1.

The client doesn't login any further and is stuck at Logging in to game server. No error appears.

 

wow_client_stuck.jpg

Share this post


Link to post
Share on other sites

Adding the battlenet.log from the client:

5/16 20:09:27.514  [IBN_Login] Starting up | hasFrontInterface=false | hasBackInterface=false
5/16 20:09:49.763  [GlueLogin] Starting login | launcherPortal=nullopt | loginPortal=127.0.0.1:1119
5/16 20:09:49.763  [GlueLogin] Resetting
5/16 20:09:49.763  [IBN_Login] Initializing
5/16 20:09:49.763  [IBN_Login] Attempting logon | host=127.0.0.1 | port=1119
5/16 20:09:49.764  [GlueLogin] Waiting for server response.
5/16 20:09:49.857  [GlueLogin] Waiting for server response.
5/16 20:09:49.865  [GlueLogin] Waiting for server response.
5/16 20:09:49.930  [GlueLogin] Waiting for server response.
5/16 20:09:50.075  [GlueLogin] Waiting for server response.
5/16 20:09:50.087  [GlueLogin] Waiting for server response.
5/16 20:09:50.097  [GlueLogin] Logon complete.
5/16 20:09:50.097  [GlueLogin] Waiting for realm list.
5/16 20:09:50.097  [IBN_Login] Requesting realm list ticket
5/16 20:09:50.097  [IBN_Login] Received realm list ticket | code=ERROR_OK (0)
5/16 20:09:50.097  [GlueLogin] Waiting for realm list.
5/16 20:09:50.118  [IBN_Login] Received sub region list | code=ERROR_OK (0)
5/16 20:09:50.118  [IBN_Login] Requesting last played chars | numSubRegions=1
5/16 20:09:50.129  [GlueLogin] Realm list ready.
5/16 20:09:50.129  [IBN_Login] Joining realm | subRegion=2-1-0 | realmAddress=2-1-1
5/16 20:09:50.293  [IBN_Login] OnRealmJoin | code=ERROR_OK (0)
5/16 20:10:27.528  [GlueLogin] Explicitly disconnecting from realm server
5/16 20:10:27.528  [IBN_Login] Front disconnecting | connectionId=1
5/16 20:10:27.528  [GlueLogin] Disconnecting from authentication server.
5/16 20:10:27.702  [IBN_BackInterface] Session with Battle.net destroyed.
5/16 20:10:27.702  [GlueLogin] Disconnected from WoW | previouslyConnected=false
5/16 20:10:27.702  [IBN_Login] Front disconnected | connectionId=1 | result=( | code=ERROR_OK (0) | localizedMessage= | debugMessage=)
5/16 20:10:27.702  [GlueLogin] Disconnected from authentication server.
5/16 20:10:27.702  [IBN_Login] Destroying | isInitialized=true
5/16 20:10:29.088  [IBN_Login] Destroying | isInitialized=false
5/16 20:10:30.480  [IBN_Login] Shutting down

 

 

Share this post


Link to post
Share on other sites

I've canceled logging in after waiting a while, but looking at this log, the connection with authentication server was lost a long time before.

Share this post


Link to post
Share on other sites

Try using your router IP instead of localhost as followed 192.168.xxx.xxx if that doesn't work try something for me and open ports 3724, 8085, & 1119 on your router then use your main IP address.  If you don't know what it is either check your router or go to www.whatismyip.com

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello Aokromes,

True, deleting the gt folder wasn't too smart. However managed to fix that by copying that back in (made a backup beforehand) and followed the steps suggested by codeman.

 

Share this post


Link to post
Share on other sites

Hello codeman,

Will follow your new instructions. I'll test first with my local ip address and check for open ports on my router. Also test with main ip addres I'll do as well. Will be back with the results this evening. Post screenshots of the steps taken.

 

Share this post


Link to post
Share on other sites
10 hours ago, codeman8214 said:

Try using your router IP instead of localhost as followed 192.168.xxx.xxx if that doesn't work try something for me and open ports 3724, 8085, & 1119 on your router then use your main IP address.  If you don't know what it is either check your router or go to www.whatismyip.com

I don't see why bouncing the traffic off a router would help in any way (although i have no idea how 7.2 works). MDK has everything local by the sounds of it, so more need to check all the IP's in the link match up. i.e. Relmlist table, conf.wtf, realmlist in data directory (if still used) and also make sure there is no hosts.sam entry or anti virus blocking.

Just my opinion.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×