Jump to content
TrinityCore
Sign in to follow this  
MDK

How to make gameobjects work

Recommended Posts

Hi Codeman!

I was curious whether you've had any luck with testing my sql scripts and whether you had the same problem or not.

 

 

Share this post


Link to post
Share on other sites

Well i have tested it now and every thing works good for me.

You can open the gameobject if you have taked the quest only (I tested it with the horde quest id=9993, alliance is the same 9992), if you havent taken the quest you cant open it.

Here you have the values for it (i didnt change any values, so its trinity original values):

Gameobject_template:

data0=57

data1=19372

data3=1

The rest of data files=0,nothing relevant there

Gameobject_template_addon:

flags=4

The rest=0

Gameobject_loot_template;

entry=19372

questrequired=1

The rest same than you.

I hope this is clear for you so you can fix it. Good luck.

Share this post


Link to post
Share on other sites

Hi Daniel,

Thanks for testing and helping out. I've applied those settings and restarted the trinitycore worldserver. However the Olemba cones are not clickable. I didn't clear the cache in the client. I'll try this tonight. If that fails then I'm thinking of rebuilding a new database. I've taken the database of dduarte v720 as a basis and then ran the updates. Is that also what you guys have done?

 

Share this post


Link to post
Share on other sites
1 hour ago, MDK said:

Hi Daniel,

Thanks for testing and helping out. I've applied those settings and restarted the trinitycore worldserver. However the Olemba cones are not clickable. I didn't clear the cache in the client. I'll try this tonight. If that fails then I'm thinking of rebuilding a new database. I've taken the database of dduarte v720 as a basis and then ran the updates. Is that also what you guys have done?

 

Well i was going to tell you about clearing your cache too. If it doesnt work:

You can truncate the world database, import the world sql file downloaded of trinity and then you run the worldserver.exe so updates get added automatly.And everything should to work good.

Just wondering why you used a different database of trinity instead of trinity one...

Share this post


Link to post
Share on other sites

Hi Daniel,

I thought so, I'll do the cache clearing first. If that fails, then I'll do the truncate and import the original world sql file. The updates that are relevant are only those in the 7.x folder right?

To clarify, I used the Dduarte database. That one is also available by Trinity TDB 720.00 which holds all data until 19-04-2017. I ran updates ontop of that one.

If I start over I can truncate the world database but... what do I do next?

Just turn on run updates when starting the worldserver?

 

Share this post


Link to post
Share on other sites

Sorry I have been gone for a while now been really busy with stuff but I did test that out and it didn't work until I started the database over again and cleared my cache so you might want to think about doing that, I have done a lot of testing lately and so far that is the best solution, I am still trying to work around one thing though so I will post back thanks

Share this post


Link to post
Share on other sites
On 17/8/2017 at 1:22 PM, MDK said:

Hi Daniel,

I thought so, I'll do the cache clearing first. If that fails, then I'll do the truncate and import the original world sql file. The updates that are relevant are only those in the 7.x folder right?

To clarify, I used the Dduarte database. That one is also available by Trinity TDB 720.00 which holds all data until 19-04-2017. I ran updates ontop of that one.

If I start over I can truncate the world database but... what do I do next?

Just turn on run updates when starting the worldserver?

 

Yes, the correct database is which you used dduarte 720 TDB_full_720.00_2017_04_18.7z

Truncate the world database, add the sql file tdb full 720 and turn on run updates automatly in the worldserver.config. Then run the worldserver.exe and everything should to be ok. Dont forget to delete the cache client folder before of starting the wowpatched..exe

Share this post


Link to post
Share on other sites

Hi Daniel,

Being busy right now with the updates of the database. I got the following error, any ideas why that happens?:

TrinityCore rev. eb555dd48b26 2017-05-15 20:36:02 +0200 (master branch) (Win64, Release, Static) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org \/__/

Using configuration file E:/Games/WowPrivateServer/Legion/Official Legion 7.2.5/worldserver.conf.
Using SSL version: OpenSSL 1.0.2k  26 Jan 2017 (library: OpenSSL 1.0.1u  22 Sep 2016)
Using Boost version: 1.59.0
Updating Auth database...
>> Auth database is up-to-date! Containing 11 new and 97 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 5 new and 67 archived updates.
Updating World database...
>> Applying update "2017_04_19_01_world.sql" 'B1EFAB0'...
mysql: Could not create or access the registry key needed for the MySQL application

to log to the Windows EventLog. Run the application with sufficient

privileges once to create the key, add the key manually, or turn off

logging for that application.


Applying of file 'F:/Development/TrinityCore/TrinityCore/sql/updates/world/master/2017_04_19_01_world.sql' to database 'world' failed! If you are a user, please pull the latest revision from the repository. Also make sure you have not applied any of the databases with your sql client. You cannot use auto-update system and import sql files from TrinityCore repository with your sql client. If you are a developer, please fix your sql query.
Could not update the World database, see log for details.

 

 

 

Share this post


Link to post
Share on other sites

Hmm ok, I was able to circumvent the above by applying all the world sql updates from the master branch and then also did that for the hotfix database.

Unfortunately the worldserver won't run:

TrinityCore rev. eb555dd48b26 2017-05-15 20:36:02 +0200 (master branch) (Win64, Release, Static) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org \/__/

Using configuration file E:/Games/WowPrivateServer/Legion/Official Legion 7.2.5/worldserver.conf.
Using SSL version: OpenSSL 1.0.2k  26 Jan 2017 (library: OpenSSL 1.0.1u  22 Sep 2016)
Using Boost version: 1.59.0
Automatic database updates are disabled for all databases!
Could not prepare statements of the World database, see log for details.

 

 

But what log do I access for details...Anyone got experience with this?

Share this post


Link to post
Share on other sites

Ok, so reinstall mysql then. It's probably not only the database that got corrupted?

 

I think I'll rebuild the project also, since I see that the log has a date of 15-05-2017, but I just pulled and built a new worldserver.exe. Something's messed up. I'll start over I think.

Share this post


Link to post
Share on other sites

I've started over:

1.) complete new git check out, rebuilt VS project with cmake.

2.) compiled new bnetserver, worldserver

3.) extracted all maps, vmaps ,mmaps and dbc/db2

4.) created new instance and hosted on mysql server 5.7

5.) created all databases auth, characters, hotfixes and world

6.) filled it with DDuarte's TDB 7.2.0.

7.) ran all updates in the updates folder

8.) downloaded and installed Wow Client 7.2.5

9.) created new account and character

10.) tested the quest 9992 Olemba Seeds

11.) The gameobjects are highlighted and drop the items!

So case closed, thanks for helping out and giving pointers to solve this issue. As for me I'm very happy with the new 7.2.5 release.

I've discovered that the riding/flying trainers do not work also the profession trainers are not responding to gossips. Is that still expected not to work? I've googled the trinitycore issue history and there is mention of that that's been solved. However my trainer table is empty

Share this post


Link to post
Share on other sites
10 hours ago, MDK said:

I've discovered that the riding/flying trainers do not work also the profession trainers are not responding to gossips. Is that still expected not to work? I've googled the trinitycore issue history and there is mention of that that's been solved. However my trainer table is empty

This is a new issue

Share this post


Link to post
Share on other sites
55 minutes ago, codeman8214 said:

Wait so you did get everything to work now?

Hi Codeman,

Yes I got the Olemba Seeds working. This was for me one of many quests with gameobjects that didn't work. With a completely new build it does. So I think that I've messed up the previous build with Navicat. I can't otherwise explain it, but I'll stick to MySql (with Workbench) as TrinityCore recommends.

Thanks for helping out!

 

Share this post


Link to post
Share on other sites
6 hours ago, MDK said:

Thanks for referring to that issue. How do you guys work around this?

I've been following DoctorKraft's advice from that thread I linked and pulling sql data from all my old sniffs. Where the data is not complete I've been making new sniffs on retail. It's slow and incomplete, but slightly better than waiting for TDB to get updated. :P 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...