Jump to content
TrinityCore
Sign in to follow this  
BeLove

No NPC at Stormwind [3.3.5a]

Recommended Posts

Hi guys. I have a pretty strange issue.

I have a totally fresh installation - TrinityCore rev. 1f9f59b4b3b9+ 2017-11-30 23:36:45 +0100 (3.3.5 branch) (Unix, RelWithDebInfo, Static) (with all DB updates), no patches (except next one):

---

update game_event set start_time = '1971-01-01 00:00:00', end_time = '1972-01-01 00:00:00' where eventEntry in (22, 17, 13, 31, 48, 49, 55, 56, 57, 58, 59, 60);

ALTER TABLE game_event MODIFY COLUMN start_time timestamp NOT NULL DEFAULT '1971-01-01 00:00:00', MODIFY COLUMN  end_time timestamp NOT NULL DEFAULT '1972-01-01 00:00:00';

--

This one is required for my MySQL server (and my chars database is old but updated).

And... most of NPC in cities like Stormwind doesn't exist. If im trying to do list cre (e.g. auctioneer in Stormwind)

list cre 8670

79706 - Auctioneer Chilton X:-8824.280273 Y:665.710999 Z:97.467400 MapId:0
Found creatures 8670: 1

and after that

go cre  |cffffffff|Hcreature:79706|h[Auctioneer Chilton X:-8824.280273 Y:665.710999 Z:97.467400 MapId:0]|h|r [Player: Risk (GUID Full: 0x000000000000bc41 Type: Player Low: 48193) (Account: 3) X: -8829.995117 Y: 632.190308 Z: 94.203384 Map: 0 (Восточные королевства) Area: 1519 (Штормград) 

I cannot see anyone. I note that list cre command does't say anything about values like "GUID Full" by no reason. Probably I'm thinking about issue in "Grid unload" functionality  (bugged in my case? I have 4 gb ram / 4 gb swap)

Do you have any ideas? Thanks.

P.S. I'm pretty sure that this case related only to my installation - that is why I didn't created this issue @ github

 

 

Share this post


Link to post
Share on other sites

Ok I found that I can bring back my NPC via .respawn command. Looking for the root is this issue

Share this post


Link to post
Share on other sites

you need mysql strict mode to be disabled to allow the update system to work properly, and after that, i suggest you to drop your world database and leave core to import the database.

  • Like 1

Share this post


Link to post
Share on other sites

1) Disabled strict mode

2) Dropped world db

3) Updated core to TrinityCore rev. 1f9f59b4b3b9+ 2017-11-30 23:36:45 +0100

4) Installed fresh TDB, all world updates are applied after first server start (without errors)

5) Issue still exist - a lot of NPC still "died" and spawned only after ".respawn" command

Share this post


Link to post
Share on other sites
27 minutes ago, BeLove said:

5) Issue still exist - a lot of NPC still "died" and spawned only after ".respawn" command

Works for me (TM)

 

UEObYT6.jpg

Share this post


Link to post
Share on other sites

Thanks for reply, I know that this issue only exists for me. Just probably it's some common thing that can happen. BTW I note that in debug mode I see a lot of errors related to mmap loading and want to re-extract all data files.

Share this post


Link to post
Share on other sites

I have heard of this issue on 7.2.5 but not 3.3.5a are you sure you are not using anything custom and everything is from a fresh start including your core files just checking because everything seems to be working like it should for me including 4.3.4

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

the extracted files could be a problem if they are corruped, make shure your client is correct (or try to export from an other fresh client)

i don't think the mmaps are wrong, more plausible the map files, but i don't know if the option to disable mmaps still exists in TC, you cold try it and if npcs stop dying you know the reason

Share this post


Link to post
Share on other sites
56 minutes ago, desteny said:

the extracted files could be a problem if they are corruped, make shure your client is correct (or try to export from an other fresh client)

i don't think the mmaps are wrong, more plausible the map files, but i don't know if the option to disable mmaps still exists in TC, you cold try it and if npcs stop dying you know the reason

mmaps version was updated few days ago, but i doub that have something to do with dead npcs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×