Jump to content
TrinityCore
Weirdfish03

[INVALID]Auth server Error

Recommended Posts

So when I load the Auth Server here is what comes up


Using configuration file authserver.conf.
OpenSSL 1.0.1c 10 May 2012 (Library: OpenSSL 1.0.1c 10 May 2012)
Opening DatabasePool 'auth'. Asynchronous connections: 1, synchronous connections: 1.
Could not connect to MySQL database at 25.89.67.241: Can't connect to MySQL server on '25.89.67.241' (10060)

 

I'm trying to play with Hamachi with my friend but it isn't working and i'm wondering what needs to be done to fix this problem?

 

Edit: I changed ALL of the possible IP's into the 25.89.67.241

Edited by Weirdfish03

Share this post


Link to post
Share on other sites

Try using 127.0.0.1 for the db IP's in worldserver.conf if its all installed on the same machine. Also make sure BindIP still 0.0.0.0

Share this post


Link to post
Share on other sites

autherserver.conf needs to be edited.

Line 185

LoginDatabaseInfo = "127.0.0.1;3306;dbuser;dbpass"

and Line 63 should remain

BindIP = "0.0.0.0"

unless you have some special configuration where your core and db are on separate machines or VMs

 

mysql only allows local connections, unless you specifically enable remote connections for specific ip's

Share this post


Link to post
Share on other sites
# AUTH SERVER SETTINGS
#
# LogsDir
# Description: Logs directory setting.
# Important: LogsDir needs to be quoted, as the string might contain space characters.
# Logs directory must exists, or log file creation will be disabled.
# Default: "" - (Log files will be stored in the current path)
 
LogsDir = "../logs"

Share this post


Link to post
Share on other sites

well I can tell you this, it's probably killing the authserver because the database tables aren't set up. Your authserver.conf doesn't contain the previous settings I mentioned, because it is an older version of the core. I would suggest checking where the LogsDir is set to, you should find a file named Auth.log there to give you a better explanation of why the server is exiting.

as far as the db goes, i think you'll have to manually import the sql db creation file, which i believe is called create_mysql.sql (dont forget to modify the user and password for every query in the file before importing it).

Tough to know what is changed in a repack.

Share this post


Link to post
Share on other sites

well if you had it running before, i would say change the configuration back to how you had it running, and then the only thing you should need to change is in the auth database, in the realmlist table in the address column of the row your server is on, change that to your hamachi ip, leave the local ip alone. that you do in navicat. you also may need to play with your client realmlist.wtf and change it to your hamachi ip on both yours and your friends client.

Share this post


Link to post
Share on other sites

When you say you put everything back, did you keep a copy of the files exactly as they were originally? You might try comparing your configuration with the stock files on the github site to see if anything else changed. Are you sure your database server is running? Can you use the mysql command line tool or the windows equivalent to look at the tables?

I had a problem a lot like this recently, with authserver unable to connect. It turned out to be because I edited the mysql.cnf file to disable sql networking on the advice of a security guide. Needless to say, that didn't work out. However, if there's a firewall blocking your loopback connection, that would probably look the same. (Or if the sql server crashed at some point.)

Edited by dane

Share this post


Link to post
Share on other sites
13 hours ago, oXL0C0Xo said:

well if you had it running before, i would say change the configuration back to how you had it running, and then the only thing you should need to change is in the auth database, in the realmlist table in the address column of the row your server is on, change that to your hamachi ip, leave the local ip alone. that you do in navicat. you also may need to play with your client realmlist.wtf and change it to your hamachi ip on both yours and your friends client.

So I did what you suggested and I got the server up this time but when I tried to login it said 'Unable to Connect' now what?

Share this post


Link to post
Share on other sites
8 hours ago, Weirdfish03 said:

So I did what you suggested and I got the server up this time but when I tried to login it said 'Unable to Connect' now what?

When you reinstall the repack does it drop and reinitialize the databases? Does it replace the *.conf files? If not, you still haven't started from zero.

Share this post


Link to post
Share on other sites

--- Canned message start --- Trinity does not support repacks. Please learn to compile and configure the source yourself, you will learn more and may even find that the error doesnt exist in vanilla TC. Please refer to the author of the repack for your questions if you continue to use said repack. --- Canned message end ---

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...