Jump to content
TrinityCore

"unknown column" "missing table" "duplicate column" error / sql problems / SQLDriverLogFile < answer on 1st post of 1st page


Apple
 Share

Recommended Posts

Hello.

I followed the guidance offered dall'info of Trinity.

I ran all the steps without any problem, but came to setting the databse I found some problems.

The first was to use the file create_mysql, which offers me an error 1146

TABLE user.mysql dosent exist

The second is to upload the file FULL_DB trinity which returns me the following errors, including the former.

Query:

DROP TABLE IF EXISTS `custom_texts`


Error occured at:2011-05-16 00:38:48

Line no.:1

Error Code: 1046 - No database selected


Query:

DROP TABLE IF EXISTS `custom_texts`


Error occured at:2011-05-16 00:38:51

Line no.:1

Error Code: 1046 - No database selected


Query:

ALTER TABLE character_db_version CHANGE COLUMN required_10254_01_characters_auctionhouse required_10312_01_characters_character_aura bit


Error occured at:2011-05-16 01:18:23

Line no.:2

Error Code: 1146 - Table 'mangos.character_db_version' doesn't exist


Query:

ALTER TABLE db_version CHANGE COLUMN required_10257_01_mangos_command required_10263_01_mangos_pool_creature bit


Error occured at:2011-05-16 01:18:57

Line no.:2

Error Code: 1054 - Unknown column 'required_10257_01_mangos_command' in 'db_version'


Query:

ALTER TABLE db_version CHANGE COLUMN required_10257_01_mangos_command required_10263_01_mangos_pool_creature bit


Error occured at:2011-05-16 01:20:10

Line no.:2

Error Code: 1054 - Unknown column 'required_10257_01_mangos_command' in 'db_version'


Query:

ALTER TABLE character_db_version CHANGE COLUMN required_10664_01_characters_arena_team_stats required_10862_01_characters_mail bit


Error occured at:2011-05-16 01:20:59

Line no.:2

Error Code: 1146 - Table 'mangos.character_db_version' doesn't exist


Query:

ALTER TABLE character_db_version CHANGE COLUMN required_10254_01_characters_auctionhouse required_10312_01_characters_character_aura bit


Error occured at:2011-05-16 01:25:09

Line no.:2

Error Code: 1054 - Unknown column 'required_10254_01_characters_auctionhouse' in 'character_db_version'


Query:

ALTER TABLE db_version CHANGE COLUMN required_10365_01_mangos_creature_ai_scripts required_10381_01_mangos_creature_model_race bit


Error occured at:2011-05-16 01:30:01

Line no.:1

Error Code: 1054 - Unknown column 'required_10365_01_mangos_creature_ai_scripts' in 'db_version'


Query:

ALTER TABLE character_db_version CHANGE COLUMN required_11299_02_characters_pet_aura required_11391_01_characters_auction bit


Error occured at:2011-05-16 01:31:10

Line no.:1

Error Code: 1146 - Table 'mangos.character_db_version' doesn't exist


Query:

ALTER TABLE db_version CHANGE COLUMN required_11453_01_mangos_spell_proc_event required_11489_01_mangos_creature_template bit


Error occured at:2011-05-16 01:41:55

Line no.:1

Error Code: 1054 - Unknown column 'required_11453_01_mangos_spell_proc_event' in 'db_version'


Query:

/*!50003 DROP PROCEDURE IF EXISTS `sp_delete_loot` */


Error occured at:2011-06-17 10:57:01

Line no.:5267

Error Code: 1146 - Table 'mysql.proc' doesn't exist


Query:

/*!50003 DROP PROCEDURE IF EXISTS `sp_delete_loot` */


Error occured at:2011-06-17 10:59:07

Line no.:4

Error Code: 1146 - Table 'mysql.proc' doesn't exist


Query:

DROP TABLE IF EXISTS `access_requirement`


Error occured at:2011-06-17 11:00:12

Line no.:22

Error Code: 1044 - Access denied for user 'root'@'localhost' to database 'information_schema'


Query:

/*!50003 DROP PROCEDURE IF EXISTS `sp_delete_loot` */


Error occured at:2011-06-17 11:01:32

Line no.:5267

Error Code: 1146 - Table 'mysql.proc' doesn't exist


Query:

GRANT USAGE ON * . * TO 'trinity'@'localhost' IDENTIFIED BY 'trinity' WITH MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 


Error occured at:2011-06-17 11:02:50

Line no.:1

Error Code: 1146 - Table 'mysql.user' doesn't exist


Query:

GRANT USAGE ON * . * TO 'trinity'@'localhost' IDENTIFIED BY 'trinity' WITH MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 


Error occured at:2011-06-17 11:03:02

Line no.:1

Error Code: 1146 - Table 'mysql.user' doesn't exist


Query:

GRANT USAGE ON * . * TO 'trinity'@'localhost' IDENTIFIED BY 'trinity' WITH MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 


Error occured at:2011-06-17 11:03:08

Line no.:1

Error Code: 1146 - Table 'mysql.user' doesn't exist


Query:

/*!50003 DROP PROCEDURE IF EXISTS `sp_delete_loot` */


Error occured at:2011-06-17 11:07:38

Line no.:5267

Error Code: 1146 - Table 'mysql.proc' doesn't exist


Query:

+++DO NOT IMPORT THIS UNLESS YOU WANT A *BLANK* DATABASE.+++

/*!40101 SET @[email protected]@CHARACTER_SET_CLIENT */


Error occured at:2011-06-17 11:08:15

Line no.:9

Error Code: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '+++DO NOT IMPORT THIS UNLESS YOU WANT A *BLANK* DATABASE.+++

/*!40101 SET @OLD_C' at line 1


Query:

/*!50003 DROP PROCEDURE IF EXISTS `sp_delete_loot` */


Error occured at:2011-06-17 14:33:39

Line no.:5267

Error Code: 1146 - Table 'mysql.proc' doesn't exist


Query:

ALTER TABLE `channels` CHANGE COLUMN `m_name` `name` varchar(128) NOT NULL,

  CHANGE COLUMN `m_team` `team` int(10) unsigned NOT NULL,

  CHANGE COLUMN `m_announce` `announce` tinyint(3) unsigned NOT NULL DEFAULT '1',

  CHANGE COLUMN `m_ownership` `ownership` tinyint(3) unsigned NOT NULL DEFAULT '1',

  CHANGE COLUMN `m_password` `password` varchar(32) DEFAULT NULL,

  CHANGE COLUMN `BannedList` `bannedList` text,

  CHANGE COLUMN `last_used` `lastUsed` int(10) unsigned NOT NULL


Error occured at:2011-06-17 15:38:12

Line no.:8

Error Code: 1054 - Unknown column 'm_name' in 'channels'


Query:

/*!50003 DROP PROCEDURE IF EXISTS `sp_delete_loot` */


Error occured at:2011-06-17 15:38:55

Line no.:5241

Error Code: 1146 - Table 'mysql.proc' doesn't exist


Query:

/*!50003 DROP PROCEDURE IF EXISTS `sp_delete_loot` */


Error occured at:2011-06-17 15:47:29

Line no.:5241

Error Code: 1146 - Table 'mysql.proc' doesn't exist


Link to comment
Share on other sites

its TDB_full_335.11.39_2011_04_02 downloaded from the wiki site -.-

I assume since your errors occurred on 0211-06-17 that you're using a relatively "new" version of the core. In that case, you should be using the "full" that was posted in May: TDB_335.11.40_2011_05_09.rar

The one you listed was from April and there have been at least a hundred core revisions between then and now.

Link to comment
Share on other sites

I think you broke your mysql instalation, reinstall and start again, btw you need to use TrinityCore for TrinityDatabase, and the most updated DB version is https://github.com/downloads/TrinityCore/TrinityCore/TDB_full_335.11.41_2011_06_18.rar

Query:

ALTER TABLE db_version CHANGE COLUMN required_11453_01_mangos_spell_proc_event required_11489_01_mangos_creature_template bit

Error occured at:2011-05-16 01:41:55

Line no.:1

Error Code: 1054 - Unknown column 'required_11453_01_mangos_spell_proc_event' in 'db_version'

Query:

/*!50003 DROP PROCEDURE IF EXISTS `sp_delete_loot` */

Error occured at:2011-06-17 10:57:01

Line no.:5267

Error Code: 1146 - Table 'mysql.proc' doesn't exist

Link to comment
Share on other sites

Problem solved :D , now still only another 1.

When i start AUTHSERVER it start w/o problems, WORLDSERVER stuck at

Loading Items . . .

No errors in log file.

Wrong, try reading the server.log very carefully and look for the warning that I know is there, because I already know what the problem is.

Link to comment
Share on other sites

  • 3 months later...

Whenever I open the "creature" table under "world" database, I get said error..

I read http://www.trinitycore.org/f/topic/3711-deathstate/ and the solution given there does not work

I compiled a whole new server, Downloaded a fresh DB (TDB_full_335.11.42_2011_08_27.sql) - Added ALL updates.

I've had A LOT of Trinity servers, so I know how stuff works. And I know that it's because "DeathState" was removed some patches ago.... But why do I get the error in a fresh install? Haven't imported anything custom yet

When I open the table, and shoo away the error, only one "creature id" shows; id: 1646104, creature_id: 16461

Thanks in advance

Trauze

Link to comment
Share on other sites

Maybe i am stupid or such but a sql editor opens up a table without checking for specific columns so i can not realy understand why you get this error. I will try to reproduce it but therefore i need some more informations. Please tell me step by step with truely every click you done in order to get this error.

Ofc this is perhabs no trinitycore problem but it would be nice to know where this error is form.

Link to comment
Share on other sites

@Athene - I want it to click the data, so that I can see all the creatures specific spawns (and add new ones manually) I tried SQLYog, but I can only get it to show the name of the tables, not the actual data. The server runs just fine and I can spawn creatures and all - It's just impossible for me to edit a creatures spawn and such without that access

@Micha - Making new thread with response

Link to comment
Share on other sites

FIRST! WHAT'S THE DEAL?

Thing is, I came back after ~2months offtime. Went into Git Extensions as usual and updates the core - yay. Started server and all, could run just fine. shut it down, Re-compiled. Got a million errors. Tried to fix them over ~6-7 hours. Finally gave up and decided "Fuck it, starting from scratch" - Backupped EVERYTHING, cleared out mysql etcetc. Download whole new core, did the appropiate things in Cmake and such (Simply followed wiki exactly by it's words, as I've done often)

No problems, Server starts fine - Except I can't see the data in "Creature" table due to topic-name error.

- What is your O.S. version?

Windows XP?

- What is your core version? (There is no "last version", on somedays we can do more than 1 commit, so post your correct core version)

Commit hash: cd7060c65adfaafe22c67bce065e2358f158e932

Commit date: 6 hours ago (sep 24 16:41:50 2011)

- Where did you grab it?

https://github.com/T...TrinityCore.git

- Did you compiled yourself?

Yep. Have compiled servers A LOT (following the official wiki, ofcourse)

- Do you have all dependency's correctly installed?

Everything that's needed, by default, is installed. Server can run, open and progress with no errors (apart from the one this thread iss about)

- What are their versions? (Same as the core, each linux flavour (by example) has his owns versions. So even if you are on windows, tell us the versions)

Uhm...

Git 1.7.3.1

KDiff3

GitExtensions

Cmake 2.8

Visual Studios C++ 10

- Did you Follow our wiki?

Yes.

- Did you correctly updated the databases?

Several times, yes.

- What is your MySQL Server version? (There is no "latest version")

5.5

- What is your MySQL Client Version? (There is no "latest version", and i mean the library's)

Not sure if I understand this one.MySQL starts when I boot up my computer, and I never touch a client. Have run a server for months with no problems

- Is your MySQL correctly configured and running?

Yes.

- What is your MySQL client? (SQLyog? MySQL command line? etc.. NOTE: please, don't use navicat)

HeidiSQL by default - Using registered SQLYog for huge imports, and in case I get errors in Heidi

- Did you opened the necessary ports?

Server is not public - Currently Alpha / Testing through 127.0.0.1 /hamachi - Others CAN connect

- Do you have any custom patches in the core? Which ones? Did you try without them?

No.

- What is your wow client version? Did you extracted the necessary files from it?

Maps, Buildings, Vmaps, DBC's etcetc

To [email protected]@@

Rightclick World Table

Drop... Table

Click on [email protected] --> Open Queries Tab --> Insert "sql/create.sql" (parts:

GRANT USAGE ON * . * TO 'trinity'@'localhost' IDENTIFIED BY 'trinity' WITH MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 ;

CREATE DATABASE `world` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;

GRANT ALL PRIVILEGES ON `world` . * TO 'trinity'@'localhost' WITH GRANT OPTION;

Press F5. World table is now there.

shut down HeidiSQL --> Reopen Heidisql

Open queries

Insert TDB_full_335.11.42_2011_08_27.sql into queries and run (77.0MB) - Wait while it chugs through everything without errors

Done - Press F5

Open world database.

Click Creature table

Click Data tab --> Error "Sql Error (1054): Unknown Column 'deathstate' In 'where Clause'"

When inserting the official TDB with SQYog I get an error before it loads:

Query:

alter table `playercreateinfo` add column taximask text(255)

Error occured at:2010-11-19 03:37:35

Line no.:1

Error Code: 1060 - Duplicate column name 'taximask'

Query:

REPLACE INTO `creature` (`guid`, `id`, `map`, `spawnMask`, `phaseMask`, `modelid`, `equipment_id`, `position_x`, `position_y`, `position_z`, `orientation`, `spawntimesecs`, `spawndist`, `currentwaypoint`, `curhealth`, `curmana`, `DeathState`, `MovementType`, `npcflag`, `unit_flags`, `dynamicflags`) VALUES (6732, ... blabla

blabla... , 0, 0, 0, 0, 0)

Error occured at:2011-09-24 22:34:32

Line no.:16

Error Code: 1054 - Unknown column 'DeathState' in 'field list'

If I forgot anything, just reply :)

Thanks in advance

Trauze

Edited by Trauze
Link to comment
Share on other sites

@Athena - Can't even import the TDB in SQLYog - made a new thread, please look it through if you have time. Thanks

Edit; found the "Data" in SQLYog - Thanks! I can indeed see the creature table without any error (But why would I get an error if I can't even import the data anyways? :s)

Might be Heidisql just raping all the dataz tho

Edited by Trauze
Link to comment
Share on other sites

Hello,

I had the same problem a while back, was another error with a different column.

However, 'Deathstate' doesnt exist in the creature table, nor any other table that im aware of. I have the same version loaded TDB_full_335.11.42_2011_08_27.

So im afraid you may have to do what I did, delete SQL from the machine and reload it in other directory.

For some reason it caches certain tables and this is an issue that some get and MySQL doesn't want to claim.

Another method I did, was installed mysql on another machine (with ibdata), then copied the entire DB back to my dev machine after importing all the necassary updates.

Also be sure to make changes or modifications to your my.ini file.

Was a Bitch, but that did the trick.

Good Luck

Link to comment
Share on other sites

  • 2 weeks later...

Hi i have a problem with running worldserver.exe. When i run it i get to Initialize data stores and then worldserver gets not responding.

Server Log

2011-10-09 22:14:32 Using configuration file worldserver.conf.

2011-10-09 22:14:32 TrinityCore rev. 2011-10-09 14:04:21 +0200 (3b4b6a2d9ab8) (Win32, Release) (worldserver-daemon)

2011-10-09 22:14:32 <Ctrl-C> to stop.

2011-10-09 22:14:32  ______					   __

2011-10-09 22:14:32 /\__  _\	   __		  __/\ \__

2011-10-09 22:14:32 \/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __

2011-10-09 22:14:32    \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \

2011-10-09 22:14:32	 \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \

2011-10-09 22:14:32	  \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \

2011-10-09 22:14:32	   \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \

2011-10-09 22:14:32								  C O R E  /\___/

2011-10-09 22:14:32 http://TrinityCore.org				    \/__/

2011-10-09 22:14:32 Realm running as realm ID 1

2011-10-09 22:14:32 Using World DB: TDB 335.11.41

2011-10-09 22:14:32 Using creature EventAI: TDBAI 335.0.3

2011-10-09 22:14:32 Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.

2011-10-09 22:14:32 Using DataDir ./

2011-10-09 22:14:32 WORLD: VMap support included. LineOfSight:1, getHeight:1, indoorCheck:1 PetLOS:1

2011-10-09 22:14:32 WORLD: VMap data directory is: ./vmaps

2011-10-09 22:14:32

2011-10-09 22:14:32 Loading Trinity strings...

2011-10-09 22:14:32 >> Loaded 899 Trinity strings from table trinity_string in 15 ms

2011-10-09 22:14:32

2011-10-09 22:14:32 Initialize data stores...

Server properties my OS: win7 ultimate x64 * TrinityCore rev. hash : 2baac877dfbe * TrinityCore rev. date : 2011-10-06 18:40:58 +0100 Server grabbed by github and compiled by my self. I have OpenSSL light 1.0.0e, Git extensions complete v2.2.4, mysql 5.1 essentials and gui tools, vcredist_x64 and visual c++ 2008 express edition. All was done by following your wiki. Mysql versions is 5.1.59 nad mysql gui tools is 5.0-r17.(running) all ports for trinity are allowed. I dont have custom patches. Crash Log
Revision: TrinityCore rev. 2011-10-09 14:04:21 +0200 (3b4b6a2d9ab8) (Win32, Release)

Date 9:10:2011. Time 21:54

//=====================================================

*** Hardware ***

Processor: Intel(R) Core(TM)2 Duo CPU	 T5800  @ 2.00GHz

Number Of Processors: 2

Physical Memory: 2095544 KB (Available: 387972 KB)

Commit Charge Limit: 4191088 KB

*** Operation System ***

Windows Vista or Windows Server 2008 Professional (Version 6.1, Build 7600)

//=====================================================

Exception code: C0000005 ACCESS_VIOLATION

Fault address:  741DE1E3 01:0003D1E3 C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.4926_none_508ed732bcbc0e5a\MSVCR90.dll

Registers:

EAX:00000000

EBX:01992108

ECX:7423A2C0

EDX:00000003

ESI:759CC069

EDI:00000000

CS:EIP:0023:741DE1E3

SS:ESP:002B:00C9D770  EBP:00C9D790

DS:002B  ES:002B  FS:0053  GS:002B

Flags:00010283

Call stack:

Address   Frame	 Function	  SourceFile

741DE1E3  00000000  strtod+84

741DE428  00000000  strtoul+27

01436601  00000000  0001:00115601 D:\Build\bin\Release\worldserver.exe

742573AF  00000000  [email protected][email protected][email protected]@[email protected]@[email protected]@[email protected]@[email protected]@[email protected]@@Z+11

0143AD60  00000000  0001:00119D60 D:\Build\bin\Release\worldserver.exe

00C9D8CC  00000000  0000:00000000

0BA05780  00000000  0000:00000000

70532F63  00000000 

If i forgot to add some info say me i will write.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Rochet2
      A lot of people have asked how to debug so I made this short guide on how to set up debugging.
      This guide only tells you how to actually set up debugging in TrinityCore on Windows and Linux.
      This will not explain the basics of debugging. You can google those or play around with the debugger to learn.
      Here are a few videos that explain how to actually debug after setting debugging up on visual studio: https://youtu.be/0ebzPwixrJA and linux: https://www.youtube.com/watch?v=sCtY--xRUyI

      This guide contains multiple guides. Each list of bullet points is it's own guide.
      Make sure you can run the server normally before trying to debug.

      Windows:
      On Windows before anything you should check these
      - Before debugging or making crashlogs etc. with Visual Studio you must compile the core in "Debug" instead of "Release". You can select this in "Build>Configuration Manager" or at the top of Visual Studio window http://i.imgur.com/5oHd59j.png
      - You also need to move the new pdb files generate by compiling in debug mode on Visual Studio from the compile output folder (bin) to your server folder - these files contain information needed for debugging.
      - It is assumed that Solution Explorer is open. Open it by selecting "View>Solution Explorer" in Visual Studio http://i.imgur.com/hkW6Gk0.png
      -- You may want to click on the Home icon to reset the view on Solution Explorer http://i.imgur.com/N8UPwDh.png
      - You can place breakpoints in Visual Studio editor by right clicking a line of code and selecting "Breakpoint>Insert Breakpoint" http://i.imgur.com/L2TxBVG.png
      - At the top of the window you should see controls for stepping and continuing when you have started to debug.
      - Here is a video showing the basic Visual Studio functionality https://www.youtube.com/watch?v=Ijdk4z8-2OI
      Fastest way to debug on windows. This is the easiest way to start up debugging a script.
      - Start the authserver and worldserver normally
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In Visual Studio at the top select "Debug>Attach to process...>worldserver.exe" and click "Attach" http://i.imgur.com/jDEI2Hq.png
      - You are now debugging
       
      The second slower way of debugging on windows. This is useful for debugging something that occurs in the startup of the server.
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In solution explorer right click on worldserver and select "Set as StartUp Project" http://i.imgur.com/wvMzeRA.png
      - In solution explorer right click on worldserver and select "Properties" http://i.imgur.com/rTNEF9O.png
      -- In Properties you should go to "Configuration Properties>Debugging" and edit "Working Directory" to point to the server folder. For me this is the default compile folder so I use "$(OutDir)" http://i.imgur.com/aRI29fB.png
      - Start the authserver normally
      - Start the worldserver by selecting "Debug>Start Debugging". The server will start with debugging attached from the beginning http://i.imgur.com/cg1KJNw.png
      - You are now debugging
      Crashlogs on windows. Once you have a way to reproduce a crash you can get a crashlog that can help you resolve it.
      - After compiling the core in "Debug" instead of "Release" start up the worldserver and authserver
      - Reproduce the crash you have
      - In the server folder there is now a folder called Crashes that contains txt and dmp files. http://i.imgur.com/9eQIdql.png
      - You can open the txt files in text editors http://i.imgur.com/EH6R17E.png
      -- At the top of a txt file there is some information about your system and below it there is the Call Stack and below that there are Variables of each part of the call stack
      -- The Call Stack will tell you at the top what was the last function call before crashing and what function calls led to that function call.
      -- Next to the function names there is the file that the function is defined in and the line number the code was executing in that function.
      -- In the Variables section you can inspect variables that were present at each function call.
      -- Based on this information you are often able to see what crashed or get a better view of what you need to inspect more in your code.
      - The dmp file can be opened in Visual Studio
      -- Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      -- Drag and drop the dmp file to Visual Studio
      -- In the window that opens click to "Debug with Native Only" http://i.imgur.com/OgyU2kM.png
      -- In the window popup click "Break" http://i.imgur.com/4jDzqRn.png
      -- You are now in a state like you would have hit a break point in the code or a crash while debugging. You can inspect the call stack and the variables.
      Edit and continue on windows. When debugging this allows you to change the code and without restarting the server apply those changes so they actually work ingame.
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In solution explorer right click on worldserver and select "Properties" http://i.imgur.com/rTNEF9O.png
      -- In Properties select "Configuration Properties>Linker>General" and set "Enable Incremental Linking" to "Yes". http://i.imgur.com/caQqwN5.png
      -- In Properties select "Configuration Properties>Linker>Advanced" and set "Image Has Safe Exception Handlers" to "No". http://i.imgur.com/FYzN8Ks.png
      -- In Properties select "Configuration Properties>C/C++>General" and set "Debug Information Format" to "Program Database for Edit And Continue". http://i.imgur.com/pxQ6I8N.png
      - At the top of the window select "Tools>Options". In the Options select "Debugging>General" and in there select "Enable Edit and Continue", "Enable Native Edit and Continue" and "Require source files to exactly match the original version".
      - Compile the server for the changes to take effect.
      - Set up "The second slower way of debugging" (I did not test edit and continue on other configurations)
      - Start the authserver normally
      - Start the worldserver by selecting "Debug>Start Debugging".
      - Try edit a cpp file a little and save it.
      - At top of Visual Studio window select "Debug>Apply Code Changes" and wait until the changes are applied. Warning: it can take considerable amount of time for the changes to be applied. http://i.imgur.com/77pb58E.png
      - If you have issues, be sure to check the error messages in Output. You can view it by selecting "View>Output" http://i.imgur.com/4cIznW9.png
      - This guide was written based on https://msdn.microsoft.com/en-us/library/esaeyddf.aspx and https://blogs.msdn.microsoft.com/vcblog/2015/07/22/c-edit-and-continue-in-visual-studio-2015/
      Linux:
      First we need to compile the server in debug mode.
      - Compile the server with the cmake flag -DCMAKE_BUILD_TYPE=Debug

      Debugging on linux. You can debug on linux by using GDB.
      - Here is a good video about it: https://www.youtube.com/watch?v=sCtY--xRUyI
      - Basically you
      -- Start the authserver
      -- Start the worldserver by using "gdb ./worldserver"
      -- Enter breakpoints by using break command on gdb
      -- Use the run command on gdb to start the server
      -- You are now debugging
      - You may also be interested in using VScode or some other more visual debuggers. https://www.youtube.com/watch?v=B0xTgyCwsAo
      Crashlogs on linux. Once you have a way to reproduce a crash you can get a crashlog that can help you resolve it.
      - Take crashreport.gdb from /contrib/debugger from source folder and place it to your server folder
      - Start the authserver
      - Start the worldserver by using "gdb -x crashreport.gdb ./worldserver"
      - Reproduce your crash
      - There should be a backtrace.log in your server folder that contains information about the crash like the callstack and variables in each function call in the call stack
      - This guide was written based on https://github.com/TrinityCore/TrinityCore/blob/master/contrib/debugger/README
      Running valgrind on linux. This helps you find memory errors like invalid reads and writes and memory leaks.
      - Here is a good video about it: https://www.youtube.com/watch?v=fvTsFjDuag8
      - Basically you
      -- Start the authserver
      -- Start the worldserver by using "valgrind ./worldserver"
      -- Run your code that you want to analyze and close the server
      -- The console or an output log should contain the valgrind log
    • By reyne
      Hey there!

      I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
      After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

      `Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

      This repeats for every line in Expansion01, and then the extractor crashes.

      I'm not sure where else to go from here.

      Thanks for your help

      Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.
    • By Uee
      I recently found the Trinity Cataclsym Preservation Project and thought I will try it out.
      I am already running 3.3.5a and Master - both server run great
      Pulled 4.3.4 down using Git and built it same way as others:
      boost_1_73_0 cmake 3.17.2 Mysql 5.7.30 VS Community 2019 Built fine - no issue. Used 'Extractor.bat' to run all the map extractors - worked great!
      Noticed there was extra file 'connection_patcher.exe`, ran that - worked great! Now have "wow_patched" and use this to launch client
      MySQL runs in standalone mode, -initialize, added base sql files, imported, auth and character sql files
      Configured both the .conf files and passwords, IPs etc are all in place.
      Note: When loading the exe and built conf file, bnetserver complain about these items missing, so I add them:
      Updates.AutoSetup = 1 Updates.EnableDatabases = 0 LoginDatabase.SynchThreads = 1 Load up Mysql - loads fine
      Load up bnetserver and appears to load ok - last few lines look like this:
      Connected to MySQL database at 127.0.0.1
      DatabasePool 'auth' opened successfully. 2 total connections running.
      Started auth database connection pool.
      Listening on connections from worldservers on port 1118...
      Load up worldserver and it adds the FULL world and hotfixes, then applied all updates (confirmed archived in SQL) - last few lines look like this:
      Calculate next monthly quest reset time...
      Calculate random battleground reset time...
      Calculate guild limitation(s) reset time...
      Calculate next currency reset time...
      World initialized in 0 minutes 13 seconds
      TrinityCore rev. d0c7bbab40bc 2020-05-06 00:01:21 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon) ready...
       
      There are no db errors in logs.
      Config.wtf contain portal, realmlist as remote server and patchlist as localhost.
      When I try to connecting using "[email protected]" and password I get immediately disconnected.
      What I did noticed different is that the bnetserver doesnt add "Added realm "Battle for Azeroth" at 192.168.10.213:8085." (From my Master log) 
      3.3.5a also have this line as last line in authserver - but 4.3.4 is not giving me this one.
      Realmlist table is accurate with right information.
      Anyone know why bnetserver is not starting me realm?
       
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
×
×
  • Create New...