Jump to content
TrinityCore
Apple

"unknown column" "missing table" "duplicate column" error / sql problems / SQLDriverLogFile < answer on 1st post of 1st page

Recommended Posts

[email protected]:~/build$ screen -AmS mk_tri

                                 C O R E  /\___/

http://TrinityCore.org                    \/__/


Daemon PID: 27294


Opening databasepool 'world'. Async threads: 1, synch threads: 1

MySQL client library: 5.0.51a

MySQL server ver: 5.0.51a-24+lenny5

Connected to MySQL database at 127.0.0.1

MySQL client library: 5.0.51a

MySQL server ver: 5.0.51a-24+lenny5

Connected to MySQL database at 127.0.0.1

Databasepool opened succesfuly. 2 total connections running.

Opening databasepool 'characters'. Async threads: 1, synch threads: 2

MySQL client library: 5.0.51a

MySQL server ver: 5.0.51a-24+lenny5

Connected to MySQL database at 127.0.0.1

[ERROR]: In mysql_stmt_prepare() id: 177, sql: "DELETE FROM game_event_save WHERE eventEntry = ?"

[ERROR]: Unknown column 'eventEntry' in 'where clause'

~DatabaseWorkerPool for ''.

~DatabaseWorkerPool for 'characters'.

~DatabaseWorkerPool for 'world'.


Cannot find a Solution. Google got me no Reasons/Solutions

Please Help Me :(

Share this post


Link to post
Share on other sites

In the commit, the file https://github.com/TrinityCore/TrinityCore/blob/90a3fee2329571863e907315fc6b5bfc7d1c96f5/sql/updates/auth_char/2011_03_18_0_characters_game_event_misc.sql does not have the DROP TABLE for the temp table.

Share this post


Link to post
Share on other sites

--- Canned message start

It appears the issue in the original post was solved, so this thread shall be closed. Should you encounter any other difficulties, please open a new thread.

--- Canned message end ---

Share this post


Link to post
Share on other sites

I have the newst core rev.

..

...

Initialize game time and timers

Starting Map System

Starting Game Event system...

Player::DeleteOldChars: Deleting all characters which have been deleted 30 days before...

Starting Arena Season...

Speicherzugriffsfehler

Why this? All updates are in the Database...

Share this post


Link to post
Share on other sites

Pls help =( 70 Users on my server waiting ...

When i start the Server comes this:

ERROR: [1054] Unknown column 'eventEntry' in 'field list'

_HandleMySQLErrno

But i have updated the DB

Edited by juke

Share this post


Link to post
Share on other sites

Hi, i have latest revision downloaded, compiled, but when i run worldserver.exe, i get a lot of this line:

Creature (GUID: 14145) does not exist but has a record in `creature_addon`

Something wrong in the db, maybe an update that i did not applied??
Loading Creature Data...

SQL: SELECT creature.guid, id, map, modelid,equipment_id, position_x, position_y

, position_z, orientation, spawntimesecs, spawndist, currentwaypoint,curhealth,

curmana, DeathState, MovementType, spawnMask, phaseMask, eventEntry, pool_entry,

creature.npcflag, creature.unit_flags, creature.dynamicflags FROM creature LEFT

OUTER JOIN game_event_creature ON creature.guid = game_event_creature.guid LEFT

OUTER JOIN pool_creature ON creature.guid = pool_creature.guid

ERROR: [1054] Unknown column 'eventEntry' in 'field list'

MySQLConnection::_HandleMySQLErrno

>> Loaded 0 creatures. DB table `creature` is empty.

My creature table is NOT empty.

I had a patched server with wowarmory from getmangos community forum, after i updated the source, and compiled it i got these lines, and every creatures are disappeared from the world, however they are exists in the db.

Any idea?

Edited by kenny_evo

Share this post


Link to post
Share on other sites

Hello there,

I'm attempting to use the Wiki instructions to create a Trinity server. I'm running 64 bit Windows 7 (on my server) and using mysql-5.5.10-winx64 and HeidiSQL 6.0. I'm not sure how to tell what the TrinityCore revision is, I used the git application just yesterday if that helps. The database files are labeled TDB_335.11.38_2011_03_05. I've not altered anything with custom code or anything else.

The problem I'm having is with the following instructions:

The following steps are done using your database management program (ex. HeidiSQL or SQLYog)

1. Create the three databases by importing C:\Trinity\sql\create\create_mysql.sql. You now have three databases - auth, characters, and world.

2. Import auth database structure by importing C:\Trinity\sql\base\auth_database.sql to the auth DB.

3. Import characters database structure by importing C:\Trinity\sql\base\character_database.sql to the characters DB.

4. Unrar C:\TDB\TDB_335.11.38_2011_03_05.rar and import world DB structure and contents by importing TDB_335.11.38_2011_03_05.sql to the world DB.

I'm not an expert at Databases and I'm very confused at what this means. Can anyone provide click-by click instructions on how to "import" a sql file?

When I do Import > Load SQL file... and open the file, nothing appears to happen. Do I need to click the Run button for it to work? I've tried that and it "does stuff" but when I get to the next part where I'm supposed to import updates to the characters database, when I try to load 2011_03_11_0_characters_channels.sql and "run" it I get an error saying "SQL Error (1054): Unknown column 'm_name' in 'channels'" which makes me think I'm doing something wrong.

I've previously set up a Trinity server on this computer using the very explicit instructions here: http://www.mmowned.com/forums/world-of-warcraft/emulator-servers/guides-tutorials/285921-guide-how-compile-trinitycore-start-finish.html . But those instructions are now out-of-date and among other things said to use Navicat, which the Wiki says not to use. Still, the level of detail in those instructions are pretty much what I need given my lack of understanding of all things sql.

Thank you in advance for your assistance. If there's any details you need to know that I left out, please let me know.

Share this post


Link to post
Share on other sites

Right click on your database........click import...

There is nothing called "import" when I right click on a database.

In the right click menu, the options are Edit, drop, empty table(s), run routines(s), Create new, Export database as SQL, Maintenance, Find text on server, Bulk table editor, Expand all, collapse all, display size of objects, select session background color, print, refresh.

There is no "import".

Share this post


Link to post
Share on other sites

There is nothing called "import" when I right click on a database.

In the right click menu, the options are Edit, drop, empty table(s), run routines(s), Create new, Export database as SQL, Maintenance, Find text on server, Bulk table editor, Expand all, collapse all, display size of objects, select session background color, print, refresh.

There is no "import".

Try SQLyog

Share this post


Link to post
Share on other sites

when I get to the next part where I'm supposed to import updates to the characters database, when I try to load 2011_03_11_0_characters_channels.sql and "run" it I get an error saying "SQL Error (1054): Unknown column 'm_name' in 'channels'" which makes me think I'm doing something wrong.

Please paste the section of the wiki that says you are to install updates to the auth or characters DBs after a fresh install -- you don't.

The base auth / characters DBs in sql/base are always up to date with the latest rev of the core. So if you are installing from scratch, you never apply updates.

-- Brian

Share this post


Link to post
Share on other sites

Try SQLyog

Considering the HeidiSQL is the one labeled "good for beginners" I think I'd rather figure out how to use it. Or is the Wiki advice in error?

Please paste the section of the wiki that says you are to install updates to the auth or characters DBs after a fresh install -- you don't.

The base auth / characters DBs in sql/base are always up to date with the latest rev of the core. So if you are installing from scratch, you never apply updates.

-- Brian

Alright that makes sense, I didn't comprehend the instructions to not update anything but world for a fresh install. Thanks. What is the proper import procedure though... was I doing it right?

Edited by Chaisy

Share this post


Link to post
Share on other sites

Considering the HeidiSQL is the one labeled "good for beginners" I think I'd rather figure out how to use it. Or is the Wiki advice in error?

http://xkcd.com/627/

And I am wondering if the problem is in the documentation or in the people that only read half of it.

Share this post


Link to post
Share on other sites

Alright that makes sense, I didn't comprehend the instructions to not update anything but world for a fresh install. Thanks. What is the proper import procedure though... was I doing it right?

We have made it about as easy as it can get...

When you download the full DB and import it, you then apply ALL the SQL in order that is in the sql/updates/world directory.

Every time a new full DB is dumped, all the SQL that was included in that full DB is moved to the sql/old dir (in case people that are just updating their DB and not reloading from scratch need the updates).

So -- again -- simple steps:

1 - load full DB

2 - import ALL SQL in sql/updates/world in order

3 - ???

4 - PROFIT!

(it is sad how true #4 is for so many people that use (abuse?) our code)

-- Brian

EDIT:

Simple steps to *keep* your DB updated:

1 - make sure that you keep track of the last update you applied to all 3 DBs

2 - when you compile a new rev of Trinity install ALL the updates from the last version you were on (this is where you need to check sql/old/3.3.5a to make sure there wasn't a full DB released between the last version you were on, and the one you are upgrading to)

3 - Since you are updating and not installing from scratch, you need to do that for all DBs (if there were updates for auth / characters). The auth / characters updates are in sql/updates/auth_char

Share this post


Link to post
Share on other sites

I felt this needed its own post...

Back to updating (a lot of people may not know this).

If you are on rev 11234 (yes, I am using old school rev numbers here) and there are no C++ code updates (only SQL DB updates between the rev you were on and the rev you are going to) you only need to apply the SQL and not recompile your core.

Here is problem with that though.. when you compile, a program gets run that gets your "easy to look at 11111 style version number" and includes it into the compile. So, if you only install the DB updates, then when you start you core it will still say 11234 even though you may be on rev 11333.

My advice is to compile the core again even if there are no code changes. It will help you know what rev you are on.

-- Brian

Share this post


Link to post
Share on other sites

Thanks for the responses everyone.

http://xkcd.com/627/

And I am wondering if the problem is in the documentation or in the people that only read half of it.

If you look at the mmowned link I put in my original post, scroll down to where it says "Now open up Navicat." Below that is the level of detail that could have avoided me making this thread. Just a FYI. My problem wasn't really with your instructions, but with my unfamiliarity with HeidiSQL, which I'm of course going to choose because it was the beginners option. Hopefully I'll be up and running on 3.3.5a Real Soon Now.

4 - PROFIT!

Well if its any relief to you I'm only making a machinima server that will never appear on the internet (and will never result in anything being sold). I think that is consistent with the trinity core philosophy if I've read the FAQs correctly.

Edited by Chaisy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Hydra_Btforce
      Just finished download & compile fresh trinitycore 4.3.4  From : https://gitlab.com/trinitycore/TrinityCore_434/tree/4.3.4
       
      Creating World database from : https://github.com/TrinityCoreLegacy/TrinityCore/releases
      Downloading the lasted one & create new database named World
      Navigate to my repo applying sql/updates/world/4.3.4
      Trying to apply all updates but an error occurred while applying updates
      And if i don't apply all updates the world is totally bugged and items/creature are missing.
       
      Please help
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
    • By Cantte
      Well ... today I was about to compile the trinity core version for WoW 4.3.4 of this repository "https://gitlab.com/trinitycore/TrinityCore_434". Download them and when you use the cmake, I generate the solution correctly. When I began to compile this went well until I got to the last step, when I was 90% practically.
      This was the error:
      Main.obj: error LNK2019: external symbol SSLeay_version unresolved referred to in the function "public: void __cdecl <lambda_4a2d53ce610f18dba0b4b4d6532c13a7> :: operator () (void) const" (?? R <lambda_4a2d53ce610f18dba0b4b4d6532c13a7> @@ QEBAXXZ)
      25> scripts.lib (cs_server.obj): error LNK2001: external symbol SSLeay_version unresolved
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_num external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_value external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_pop_free external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: outer symbol OPENSSL_add_all_algorithms_noconf unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_load_error_strings unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved external SSLv23_method symbol referenced in the ssl_auth_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_library_init unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_state unresolved referenced in the tcp_connect function
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_num_locks unresolved referred to in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_set_locking_callback unresolved referred to in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_THREADID_set_numeric unresolved referred to in the function "void __cdecl threadIdCallback (struct crypto_threadid_st *)" (? ThreadIdCallback @@ YAXPEAUcrypto_threadid_st @@@ Z)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_THREADID_set_callback unresolved referenced in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (ARC4.obj): error LNK2019: external symbol EVP_CIPHER_CTX_init unresolved referred to in the function "public: __cdecl ARC4 :: ARC4 (unsigned int)" (?? 0ARC4 @@ QEAA @ I @ Z)
      25> common.lib (HmacHash.obj): error LNK2019: unresolved HMAC_CTX_init external symbol referenced in the "struct hmac_ctx_st * __cdecl HMAC_CTX_new (void)" function (? HMAC_CTX_new @@ YAPEAUhmac_ctx_st @@ XZ)
      25> common.lib (HmacHash.obj): error LNK2019: unresolved HMAC_CTX_cleanup external symbol referenced in the "void __cdecl HMAC_CTX_free (struct hmac_ctx_st *)" function (? HMAC_CTX_free @@ YAXPEAUhmac_ctx_st @@@ Z)
      25> E: \ Server-Wow \ TrinityCore_434-4.3.4 \ Build \ bin \ RelWithDebInfo \ worldserver.exe: fatal error LNK1120: 16 external unresolved
      25> Compilation of the "worldserver.vcxproj" project completed - ERROR.
      26> ------ Compile operation started: project: ALL_BUILD, configuration: RelWithDebInfo x64 ------
      26> Building Custom Rule E: /Server-Wow/TrinityCore_434-4.3.4/CMakeLists.txt
      26> CMake does not need to re-run because E: /Server-Wow/TrinityCore_434-4.3.4/Build/CMakeFiles/generate.stamp is up-to-date.
      ========== Compile: 23 correct, 3 incorrect, 0 updated, 0 omitted ==========
       
      And this is the original error in Spanish (since I use the compiler in Spanish)
       
      Main.obj : error LNK2019: símbolo externo SSLeay_version sin resolver al que se hace referencia en la función "public: void __cdecl <lambda_4a2d53ce610f18dba0b4b4d6532c13a7>::operator()(void)const " (??R<lambda_4a2d53ce610f18dba0b4b4d6532c13a7>@@QEBAXXZ)
      25>scripts.lib(cs_server.obj) : error LNK2001: símbolo externo SSLeay_version sin resolver
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_num sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_value sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_pop_free sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo OPENSSL_add_all_algorithms_noconf sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_load_error_strings sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSLv23_method sin resolver al que se hace referencia en la función ssl_auth_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_library_init sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_state sin resolver al que se hace referencia en la función tcp_connect
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_num_locks sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_set_locking_callback sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_THREADID_set_numeric sin resolver al que se hace referencia en la función "void __cdecl threadIdCallback(struct crypto_threadid_st *)" ([email protected]@[email protected]@@Z)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_THREADID_set_callback sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(ARC4.obj) : error LNK2019: símbolo externo EVP_CIPHER_CTX_init sin resolver al que se hace referencia en la función "public: __cdecl ARC4::ARC4(unsigned int)" ([email protected]@[email protected]@Z)
      25>common.lib(HmacHash.obj) : error LNK2019: símbolo externo HMAC_CTX_init sin resolver al que se hace referencia en la función "struct hmac_ctx_st * __cdecl HMAC_CTX_new(void)" ([email protected]@[email protected]@XZ)
      25>common.lib(HmacHash.obj) : error LNK2019: símbolo externo HMAC_CTX_cleanup sin resolver al que se hace referencia en la función "void __cdecl HMAC_CTX_free(struct hmac_ctx_st *)" ([email protected]@[email protected]@@Z)
      25>E:\Server-Wow\TrinityCore_434-4.3.4\Build\bin\RelWithDebInfo\worldserver.exe : fatal error LNK1120: 16 externos sin resolver
      25>Compilación del proyecto "worldserver.vcxproj" terminada -- ERROR.
      26>------ Operación Compilar iniciada: proyecto: ALL_BUILD, configuración: RelWithDebInfo x64 ------
      26>Building Custom Rule E:/Server-Wow/TrinityCore_434-4.3.4/CMakeLists.txt
      26>CMake does not need to re-run because E:/Server-Wow/TrinityCore_434-4.3.4/Build/CMakeFiles/generate.stamp is up-to-date.
      ========== Compilar: 23 correctos, 3 incorrectos, 0 actualizados, 0 omitidos ==========
       
       
      Thanks.
    • By Fyury
      When I run "worldserver.exe" it just crashes and I get this:
      TrinityCore rev. 084da48ba15a 2018-05-26 18:48:09 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
      <Ctrl-C> to stop.
       ______                       __
      /\__  _\       __          __/\ \__
      \/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
         \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
          \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
           \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
            \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                       C O R E  /\___/
      http://TrinityCore.org                    \/__/
      Using configuration file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf.
      Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.1e 11 Feb 2013)
      Using Boost version: 1.65.1
      Updating Auth database...
      >> Auth database is up-to-date! Containing 6 new and 115 archived updates.
      Updating Character database...
      >> Character database is up-to-date! Containing 3 new and 77 archived updates.
      Updating World database...
      >> World database is up-to-date! Containing 193 new and 2262 archived updates.
      Updating Hotfixes database...
      >> Hotfixes database is up-to-date! Containing 18 new and 130 archived updates.
      Realm running as realm ID 1
      Using World DB: TDB 735.00
      Using enUS DBC Locale
      Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
      Using DataDir ./
      WORLD: MMap data directory is: ./mmaps
      VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
      VMap data directory is: ./vmaps
      Missing name Guild.SaveInterval in config file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf, add "Guild.SaveInterval = 15" to this file
      Initialize PlayerDump...
      >> Initialized 370 PlayerDump ColumnDefinitions in 551 ms.
      Loading Trinity strings...
      >> Loaded 965 trinity strings in 32 ms
      Initialize data stores...
      Some required *.db2 files (2 from 230) not found or not compatible:
      ItemSearchName.db2
      WorldSafeLocs.db2
       
       
      ItemSearName.db2 & WorldSafeLocs.db2 dont exist but how can I get them
      When I start "mapextractor.exe" this happens:
       
      Unable to open file DBFilesClient\ItemSearchName.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\Unittest.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\WorldSafeLocs.db2 in the archive for locale enUS: FILE_NOT_FOUND
       
×
×
  • Create New...