Jump to content
TrinityCore

"unknown column" "missing table" "duplicate column" error / sql problems / SQLDriverLogFile < answer on 1st post of 1st page


Apple
 Share

Recommended Posts

That level of detail also makes the guide obsolete more quickly, as you yourself pointed out. If you can't figure out how to apply sqls to your db, maybe you are not in the target audience tc is looking to support, and should give up.

Everyone has to learn at some point, unless you think some people were born knowing how it works. What's wrong with learning it here? Your attitude is thoroughly unhelpful, I'm glad I see that you're only a user and not a dev.

That guide I linked is obsolete because 1) its for 3.3.3a, not 3.3.5a, and 2) it recommends using Navicat which the guide here says specifically not to use. So your assertion is false, the higher level of detail I requested would not obsolete it quicker. What's more likely to change, the method sqls are added to databases, or the version of the WoW client that Trinitycore is currently supporting? In any case, that mmowned guide I linked, obsolete or not, still helped me solve numerous problems with this new install that I didn't bring to this thread (for example, how to add new player accounts and give them privileges).

I got the server up and running very late last night (or early this morning). Thanks again for the help. If I one day become an expert at all this, I'll come back and edit the wiki myself so future people won't make the same mistakes I did.

Edited by Chaisy
Link to comment
Share on other sites

Not that I have any interest in using it, but is there any documented evidence of the ineptitude of Navicat, or is it not recommended because of past personal experience? It seems almost the entirety of AC-Web and MMOwned swear by it, and even though that would be enough for me not to use it, there has to be a reason why so many prefer it. It's a bit difficult to Google data like this on software these days when the internet is filled with download links to torrents and such.

Just curious.

Link to comment
Share on other sites

______ __

/\__ _\ __ __/\ \__

\/_/\ \/ _ __ /\_\ ___ /\_\ \ ,_\ __ __

\ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \

\ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \

\ \_\ \_\ \ \_\ \_\ \_\ \_\ \__\\/`____ \

\/_/\/_/ \/_/\/_/\/_/\/_/\/__/ `/___/> \

C O R E /\___/

http://TrinityCore.org \/__/

SFMT has been enabled as the random number generator, if worldserver

freezes or crashes randomly, first, try disabling SFMT in CMAKE configuration

Opening databasepool 'world'. Async threads: 1, synch threads: 1

MySQL client library: 5.5.9

MySQL server ver: 5.5.10

[WARNING] MySQL client/server version mismatch; may conflict with behaviour of p

repared statements.

MySQL client library: 5.5.9

MySQL server ver: 5.5.10

[WARNING] MySQL client/server version mismatch; may conflict with behaviour of p

repared statements.

Databasepool opened succesfuly. 2 total connections running.

Opening databasepool 'characters'. Async threads: 1, synch threads: 2

MySQL client library: 5.5.9

MySQL server ver: 5.5.10

[WARNING] MySQL client/server version mismatch; may conflict with behaviour of p

repared statements.

[ERROR]: In mysql_stmt_prepare() id: 154, sql: "INSERT INTO channels(name, team,

lastUsed) VALUES (?, ?, UNIX_TIMESTAMP())"

[ERROR]: Unknown column 'name' in 'field list'

~DatabaseWorkerPool for ''.

~DatabaseWorkerPool for 'characters'.

~DatabaseWorkerPool for 'world'.

Link to comment
Share on other sites

 [ERROR]: In mysql_stmt_prepare() id: 154, sql: "INSERT INTO channels(name, team,

 lastUsed) VALUES (?, ?, UNIX_TIMESTAMP())"

 [ERROR]: Unknown column 'name' in 'field list'

You forgot to apply some sql.

I used to full TBD. I still need to add the previous world sql???

The other sql in the pack are older versions...Correct?

Edited by Alyssia
Link to comment
Share on other sites

hello!

i compile trinity core following the steps of the wiki and i get this error:

Opening databasepool 's0_world'. Async threads: 1, synch threads: 1

MySQL client library: 5.5.10

MySQL server ver: 5.5.10

MySQL client library: 5.5.10

MySQL server ver: 5.5.10

Databasepool opened succesfuly. 2 total connections running.

Opening databasepool 's0_characters'. Async threads: 1, synch threads: 2

MySQL client library: 5.5.10

MySQL server ver: 5.5.10

[ERROR]: In mysql_stmt_prepare() id: 13, sql: "SELECT guid, account, name, race,

class, gender, level, xp, money, playerBytes, playerBytes2, playerFlags,positio

n_x, position_y, position_z, map, orientation, taximask, cinematic, totaltime, l

eveltime, rest_bonus, logout_time, is_logout_resting, resettalents_cost,resettal

ents_time, trans_x, trans_y, trans_z, trans_o, transguid, extra_flags, stable_sl

ots, at_login, zone, online, death_expire_time, taxi_path, instance_mode_mask,ar

enaPoints, totalHonorPoints, todayHonorPoints, yesterdayHonorPoints, totalKills,

todayKills, yesterdayKills, chosenTitle, knownCurrencies, watchedFaction, drunk

,health, power1, power2, power3, power4, power5, power6, power7, instance_id, sp

eccount, activespec, exploredZones, equipmentCache, ammoId, knownTitles, actionB

ars FROM characters WHERE guid = ?"

[ERROR]: Unknown column 'instance_mode_mask' in 'field list'

~DatabaseWorkerPool for ''.

~DatabaseWorkerPool for 's0_characters'.

~DatabaseWorkerPool for 's0_world'.

i can only see the error if i start the program by console, if i clik the .exe no logs appear, only that:

2011-03-27 14:04:07 Using configuration file worldserver.conf.

2011-03-27 14:04:07 TrinityCore Rev: 0 Release Hash: Archive (Win32, little-endian) (core-daemon)

2011-03-27 14:04:07 <Ctrl-C> to stop.

2011-03-27 14:04:07 ______ __

2011-03-27 14:04:07 /\__ _\ __ __/\ \__

2011-03-27 14:04:07 \/_/\ \/ _ __ /\_\ ___ /\_\ \ ,_\ __ __

2011-03-27 14:04:07 \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \

2011-03-27 14:04:07 \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \

2011-03-27 14:04:07 \ \_\ \_\ \ \_\ \_\ \_\ \_\ \__\\/`____ \

2011-03-27 14:04:07 \/_/\/_/ \/_/\/_/\/_/\/_/\/__/ `/___/> \

2011-03-27 14:04:07 C O R E /\___/

2011-03-27 14:04:07 http://TrinityCore.org \/__/

i get the sql files from

world https://github.com/downloads/TrinityCore/TrinityCore/TDB_335.11.38_2011_03_05.rar

characters and auth from https://github.com/TrinityCore/TrinityCore/zipball/3.3.5a-clientsupport

how can i solve this problem?

thanks!

Edited by predicador
Link to comment
Share on other sites

When an SQL client chokes on STANDARD SQL, there is a problem, when an SQL client neglects to apply some tables and tells the user all went well and they end up going to the forum and posting an invalid bug report, there is a problem, when a free community edition of another SQL client works better than the paid for (or pirated) SQL client, there is definitely a problem.

Link to comment
Share on other sites

  • 2 weeks later...

Hi, I have a error very rare with my server Trinity Core 2.

Picture:

[WARNING] MySQL client/server version mismatch: may conflict with behaviour of prepared statements.

Update your MySQL server to the proper version and the prepared statement failures should go away.

Bit

Also, don't post screenshots of errors. It makes it impossible to use the search features.

Edited by bitherd
Link to comment
Share on other sites

[WARNING] MySQL client/server version mismatch: may conflict with behaviour of prepared statements.
Update your MySQL server to the proper version and the prepared statement failures should go away. Bit
bitherd, if you look @ the image you will see that he has the right MySQL version, that is only a warning. But the
[ERROR]: Unknown column 'itemEntry' in 'field list'

means that he missed some DB updates.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Rochet2
      A lot of people have asked how to debug so I made this short guide on how to set up debugging.
      This guide only tells you how to actually set up debugging in TrinityCore on Windows and Linux.
      This will not explain the basics of debugging. You can google those or play around with the debugger to learn.
      Here are a few videos that explain how to actually debug after setting debugging up on visual studio: https://youtu.be/0ebzPwixrJA and linux: https://www.youtube.com/watch?v=sCtY--xRUyI

      This guide contains multiple guides. Each list of bullet points is it's own guide.
      Make sure you can run the server normally before trying to debug.

      Windows:
      On Windows before anything you should check these
      - Before debugging or making crashlogs etc. with Visual Studio you must compile the core in "Debug" instead of "Release". You can select this in "Build>Configuration Manager" or at the top of Visual Studio window http://i.imgur.com/5oHd59j.png
      - You also need to move the new pdb files generate by compiling in debug mode on Visual Studio from the compile output folder (bin) to your server folder - these files contain information needed for debugging.
      - It is assumed that Solution Explorer is open. Open it by selecting "View>Solution Explorer" in Visual Studio http://i.imgur.com/hkW6Gk0.png
      -- You may want to click on the Home icon to reset the view on Solution Explorer http://i.imgur.com/N8UPwDh.png
      - You can place breakpoints in Visual Studio editor by right clicking a line of code and selecting "Breakpoint>Insert Breakpoint" http://i.imgur.com/L2TxBVG.png
      - At the top of the window you should see controls for stepping and continuing when you have started to debug.
      - Here is a video showing the basic Visual Studio functionality https://www.youtube.com/watch?v=Ijdk4z8-2OI
      Fastest way to debug on windows. This is the easiest way to start up debugging a script.
      - Start the authserver and worldserver normally
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In Visual Studio at the top select "Debug>Attach to process...>worldserver.exe" and click "Attach" http://i.imgur.com/jDEI2Hq.png
      - You are now debugging
       
      The second slower way of debugging on windows. This is useful for debugging something that occurs in the startup of the server.
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In solution explorer right click on worldserver and select "Set as StartUp Project" http://i.imgur.com/wvMzeRA.png
      - In solution explorer right click on worldserver and select "Properties" http://i.imgur.com/rTNEF9O.png
      -- In Properties you should go to "Configuration Properties>Debugging" and edit "Working Directory" to point to the server folder. For me this is the default compile folder so I use "$(OutDir)" http://i.imgur.com/aRI29fB.png
      - Start the authserver normally
      - Start the worldserver by selecting "Debug>Start Debugging". The server will start with debugging attached from the beginning http://i.imgur.com/cg1KJNw.png
      - You are now debugging
      Crashlogs on windows. Once you have a way to reproduce a crash you can get a crashlog that can help you resolve it.
      - After compiling the core in "Debug" instead of "Release" start up the worldserver and authserver
      - Reproduce the crash you have
      - In the server folder there is now a folder called Crashes that contains txt and dmp files. http://i.imgur.com/9eQIdql.png
      - You can open the txt files in text editors http://i.imgur.com/EH6R17E.png
      -- At the top of a txt file there is some information about your system and below it there is the Call Stack and below that there are Variables of each part of the call stack
      -- The Call Stack will tell you at the top what was the last function call before crashing and what function calls led to that function call.
      -- Next to the function names there is the file that the function is defined in and the line number the code was executing in that function.
      -- In the Variables section you can inspect variables that were present at each function call.
      -- Based on this information you are often able to see what crashed or get a better view of what you need to inspect more in your code.
      - The dmp file can be opened in Visual Studio
      -- Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      -- Drag and drop the dmp file to Visual Studio
      -- In the window that opens click to "Debug with Native Only" http://i.imgur.com/OgyU2kM.png
      -- In the window popup click "Break" http://i.imgur.com/4jDzqRn.png
      -- You are now in a state like you would have hit a break point in the code or a crash while debugging. You can inspect the call stack and the variables.
      Edit and continue on windows. When debugging this allows you to change the code and without restarting the server apply those changes so they actually work ingame.
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In solution explorer right click on worldserver and select "Properties" http://i.imgur.com/rTNEF9O.png
      -- In Properties select "Configuration Properties>Linker>General" and set "Enable Incremental Linking" to "Yes". http://i.imgur.com/caQqwN5.png
      -- In Properties select "Configuration Properties>Linker>Advanced" and set "Image Has Safe Exception Handlers" to "No". http://i.imgur.com/FYzN8Ks.png
      -- In Properties select "Configuration Properties>C/C++>General" and set "Debug Information Format" to "Program Database for Edit And Continue". http://i.imgur.com/pxQ6I8N.png
      - At the top of the window select "Tools>Options". In the Options select "Debugging>General" and in there select "Enable Edit and Continue", "Enable Native Edit and Continue" and "Require source files to exactly match the original version".
      - Compile the server for the changes to take effect.
      - Set up "The second slower way of debugging" (I did not test edit and continue on other configurations)
      - Start the authserver normally
      - Start the worldserver by selecting "Debug>Start Debugging".
      - Try edit a cpp file a little and save it.
      - At top of Visual Studio window select "Debug>Apply Code Changes" and wait until the changes are applied. Warning: it can take considerable amount of time for the changes to be applied. http://i.imgur.com/77pb58E.png
      - If you have issues, be sure to check the error messages in Output. You can view it by selecting "View>Output" http://i.imgur.com/4cIznW9.png
      - This guide was written based on https://msdn.microsoft.com/en-us/library/esaeyddf.aspx and https://blogs.msdn.microsoft.com/vcblog/2015/07/22/c-edit-and-continue-in-visual-studio-2015/
      Linux:
      First we need to compile the server in debug mode.
      - Compile the server with the cmake flag -DCMAKE_BUILD_TYPE=Debug

      Debugging on linux. You can debug on linux by using GDB.
      - Here is a good video about it: https://www.youtube.com/watch?v=sCtY--xRUyI
      - Basically you
      -- Start the authserver
      -- Start the worldserver by using "gdb ./worldserver"
      -- Enter breakpoints by using break command on gdb
      -- Use the run command on gdb to start the server
      -- You are now debugging
      - You may also be interested in using VScode or some other more visual debuggers. https://www.youtube.com/watch?v=B0xTgyCwsAo
      Crashlogs on linux. Once you have a way to reproduce a crash you can get a crashlog that can help you resolve it.
      - Take crashreport.gdb from /contrib/debugger from source folder and place it to your server folder
      - Start the authserver
      - Start the worldserver by using "gdb -x crashreport.gdb ./worldserver"
      - Reproduce your crash
      - There should be a backtrace.log in your server folder that contains information about the crash like the callstack and variables in each function call in the call stack
      - This guide was written based on https://github.com/TrinityCore/TrinityCore/blob/master/contrib/debugger/README
      Running valgrind on linux. This helps you find memory errors like invalid reads and writes and memory leaks.
      - Here is a good video about it: https://www.youtube.com/watch?v=fvTsFjDuag8
      - Basically you
      -- Start the authserver
      -- Start the worldserver by using "valgrind ./worldserver"
      -- Run your code that you want to analyze and close the server
      -- The console or an output log should contain the valgrind log
    • By reyne
      Hey there!

      I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
      After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

      `Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

      This repeats for every line in Expansion01, and then the extractor crashes.

      I'm not sure where else to go from here.

      Thanks for your help

      Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.
    • By Uee
      I recently found the Trinity Cataclsym Preservation Project and thought I will try it out.
      I am already running 3.3.5a and Master - both server run great
      Pulled 4.3.4 down using Git and built it same way as others:
      boost_1_73_0 cmake 3.17.2 Mysql 5.7.30 VS Community 2019 Built fine - no issue. Used 'Extractor.bat' to run all the map extractors - worked great!
      Noticed there was extra file 'connection_patcher.exe`, ran that - worked great! Now have "wow_patched" and use this to launch client
      MySQL runs in standalone mode, -initialize, added base sql files, imported, auth and character sql files
      Configured both the .conf files and passwords, IPs etc are all in place.
      Note: When loading the exe and built conf file, bnetserver complain about these items missing, so I add them:
      Updates.AutoSetup = 1 Updates.EnableDatabases = 0 LoginDatabase.SynchThreads = 1 Load up Mysql - loads fine
      Load up bnetserver and appears to load ok - last few lines look like this:
      Connected to MySQL database at 127.0.0.1
      DatabasePool 'auth' opened successfully. 2 total connections running.
      Started auth database connection pool.
      Listening on connections from worldservers on port 1118...
      Load up worldserver and it adds the FULL world and hotfixes, then applied all updates (confirmed archived in SQL) - last few lines look like this:
      Calculate next monthly quest reset time...
      Calculate random battleground reset time...
      Calculate guild limitation(s) reset time...
      Calculate next currency reset time...
      World initialized in 0 minutes 13 seconds
      TrinityCore rev. d0c7bbab40bc 2020-05-06 00:01:21 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon) ready...
       
      There are no db errors in logs.
      Config.wtf contain portal, realmlist as remote server and patchlist as localhost.
      When I try to connecting using "[email protected]" and password I get immediately disconnected.
      What I did noticed different is that the bnetserver doesnt add "Added realm "Battle for Azeroth" at 192.168.10.213:8085." (From my Master log) 
      3.3.5a also have this line as last line in authserver - but 4.3.4 is not giving me this one.
      Realmlist table is accurate with right information.
      Anyone know why bnetserver is not starting me realm?
       
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
×
×
  • Create New...