Jump to content
TrinityCore
CFGhost

Stuck at connected / infinite loop / login issues / battle.net

Recommended Posts

as you can see port 80, 8085 are listening to PID 2112(worldserver) and port 3724 is listening to PID

3364(authserver) while 3306 is listening to PID 2368(MySQL)

post-15658-0-51756000-1349891800_thumb.p

also my firewall is allowing auth and world to connect

post-15658-0-48026600-1349892028_thumb.p

i will run some other tests soon i just hope i get more input as to what might be the issue.

As you can see localhost is established with port 3306 to PID 2368(MySQL)

post-15658-0-46755900-1349893408_thumb.p

and here you can see that there is a close_wait connection with port 80 on PID 2940(AvastUi) which

is my antivirus, though i am not sure what it means.

post-15658-0-15700800-1349893719_thumb.p

Share this post


Link to post
Share on other sites

How exactly have you made it "Public"? From the Realmlist in your Auth database you have no hostname and a localhost 127.0.0.1 address. I'm assuming you have port forwarded 8085 (or 8086 can't remember) and pointed it to the server IP address but for external users you will need to have your Public IP address in the realmlist and also configure the public IP in the realmlist.wtf in the client.

Unless i'm missing your point ??

Edited by skipperheartbeat

Share this post


Link to post
Share on other sites

I GOT IT!!!!!!!!!!!!!!!!!!!!!!!!!!

here is the culprit:

post-15658-0-22008500-1349960765_thumb.p

the port for some reason was set to 7878 so i thought ok let me portforward it and i did and it did not get stuck on realm selection just on success so i thought wait a minute this is suppose to be set to 8085 so i change it to

that and it worked lol!.

thank you all for helping and ofc CDawg was right.

Share this post


Link to post
Share on other sites

--- Canned message start ---

It appears the issue in the original post was solved, so this thread shall be closed.

Should you encounter any other difficulties, please open a new thread.

--- Canned message end ---

Share this post


Link to post
Share on other sites

Hi all.

 

First of all, im a beginner with a large 'B' in all this, so pleace have some patience with me.

 

I have setup a trinity server following the how to: win, guide. (Greate guide btw, realy good)

 

I have my server up and running, and i can connect to it from the same PC as i have the server on, no problem. So i guess that this meens that its working right? The DB is working and all that.

 

But when i try to connect to the server from a difrent PC, then i get the "Realm Loop" i think you guys call it. The thing where i get presentet with the realm list, and then when i select the one realm, i get "Logging into gameserver" for a few seconds, and then i get the realm list again.

And what i have seen from searching this forum and some on google, its a known problem, but also a problem with alot of solved cases, but i cant seem to find the solution for me. :(

 

I guess you want some info on what i have done. I will try to inform you the best way i can.

 

Im runnig a Windows 7 machine. 64 bit.

 

TrinityCore rev. 2012-11-18 13:50:14 +0100 (e60d26f36b21)

 

Database ver. TDB 335.49

 

MySql Server 5.5

 

I have followed the stuff that Athena postet in another topic:

 

  • Setup a dynamic DNS on your favourite provider. - Done
  • Go in your realm database, realm table, and set the address to the DNS you have setup on point 3.1. - Think i have done this. In the auth DB under realmlist and then under adress i have written the dns adress. Is that right?
  • Go in your hosts file and set "127.0.0.1 yourdnsname.dynamicdns.tld". (if your server is local. If server is in your lan, instead of 127.0.0.1 put the Lan IP of the server) - Done
  • Go in your realmlist.wtf file and put the dns you have setup earlier (yourdnsname.dynamicdns.tld). - Done.
  • For the people outside the network:
  • In your router: Point the ports 8085 and 3724 to the server ip address (internal lan IP). - Done
  • Your clients in their realmlist.wtf put the dns you have setup (yourdnsname.dynamicdns.tld). - Done
  • And they can connect and play. - Unfortunately no :(

Hope someone can help me solve this problem.

 

If you need more information from me, please let me know, and please remember, im a total noob, so... be gentle :)

 

 

 

Share this post


Link to post
Share on other sites

UPDATE `realmlist` SET `address`='<putyourdnsnamehere>' WHERE `id`=1;
  Ugh.. I hate windows. Open a command prompt in windows and type "ping <yourdnsname>". If it results back an IP.address then your good on resolving the dns. Then type "ipconfig" (to get your internal IP address) Use your internal address in your router to forward the ports 8085 and 3724. Example:
10.11.12.13 => 8085 10.11.12.13 => 3724

Share this post


Link to post
Share on other sites

Hi and thankyou for getting back to me on this.

 

Well i have done the ping to mydnsname and it returns an ip, and looks alright, no lost data.

The ports in the router are open and checked open with canyouseeme, and everything checked out.

 

But still the same problem, with the logging into gameserver, and then realm list again, over and over again.

 

Edit: Actually now, when I try to run the authserver, it just flashes and then shuts down again. When i run it in a command prompt i see no errors.

Edited by Jrod

Share this post


Link to post
Share on other sites

Just to be sure here:

 

This: UPDATE `realmlist` SET `address`='<putyourdnsnamehere>' WHERE `id`=1;

 

This is a quary you want me to run in my Auth Database right?

Share this post


Link to post
Share on other sites

Yes put the name of the dns in the address='putyourdnsnamehere'. Be sure to copy the above where it's wrapped in code tags, just in case there's a back-tick missing.

My guess is that you didn't have the dns name in the DB originally, which is where people find themselves in the connection loop.

 

worldserver.conf = localhost (127.0.0.1) [if your DB is on the same machine]

router configuration = 10.10.10.10 => [8085] (whatever your local network is set to. in my case it would be like 192.168.x.x) <= whatever your router resolves locally!

router configuration = 10.10.10.10 => [3724] (whatever your local network is set to. in my case it would be like 192.168.x.x) <= whatever your router resolves locally!

DB auth.realmlist = DNSName (external) (The query example i gave should help you modify your DB realmlist to get your friends to connect)

 

[On outside connections]

Tell them to point to your DNSName in the realmlist.wtf, It also helps to change your .wtf file as well.  Think as if your outside trying to get in...

The application is exposed talking outside.

 

Thats it!

  • Upvote 1

Share this post


Link to post
Share on other sites

Its solved! Thanks a milion CDawg.

 

The databse quarry was the one that solved it.

 

Now everything is working, and i can connect from outside my lan.

 

Again, thank you very much.

Share this post


Link to post
Share on other sites

Ok, guys i use trinity and a dns redirect from no-ip and i cant login to my server when i haven't edited host file.

I have edited them and when i make them:

127.0.0.1 [my DNS]

and i start authserver it runs the server at 127.0.0.1 

if i run it on host and make the realm 127.0.0.1 i can see realm but not to join...

 

Also other player can connect and play this problem is only for me.

But is i run at 127.0.0.1 they will not be able to connect

 

 Can i duplicate the realm with other ip but to be able to see players..I mean they to be actually the same realms but to be able to connect from two places one local and one non-local

 

I am running site and there is showing that the server is offline but it is actually online :(

Edited by DefaultWoW

Share this post


Link to post
Share on other sites

Ok, guys i use trinity and a dns redirect from no-ip and i cant login to my server when i haven't edited host file.

I have edited them and when i make them:

127.0.0.1 [my DNS]

and i start authserver it runs the server at 127.0.0.1

if i run it on host and make the realm 127.0.0.1 i can see realm but not to join...

Also other player can connect and play this problem is only for me.

But is i run at 127.0.0.1 they will not be able to connect

Can i duplicate the realm with other ip but to be able to see players..I mean they to be actually the same realms but to be able to connect from two places one local and one non-local

I am running site and there is showing that the server is offline but it is actually online :(

You are binding the server to listen to local traffic how do you expect to connect through the internet? Read through this thread, you'll get the idea..

Share this post


Link to post
Share on other sites

Hello, I made a WoW 3.3.5a Server lately and everything works just fine now, my friends can connect externally.

However, when I try to connect myself through the localhost I get the Realm Loop that my friends had before, while connecting through my external IP doesnt work at all.

I have been searching all over google and trinitycore.org, is there any known fix to this?

 

Thanks in Advance

Share this post


Link to post
Share on other sites

hello, you can try this, have the IP address in the realmlist table set to the external IP, portforward and try connecting through the external IP on the local machine.

Share this post


Link to post
Share on other sites

I don't remember the post where I put it, but like Zze says, think of it as you are one of your friends on an external machine trying to get in.

Share this post


Link to post
Share on other sites

As far I know there are a few ports that have to be forwarded in the router in order to get your server live.

 

You need to forward:

8085
9000
3724

 

Also this is open to discussion though, it just depends on how you configured your Worldserver.conf file.

Share this post


Link to post
Share on other sites

As far I know there are a few ports that have to be forwarded in the router in order to get your server live.

 

You need to forward:

8085

9000

3724

 

Also this is open to discussion though, it just depends on how you configured your Worldserver.conf file.

You don't need to forward 9000. The 2 links provided are sufficient.

Share this post


Link to post
Share on other sites

My bad... I've changed the port for SOAP to 9000 due to 7878 being taken, making this port not a requirement but merely optional.

Edited by Failed
  • Upvote 1

Share this post


Link to post
Share on other sites

Info:

  • Operating System             -Win 64x
  • TrinityCore Revision         -2013-01-22 <4f3c6b139031>
  • TrinityDatabase Version   - 335.50_2013_01_14
  • DB servers running on my local machine.
  • MySQL Server                  -5.5.29

 

Been wrestling with the "Realm loop" problem for a family member trying to connect from outside my LAN.  I've followed the steps necessary to setup the server for external access by doing the following:

 

-Setup a DDNS through DynDNS.  I've tested it by pinging via CMD and it successfully returns my external IP - so I'm fairly confident it is setup correctly.

-Forwarded ports 3724 and 8085. I've tested ports via both my external IP and my DDNS and they show as open. 

-Modified realmlist DB to point to my DDNS.  (The data entry, I did not make the "default entry" mistake on HeidiSQL)

-Modified realmlist.WTF to point to my DDNS.

-Have my family member do the same to his realmlist.WTF

 

 

Now I did encounter the Realm Loop issue on my own computer.  After browsing the forums I understand that there sometimes is a loopback issue when trying to connect from the host machine, I fixed this by editing my "Hosts" file with "127.0.0.1 <DDNS.net>" and I can login just fine.  A family member trying to get in, however, suffers from the Realm loopback.  (He sees my Trinity server  ---> Connecting......  ----> Back to realm selection).  I have a creeping suspicion that my hosts file will play a role in whatever issue this is, but I'm not quite savvy enough to figure it out on my own. :unsure:

 

 

I've searched around for this issue, I know there's more than a few topics on it, but I cannot seem to fix it with any of the suggested methods.  I've tried the following:

 

-Reset router

 

-Changed the worldserver port from 8085 to 8086 in the worldserver.conf, realmlist DB, and the forwarded ports in case the 8085 port was hosed up.  Same issue, I can login fine with the different port - but outside connections cannot. 

 

-Disabled all firewalls (including routers)

 

 

 

Any help would be greatly appreciated.

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×