Jump to content
TrinityCore

Stuck at connected / infinite loop / login issues / battle.net


CFGhost
 Share

Recommended Posts

@timp11 To add what Brainy mentioned, figure out what your public IP is..
set your database realmlist with that public IP.
You will only need 3724 (authserver) and the worldserver (default: 8085) open to public. worldserver port is configured in your .conf file. There should be no other ports open.

 

Link to comment
Share on other sites

5 hours ago, HannibalRoG said:

@CDawg that depends on whether it is master or 3.3.5, as I said, with so little information you can not help much. In master its a bit diferent.

It should be pretty obvious. Just show him how it's configured for "master"

https://github.com/TrinityCore/TrinityCore/blob/master/src/server/bnetserver/bnetserver.conf.dist#L76

 

Rather than complain, then show both options.

  • Upvote 2
Link to comment
Share on other sites

Hi, I've been reading almost everything here done stuff that already you guys explained and I'm still stuck at Connected, cant log into the character list, I'm all doing it on localhost for me only, disabled firewall... and nothing still stuck at connected. Can anyone help me? I will provide everything screenshots etc.

PD: I'm using the 3.3.5 branch.

Edited by Shalker96
Link to comment
Share on other sites

On 10/18/2017 at 6:47 PM, Shalker96 said:

Hi, I've been reading almost everything here done stuff that already you guys explained and I'm still stuck at Connected, cant log into the character list, I'm all doing it on localhost for me only, disabled firewall... and nothing still stuck at connected. Can anyone help me? I will provide everything screenshots etc.

PD: I'm using the 3.3.5 branch.

What OS?
What is your auth.realmlist set at?

Link to comment
Share on other sites

5 hours ago, CDawg said:

What OS?
What is your auth.realmlist set at?

Windows 10 Pro 64 bit creators update

https://gyazo.com/3c4fa2483a1aa8b4e0c5bd5e378e9846

This is the authserver.conf: https://pastebin.com/RnHRu3RR

This is the worldserver.conf: https://pastebin.com/4YdhWzcr

and this is the folder where the binaries are: https://gyazo.com/175d2ca36daeb3451305afe8f9f0e3bb

oh and this is the realmlist table in the auth database: https://gyazo.com/69a802de46b7e4352921524f0ea853c9

Edited by Shalker96
Link to comment
Share on other sites

On 19/10/2017 at 3:47 AM, Shalker96 said:

Hi, I've been reading almost everything here done stuff that already you guys explained and I'm still stuck at Connected, cant log into the character list, I'm all doing it on localhost for me only, disabled firewall... and nothing still stuck at connected. Can anyone help me? I will provide everything screenshots etc.

PD: I'm using the 3.3.5 branch.

Maybe your issue is your client if you donwloaded it of a private server site. Did you patch your wow.exe?

Change the realmlist in the config.wtf file (set realmlist "127.1.0.0")  of your wow and check in propierties "only read".

Be sure that your wow client version is the same than trinity core version soported.

Link to comment
Share on other sites

35 minutes ago, Daniel25 said:

Maybe your issue is your client if you donwloaded it of a private server site. Did you patch your wow.exe?

Change the realmlist in the config.wtf file (set realmlist "127.1.0.0")  of your wow and check in propierties "only read".

Be sure that your wow client version is the same than trinity core version soported.

I downloaded the client from warmane, I'm downloading now another 2 clients from different sources hopefully is the client's problem.

I also did change to read only the config.wtf and the realmlist.wtf: https://gyazo.com/12a44d7d5ec5df4a44755f86e53c91c5 but still nothing changed.

The client's version is the 12340 one which is the correct for the 3.3.5 branch

Update: tried with 2 different clients but still no change.

Edited by Shalker96
Link to comment
Share on other sites

1 hour ago, Daniel25 said:

Maybe your issue is your client if you donwloaded it of a private server site. Did you patch your wow.exe?

Change the realmlist in the config.wtf file (set realmlist "127.1.0.0")  of your wow and check in propierties "only read".

Be sure that your wow client version is the same than trinity core version soported.

he is using 3.3.5a branch, no patching needed.

Link to comment
Share on other sites

Hi, it seems I have the same issue: got stuck at the "selecting server" interface and cannot get into the character list. It has puzzled me for a couple of days. Should I just post here or start a new thread?

I'm running branch 3.3.5a of TrinityCore on a Win10 PC (just call it "server", LAN ip 192.168.0.108), and there is another Win10 PC ("client", LAN ip 192.168.0.105) connected on the same router. I can run authserver + worldserver + wow.exe all on the "server" PC smoothly. But when I tried to run wow.exe on the "client" PC, I got the above issue.

FYI, below I've attached screenshots for my settings for the database and running authserver & worldserver. And I have these lines in "worldserver.conf" & "authserver.conf":

LoginDatabaseInfo     = "127.0.0.1;3306;trinity;trinity;auth"                  # in both authserver.conf and worldserver.conf
WorldDatabaseInfo     = "127.0.0.1;3306;trinity;trinity;world"                # only in worldserver.conf
CharacterDatabaseInfo = "127.0.0.1;3306;trinity;trinity;characters"     # only in worldserver.conf

Also, on both "server" and "client" PCs, I've confirmed that I have SET realmList "192.168.0.108" in WTF/config.wtf. And Data/enGB/realmlist.wtf has one single line: set realmlist 192.168.0.108

In addition, I opened port 8085 and 3724 in the firewall settings on the "server" PC. 

The connection.log file on the "client" PC:

10/28 03:06:08.206  GRUNT: state: LOGIN_STATE_CONNECTING result: LOGIN_OK 
10/28 03:06:08.224  GRUNT: state: RESPONSE_CONNECTED result: LOGIN_OK 192.168.0.108:3724
10/28 03:06:08.300  GRUNT: state: LOGIN_STATE_AUTHENTICATING result: LOGIN_OK 
10/28 03:06:08.336  GRUNT: state: LOGIN_STATE_CHECKINGVERSIONS result: LOGIN_OK 
10/28 03:06:08.514  GRUNT: state: LOGIN_STATE_HANDSHAKING result: LOGIN_OK 
10/28 03:06:08.561  GRUNT: state: LOGIN_STATE_AUTHENTICATED result: LOGIN_OK 
10/28 03:06:08.571  ClientConnection Initiating: COP_CONNECT code=CSTATUS_CONNECTING 
10/28 03:06:09.650  ClientConnection Completed: COP_CONNECT code=RESPONSE_FAILED_TO_CONNECT result=FALSE

10/28 03:06:13.200  ClientConnection Initiating: COP_CONNECT code=CSTATUS_CONNECTING 
10/28 03:06:14.251  ClientConnection Completed: COP_CONNECT code=RESPONSE_FAILED_TO_CONNECT result=FALSE
10/28 03:06:15.300  GRUNT: state: LOGIN_STATE_DISCONNECTED result: LOGIN_OK 

Could someone who is experienced with this please let me know which part is going wrong?

AuthServer.JPG

MySQL-realmlist.JPG

WorldServer.JPG

Edited by rbliu
Link to comment
Share on other sites

4 hours ago, rbliu said:

Hi, it seems I have the same issue: got stuck at the "selecting server" interface and cannot get into the character list. It has puzzled me for a couple of days. Should I just post here or start a new thread?

I'm running branch 3.3.5a of TrinityCore on a Win10 PC (just call it "server", LAN ip 192.168.0.108), and there is another Win10 PC ("client", LAN ip 192.168.0.105) connected on the same router. I can run authserver + worldserver + wow.exe all on the "server" PC smoothly. But when I tried to run wow.exe on the "client" PC, I got the above issue.

FYI, below I've attached screenshots for my settings for the database and running authserver & worldserver. And I have these lines in "worldserver.conf" & "authserver.conf":

LoginDatabaseInfo     = "127.0.0.1;3306;trinity;trinity;auth"                  # in both authserver.conf and worldserver.conf
WorldDatabaseInfo     = "127.0.0.1;3306;trinity;trinity;world"                # only in worldserver.conf
CharacterDatabaseInfo = "127.0.0.1;3306;trinity;trinity;characters"     # only in worldserver.conf

Also, on both "server" and "client" PCs, I've confirmed that I have SET realmList "192.168.0.108" in WTF/config.wtf. And Data/enGB/realmlist.wtf has one single line: set realmlist 192.168.0.108

In addition, I opened port 8085 and 3724 in the firewall settings on the "server" PC. 

The connection.log file on the "client" PC:

10/28 03:06:08.206  GRUNT: state: LOGIN_STATE_CONNECTING result: LOGIN_OK 
10/28 03:06:08.224  GRUNT: state: RESPONSE_CONNECTED result: LOGIN_OK 192.168.0.108:3724
10/28 03:06:08.300  GRUNT: state: LOGIN_STATE_AUTHENTICATING result: LOGIN_OK 
10/28 03:06:08.336  GRUNT: state: LOGIN_STATE_CHECKINGVERSIONS result: LOGIN_OK 
10/28 03:06:08.514  GRUNT: state: LOGIN_STATE_HANDSHAKING result: LOGIN_OK 
10/28 03:06:08.561  GRUNT: state: LOGIN_STATE_AUTHENTICATED result: LOGIN_OK 
10/28 03:06:08.571  ClientConnection Initiating: COP_CONNECT code=CSTATUS_CONNECTING 
10/28 03:06:09.650  ClientConnection Completed: COP_CONNECT code=RESPONSE_FAILED_TO_CONNECT result=FALSE

10/28 03:06:13.200  ClientConnection Initiating: COP_CONNECT code=CSTATUS_CONNECTING 
10/28 03:06:14.251  ClientConnection Completed: COP_CONNECT code=RESPONSE_FAILED_TO_CONNECT result=FALSE
10/28 03:06:15.300  GRUNT: state: LOGIN_STATE_DISCONNECTED result: LOGIN_OK 

Could someone who is experienced with this please let me know which part is going wrong?

AuthServer.JPG

MySQL-realmlist.JPG

WorldServer.JPG

you have changed DEFAULT value, NOT value of realmlist table.

Link to comment
Share on other sites

  • 3 weeks later...

Hi guys,

I am not sure if this has been answered elsewhere but I've searched a lot and could not find any answer to fix my problem.

I have a pristine master build (latest db unmodified) and it compiles and runs perfectly on my main machine, however, when I try to run the client from my laptop it just doesn't connect.

I get first "connecting" and then "disconnected from the server".

I have patched the client and setup the realmlist with all combinations I could find.

The client on the laptop is a copy of the client that is running fine on my main machine.

 

Table Realmlist address field has my external address 151.x.x.x and localAdress has my internal LAN address 192.168.x.x

I also have tried a few other combination and nothing seems to work.

I am sure I am missing something pretty simple here.

Any help would be greatly appreciated.

 

 

 

 

Edited by fvicaria
Link to comment
Share on other sites

Hi guys,

I started a server trinity 3.3.5 , but when i do what is write here (https://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130094/Networking) my friends (and me (except in local)) can't connect to my server.

Port 8085 and 3724 are open on my router, the auth.realmlist.adress is changed, obviously like the realmlist of my wow. (i try with my firewall disabled, but that's not working too)

I take the ip of http://www.whatsmyip.org/.

Sorry for my bad english, and thanks for your help ! :D

Some pictures, if you want ^^'

http://prntscr.com/hkim62

http://prntscr.com/hkimkd

 

Link to comment
Share on other sites

While since i did this but i believe the local address in the realmlist table should be the LAN IP address of your server e.g. 192.168.x.x

As stated, on your router, make sure you forward traffic received on ports 8085 and 3724 to you server LAN IP address e.g. 192.168.x.x 

Realmlist of WOW should be set to the Public IP address received from whatsmyip

Link to comment
Share on other sites

13 minutes ago, skipperheartbeat said:

While since i did this but i believe the local address in the realmlist table should be the LAN IP address of your server e.g. 192.168.x.x

As stated, on your router, make sure you forward traffic received on ports 8085 and 3724 to you server LAN IP address e.g. 192.168.x.x 

Realmlist should be set to the Public IP address received from whatsmyip

Thanks for your help, but that's not working too ^^'

Link to comment
Share on other sites

127.0.0.1 for localAdress works well mostly.

But is your public IP a static IP? Some provider in some countries change this on a daily schedule.

Does your server PC has a static IP ?

And did you forward both ports to your server ? (As SarcNBit asked?)

Check your ports: https://www.yougetsignal.com/tools/open-ports/
(ATM they are closed for your given IP)

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...