Jump to content
TrinityCore

Stuck at connected / infinite loop / login issues / battle.net


CFGhost
 Share

Recommended Posts

On 5/27/2018 at 7:42 PM, Vell said:

My hosts file (etc/hosts) :

127.0.0.1           localhost

127.0.1.1          my_pc_name-UBUNTU

192.168.1.78  *******.ddns.net

If you have set 127.0.1.1 as a local host address, then you need to be careful with your subnet masks. The local Host subnet mask should be a 255.0.0.0 not 255.255.255.0

Link to comment
Share on other sites

  • 1 month later...

So i get the error "WorldSocket::HandleAuthSession: Authentication failed" when trying to log in a basic user.

This is done using a completely fresh install of WoW, latest branch of trinity and anything else further untouched.

The realmlist ID is correct, this and i am trying to connect on a local machine.

 

What is going on, and why is this error message so vague?

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...

Hello, I'm right now using 7.3.5.26972 (x64).

My problem here is that I've done the server, and it was working for me on "Local" but then I tried to open it for friends to play with, and then now I'm getting the "BLZ51901002", I've been all the day checking everything I've done from changing to an "Online" server.

So all I've done is =
- Oppening the 8085 & 3724 ports in my router.
- Putting the exception in the Firewall (8085 & 3724 TCP and UDP).
- Creating a DNS in https://www.noip.com/ 
- Add my external IP adress and DNS in "host" of Windows in: C:\Windows\System32\drivers\etc
127.0.0.1  myhost.ddns.net
 externalip myhost.ddns.net

- Change localip to externalip in the DB
- Change Local IP in "config.wtf" to the DNS or External IP on: "\World of Warcraft\WTF"

Edit: Sry if you already responded to this (I'm reading everything now, I posted this just in case). And sorry for my bad grammar (If there's something)

Edited by LoboTron11
Link to comment
Share on other sites

31 minutes ago, LoboTron11 said:

Hello, I'm right now using 7.3.5.26972 (x64).

My problem here is that I've done the server, and it was working for me on "Local" but then I tried to open it for friends to play with, and then now I'm getting the "BLZ51901002", I've been all the day checking everything I've done from changing to an "Online" server.

So all I've done is =
- Oppening the 8085 & 3724 ports in my router.
- Putting the exception in the Firewall (8085 & 3724 TCP and UDP).
- Creating a DNS in https://www.noip.com/ 
- Add my external IP adress and DNS in "host" of Windows in: C:\Windows\System32\drivers\etc
127.0.0.1  myhost.ddns.net
 externalip myhost.ddns.net

- Change localip to externalip in the DB
- Change Local IP in "config.wtf" to the DNS or External IP on: "\World of Warcraft\WTF"

Edit: Sry if you already responded to this (I'm reading everything now, I posted this just in case). And sorry for my bad grammar (If there's something)

master branch needs different ports than 3.3.5a:

https://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130094/Networking

Link to comment
Share on other sites

On 8/21/2018 at 10:11 PM, Lost PMR said:

New screenshot !

https://prnt.sc/klbhpc

 

On 8/21/2018 at 11:45 AM, Lost PMR said:

Yes ! my firewall rules is fine, bcz auth is work & you can login. after login you stuck in loading 100%.

Sometimes I can login !

I have problem on delete or create new character too :

look at this :

https://prnt.sc/kl3jdo

 

On 8/17/2018 at 12:18 PM, Lost PMR said:

Hi all

I cannot connect to my server!

but some people is online in server !

what is the problem ! loading is 100% but its take long time & cannot login !

Screenshot :

https://prnt.sc/kjntwj

I test to disable firewall! unstuck ... but still not working ...

1 Month & no answer !

I need help about this.

Link to comment
Share on other sites

1 hour ago, Lost PMR said:

3.3.5a

Your screenshot shows the master branch under unix, so that's confusing.

Maybe it would help if you describe your current setup. What operating system are you running? Did you get the source with git? (The answer should be yes.) Post the result of "uname -a", "git remote show origin" and "git branch -v". Are you running the client on the same machine as the server? What's in your realmlist.wtf? What do you get from sql when you run "select * from auth.realmlist;"? What do you get when you run "iptables -L" and "ip6tables -L" on both (linux) client and server machines? You might even link your Server.log and Auth.log, if that's not a problem.

Link to comment
Share on other sites

11 hours ago, dane said:

Your screenshot shows the master branch under unix, so that's confusing.

Maybe it would help if you describe your current setup. What operating system are you running? Did you get the source with git? (The answer should be yes.) Post the result of "uname -a", "git remote show origin" and "git branch -v". Are you running the client on the same machine as the server? What's in your realmlist.wtf? What do you get from sql when you run "select * from auth.realmlist;"? What do you get when you run "iptables -L" and "ip6tables -L" on both (linux) client and server machines? You might even link your Server.log and Auth.log, if that's not a problem.

Its centos, yes its from git, everything is ok, iptable is ok too. Some people can connect from internet some people cannot connect ! they can auth & load characters...

Link to comment
Share on other sites

I had a similar issue on my server. It took me 3 days with some Teamviewer, VPN and stuffs with the player to figure out what was happening.

For some mysterious reasons, in some Windows configurations, the port 8085 is blocked as default for outcome and income, so I've looked up for the biggest servers and saw that they use the port 8084 instead of 8085. Now on, no more complains about this!! :)

Edited by boveloco
Link to comment
Share on other sites

15 hours ago, boveloco said:

I had a similar issue on my server. It took me 3 days with some Teamviewer, VPN and stuffs with the player to figure out what was happening.

For some mysterious reasons, in some Windows configurations, the port 8085 is blocked as default for outcome and income, so I've looked up for the biggest servers and saw that they use the port 8084 instead of 8085. Now on, no more complains about this!! :)

Changed, Thank you, But I use another port for example : 9965 & etc, That's need to test.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...