Jump to content
TrinityCore
CFGhost

Stuck at connected / infinite loop / login issues / battle.net

Recommended Posts

I have spent lots of time googling how to fix this issue but nothing works.

running the server from the same pc i connect to it even, the only way i can connect is to change the realmlist.wtf to "192.168.0.X" ... my router ip is 192.168.1.1 and if i use an ip address that's in the "192.168.1.X" i can't connect to the server. All ports are forwarded through 

router and firewall... though to connect to my server that's on my own pc it's shouldn't matter. I can't find any way to make it work .. other then setting the ip in realmlist.wtf to "192.168.0". The auth and world configs are standard and i just change the ip in realmlist.wtf.

I tried this http://www.ac-web.org/forums/showthread.php?130614-Trinity-Public-LAN-local-server-all-in-one too but no luck. If anyone can help with whats wrong i would greatly appreciate it.

Share this post


Link to post
Share on other sites

What is the IP address and subnet mask of your Router and Server? You seem to be mixing 192.168.0.x and 192.168.1.x

 

192.168.x.x is a private address range. If you have set up port forwarding, i assume you want to connect from outside your network.

In which case, you need to use the public address that is shown if you go to whatsmyip.org from your server.

you should set the public address in realmlist.wtf and also in the realmlist table in the database.

 

Share this post


Link to post
Share on other sites

i have tried both. my routers ip range is 192.168.1.X ... however if i set the realmlist to 192.168.1.8 which is my computers static ip on the network i ca't connect to the server on the pc i run it from . However if i change my adapters ip to 192.168.0.x i can conect to the server :S. I also have a static ip from my IPS which i added to a second table in the realmlist database. I couldn't get it working either. I also tried putting my ip in the dmz just in case the port forwarding didn't work.. which didn't make any difference either.

I have done a heap of googling and can't figure out whats wrong. If i want to run it from local i should be able to just use 192.168.1.8 and if i want to run it online with the port forwarding and my external static ip (whatismyip.org) should be fine o.O

 

Share this post


Link to post
Share on other sites
11 hours ago, djorn01 said:

i have tried both. my routers ip range is 192.168.1.X ... however if i set the realmlist to 192.168.1.8 which is my computers static ip on the network i ca't connect to the server on the pc i run it from . However if i change my adapters ip to 192.168.0.x i can conect to the server :S. I also have a static ip from my IPS which i added to a second table in the realmlist database. I couldn't get it working either. I also tried putting my ip in the dmz just in case the port forwarding didn't work.. which didn't make any difference either.

I have done a heap of googling and can't figure out whats wrong. If i want to run it from local i should be able to just use 192.168.1.8 and if i want to run it online with the port forwarding and my external static ip (whatismyip.org) should be fine o.O

 

be sure you change the value and not the default value.

Share this post


Link to post
Share on other sites

For me it seems here it lacks a little bit of knowledge about networks.  ;-)

Guess your target is to open your TC server to public internet and you are on a 3.3.5 branch, windows OS and using a common router setting and LAN.

3 steps that you need to do:

Step 1:   WoW client and TC server on the same PC

- Check in your router which IP range and mask your DHCP is using for local dynamic IPs and which range is free for local static IPs in your LAN. If your router uses the IP 192.168.1.1 I guess you are in this net: 192.168.1.0/255.255.255.0 

- The DHCP server in your router will use some of the available IPs dynamically for your devices. For ex. maybe 192.168.1.50 up to 192.168.1.200 are dynamically. So you can use the range up to 49 and over 200 as a static IP for your server PC. Check and may change the setting for your needs.

- Set the IP and mask of your TC server to an IP in the range for local static IPs., f. ex 192.168.1.8/255.255.255.0. (Check that no other device has the same static IP in your LAN)

- Try to configure your server for this IP (192.168.1.8) in realmlist, auth database, config files as described in the wiki.

- Run Wow Client and server, test everything.  If it doesn't work, fix it. Don't go further to Step 2 :-)

Step 2:   WoW client and TC server on different PCs but in the same LAN

- Use the WoW Client on a 2nd PC in your LAN. This PC can get a dynamically IP from DHCP, f.ex. 192.168.1.51/255.255.255.0

- The IP in the realmlist is the same as in step1 (f.ex. 192.168.1.8)

- Run Wow Client and server, test everything.  If it doesn't work, fix it. Don't go further to Step 3 :-)     May you need to setup your Windows Firewall or switch it off.

Step 3:   Access TC server by public WAN IP

- Be sure you got a static public IP from your ISP.

- In your router you need port forwarding of port 3724 and 8085 to your TC server (192.168.1.8)

- Change in auth DB in table realmlist the address to your public IP.

- On your 2nd PC in the LAN, change in the wow realmlist the IP to your public IP.

- Done, it should work now ;-) If not ask in the forum with exactly information where your stuck.

(Sorry, if I have forgotten something basically)

Share this post


Link to post
Share on other sites

Ok .. soo after trying crap loads of configurations i decided to try changing my routers range from its default ip range 192.168.1X  to 192.168.0.X under the assumption that trinity has a problem with a 192.168.1.X range and now it works o.O XD

So even with the correct settings if you have a router with 192.168.1.X it won't work (exact same settings except changing the ip range from 192.168.1.x => 192.168.0.x)... i don't know why but if anyone else has a similar problem change your routers range to 192.168.0.x

 

Edited by djorn01

Share this post


Link to post
Share on other sites

TC doesn't have any problems with 192.168.1.x net range. ;)

But networks can make a lot of strange problems, you need good knowledge how it works and tons of tools to test them.

Share this post


Link to post
Share on other sites

Snipaste_2019-04-28_14-56-36.thumb.png.58fb8d47817f0c230bf117cb7aff5cc5.pngSnipaste_2019-04-28_14-57-09.thumb.png.9d9150559a1161aed8611baa5874cb4b.pngSnipaste_2019-04-28_14-56-49.thumb.png.d50d98efec881f8bac4bf9ec288d7a68.png

 

wow client realese 3.3.5(12340), status fo realm is ok,but when i select it,press OK ,then return to 'logining to realm'....press ok ,return.....press ok ,return....

i stoped firewall of server(ubuntu 18),and the problem sitll.

Edited by sealone

Share this post


Link to post
Share on other sites

Greetings,

First thanks for the trinity core repack. The kids here have played lots of WoW  locally with it and appreciate the work you put into making this. Both our computers will work when playing locally. 

I have an issue with the infinite realm loop though and connecting to the host computer over a crossover cable LAN, both running windows 10. We have many other games which work in MP over the LAN so I've narrowed it down to probably being a problem with my settings on the host comp somewhere within the repack files. I've been trying various combos of IP settings in config/auth files etc. but have had zero luck in getting it to work. Computer 2 connects to computer 1 and all works well until choosing the realm. Choose realm, instant loop back to choose realm. It's green and even shows the correct amount of characters for whichever accounts we try and log in with.

Would anyone be willing to take a crack at this with me? Been trying for about a month now and the young ones just want to play together. If someone is willing to take a look just let me know what info you need me to post here. 

Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...