Jump to content
TrinityCore
CFGhost

Stuck at connected / infinite loop / login issues / battle.net

Recommended Posts

Fixed!

Here's what I had to change to get it working:

1) Opened port 3306 for SQL service

2) When I was modifying my Realm DB, from reading the guides it would seem that the "Data" table entry is all matters, I didn't realise that I also had to update the "default" table. I was making the inverse mistake that others were. D'oh!

3) When running authserver - my HOST file was forcing the server to run on localhost - which I think was wrong. My fix was to clear my HOSTS file, run the server, (now shows it running on my external IP at 8085) then put 127.0.0.1 (DDNS) back into my HOST file so that I could connect.

Hope that helps anyone w/ the same issue!

Edited by comradeboris

Share this post


Link to post
Share on other sites

Hey guys, I'm despaired..

Yes, I've searched at least 20 times, on more than 4 different sites, including your search tool, but still after ~10 hours of god damn searching, I haven't found the solution..

I think you all know the problem, I can't get anybody else to connect to my server, neither my second computer in same LAN, nor my friend. I managed to make my server online a year ago when I had an older revision though.

What works: I can join my server with either my local IP or my internal IP or my DNS (not with my external IP, I guess that's kinda part of my problem), so that works just fine. My friend can only connect (WAN) to the auth server (Realm Loop) and my other PC (LAN) isn't even able to connect to the auth server, only when I edit it's hosts file to "10.0.0.1 MyDNS". Then it's obviously able to connect and join the game, but that's only a small "solution" for LAN computers.. I want it to work for everyone (or let's say for my friend)..

 

So this is what I got:

Win 7 64bit

       Auth.log:

TrinityCore rev. 2013-02-15 17:00:09 +0000 (e685b7bd9ec3) (Win64, Release) (authserver)

Using configuration file authserver.conf.
OpenSSL 1.0.0e 6 Sep 2011 (Library: OpenSSL 1.0.0e 6 Sep 2011)
Opening DatabasePool 'auth'. Asynchronous connections: 1, synchronous connections: 1.
MySQL client library: 5.5.19
MySQL server ver: 5.5.19 
Connected to MySQL database at 10.0.0.1
MySQL client library: 5.5.19
MySQL server ver: 5.5.19 
Connected to MySQL database at 10.0.0.1
DatabasePool 'auth' opened successfully. 2 total connections running.
Started auth database connection pool.
Updating Realm List...
Added realm "MyRealmNameHere" at 10.0.0.1:8085.

     

      Server.log:

Using configuration file worldserver.conf.
Using SSL version: OpenSSL 1.0.0e 6 Sep 2011 (library: OpenSSL 1.0.0e 6 Sep 2011)
Using ACE version: 6.1.4
TrinityCore rev. 2013-02-15 17:00:09 +0000 (e685b7bd9ec3) (Win64, Release) (worldserver-daemon)
Realm running as realm ID 1
Using World DB: TDB 335.51
World initialized in 0 minutes 6 seconds
worldserver process priority class set to HIGH
TrinityCore rev. 2013-02-15 17:00:09 +0000 (e685b7bd9ec3) (Win64, Release) (worldserver-daemon) ready...

Got the TDB from here (Git), it's revision 335.51.

Made everything as in your guide and included 2 world updates that were in the updates folder.

My hosts file contains: 127.0.0.1 localhost

                                    10.0.0.1   MyDNS.no-ip.org
10.0.0.1 is my internal IP as you can guess
Authserver.conf has my internal IP (10.0.0.1)
Worldserver.conf also internal IP
Realmlists are set to MyDNS
I'm using SQLYog, this is in the realmlist table:
1 MyRealmName MyDNS 127.0.0.1 255.255.255.0 8085 1 0 9 0 0 12340
My Windows Firewall is usually turned off, but I've activated it and it doesn't change a thing.
And my Antivirus and Firewall is Kaspersky Internet Security 2013. (back then when my server worked it was version 2012)
And I think I have forwarded the TCP ports 3724 and 8085. It looks like this: http://img705.imageshack.us/img705/8380/portforward.png
So Local IP is my internal IP and it's set to "Any Port to 3724 and Any Port to 8085" or something like this, I don't really know how that works exactly. But with this setting when my auth and worldservers are running and I check the ports at canyouseeme.org it says success. (when servers aren't running, it says failed)
 
 
I think that should be enough information, if not I'm gonna add it then, when asked to.

Please help me, I'm out of ideas..

Share this post


Link to post
Share on other sites

you put in your local LAN IP, and can't figure out why anyone outside of your LAN can't connect? maybe you should stop and think on that one for a bit.

Share this post


Link to post
Share on other sites

I've done everything like in the wiki, tried all possible configurations in the config and Db, but nothing solved my problem, so please give me a little help, there is no thread on this forum (which I have found) which contains an answer to my problem.. 

Share this post


Link to post
Share on other sites

That's funny, because you are only the millionth person (of course I am rounding up) to post this, and I recall all of them being solved in the end.

Share this post


Link to post
Share on other sites

Don't you think I know that after searching for several days? (I've had this problem too back then, but I could solve it with the hosts file, because that wasn't part of your guide)

I've read them all, still not a solution for my problem. So can you help me now or not? 

Share this post


Link to post
Share on other sites

If I remember correctly (out of town atm), both of my conf files point to 127.0.0.1 and my realmlist table has the external IP address. There were no LAN IPs used anywhere. Also make sure you ports are opened and forwarded on your router.

Share this post


Link to post
Share on other sites

@Matter94

Ports opened = allow from firewall

Ports forwarded = router/proxy settings

 

Iv'e said this , time and time again.

 

Everything is pointing to internal. Like baric mentioned above. The only external is the realmlist.DB. (Tell your friends to use the external in thier realmist.wtf file)

 

Depending on the ports you have forwarded and opened. You only need 3724 for the authserver and 808* for your world.

 

That's it!

Share this post


Link to post
Share on other sites

Well I think I've opened and forwarded everything correctly, the thing is nobody can ping my external IP, I've tried it at my Dad's house and when I ping my DNS or external IP (DNS points to ext IP) I get no answer.. I guess that shouldn't be like that?

Share this post


Link to post
Share on other sites

At home, go to a website like whatismyip.com. Than see if you can ping it from your Dad's house. If you can hit the address, than it's something on your DNS side of configuration, nothing to do with TC.

If the address changes, be sure that you have the DNS service where it changes along with your IP or ISP's NS servers.

Share this post


Link to post
Share on other sites

The DNS configuration is fine, but I can't ping my own ext IP (or my Dad's IP from my PC). Funny thing is I can ping my DNS from my PC (getting my ext IP back), but no response when I try it at my Dad's PC. But I can ping my Dad's IP from his PC, so there must be something wrong with either my PC or my router.. :(

Share this post


Link to post
Share on other sites
The DNS configuration is fine, but I can't ping my own ext IP (or my Dad's IP from my PC). Funny thing is I can ping my DNS from my PC (getting my ext IP back), but no response when I try it at my Dad's PC. But I can ping my Dad's IP from his PC, so there must be something wrong with either my PC or my router.. :(

 

The External IP is resolved from your ISP. You can also try to reset your router it so that it changes the MAC address. The external IP should not change unless you have an agreement from your ISP and you have a static external IP. But, if you can't ping your own external IP and you are able to get on the internet, you configured something wrong. You may also have a special setting in your router to not allow pings, either way, you may have to call your ISP or the support line for your router.

  • Upvote 1

Share this post


Link to post
Share on other sites

Ok so I've tried to start the server on my dad's PC and it just works fine, my friend can also join the server. Now the funny thing is: My dad has the same ISP and the same router as me. Same OS, only difference is that he has installed KIS 2012 and I have KIS 2013. So either it is the new Kaspersky blocking all incoming and outcoming pings (and thus also connections from outside I guess?) or some stupid program I don't know about. Could VPN programs be a problem? Like Hotspot Shield or OpenVPN?

Share this post


Link to post
Share on other sites

Well the question is.. What on earth do you have installed on that PC?

Seems like it's blocking everything. It's blocking a simple ping?

Share this post


Link to post
Share on other sites

It really seems like that, I don't know. I can't ping my own external IP (last time I was at home), lol ^^ or any other IP except localhost or internal IPs. What the hell is blocking that? :/

Share this post


Link to post
Share on other sites

Wait I've just noticed a difference in the router page, it says "Technology: VDSL" at my Dad's and "Technology: ADSL" at my router. Also something called PTM at my Dad's and at mine it's ATM and last thing is the protocol, it's PPPoE at my Dad's and PPPoA at mine.

Is this causing my problem??

 

I don't really think that, but what else could it be.. :'(

Edited by Matter94

Share this post


Link to post
Share on other sites

http://en.wikipedia.org/wiki/Point-to-Point_Protocol_over_ATM

http://en.wikipedia.org/wiki/Point-to-point_protocol_over_Ethernet

Almost the same thing.

Still, this issue should probably be brought up with your ISP. Most ISP's block certain or an amount of incoming. I don't know how your DSL is setup, and I'm not a big fan of it.

Also try turning off your 3rd party apps to test it.

Temporarily:

Turn off the anti-virus, firewall, any other network 3rd party apps. then ping your box. If you get a ping, then turn each app back on 1 by 1 as a process of elimination.

If all that still fails... call your ISP.

Share this post


Link to post
Share on other sites

Okay great news guys! I solved the problem. My configuration was all fine (as I could see on my Dad's PC), my router was the actual problem, don't ask me what it was. So for anyone who has the same problem, this is what I did: I resetted my router in the router configuration page to default settings, turned off my router, also resetted him with the reset button (holding more than 10 seconds), entered my login data (given by my ISP) so I could connect to the internet again (don't do that guys before you know your login data!!!), configured my internal IP as static (10.0.0.1), forwarded the TCP ports 3306,3724,8085 just to be sure, and yeah that's it.

My server configuration: In the realmlist table I set my DNS, auth and worldserver.cfg I set my internal IP (127.0.0.1) and my root user + pw, and my hosts file only contains 127.0.0.1 localhost, that's it. No need to edit it. :)

 

Thank you for your answers, and I hope this will help some people out there. ;)

See ya!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...