Jump to content

Dbc, Maps, mmaps, Vmaps problems


Recommended Posts

Ah, like the lawn mowing wind riders in Org (4.3.4 branch) and the many duplicate spawns (NPCs and gameobjects), huh. One has to wonder if some of these errors aren't the result of typos (signed vs unsigned or vice versa). Maybe a slight buffer overflow or stack size being too small? Perhaps, a simple issue of a variable not being cleared or initialized properly? Surely, such things would show up during compile and/or debugged, though.

Link to comment
Share on other sites

Some info about my situation:

On windows PC

Trying to set up trinitycore 3.3.5 WoTLK

Sorry for the necro, but I'm on this step of Rochet2's explanation.

On ‎12‎/‎18‎/‎2015‎ ‎2‎:‎22‎:‎38‎, Rochet2 said:


If you want mmaps you should now run the mmaps_generator that is in the server folder (next to worldserver.exe). Make sure the vmaps etc is in the same folder since the mmap generator uses them to generate the mmaps.

But when I run mmaps_generator I get this:

"mmaps directory does not exist"

"press enter to close"


Any suggestions?


Here's a pic of my server folder and its contents. I don't think anything is missing?




Edited by gypser
Link to comment
Share on other sites

  • 3 weeks later...

I've compiled the latest revision from 3.3.5 branch. Under ubuntu 15.10. I compiled with tools also. I extracted maps, vmaps and mmaps. Everything went without errors. I followed instructions and authserver is started and worldserver imported db_full, however after that I've got an error:

Using configuration file /home/wow/server/etc/worldserver.conf.

Using SSL version: OpenSSL 1.0.2d 9 Jul 2015 (library: OpenSSL 1.0.2d 9 Jul 2015)

Using Boost version: 1.58.0

Updating Auth database...

>> Auth database is up-to-date! Containing 2 new and 8 archived updates.

Updating Character database...

>> Character database is up-to-date! Containing 1 new and 12 archived updates.

Updating World database...

>> World database is up-to-date! Containing 109 new and 882 archived updates.

Realm running as realm ID 2

Using World DB: TDB 335.60

GM.StartLevel (1) must be in range StartPlayerLevel(70)..100. Set to 70.

Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.

Using DataDir ../data/

WORLD: MMap data directory is: ../data/mmaps

VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1

VMap data directory is: ../data/vmaps

Loading Trinity strings...

>> Loaded 1036 trinity strings in 2 ms

Initialize data stores...

You have _outdated_ DBC files. Please extract correct versions from current using client.

As, I understand this kind of error appears if DBC database does not pass 3.3.5a version check, I believe I have 3.3.5a, but I'll double check!


It would be more informative like "DBC files are not from 3.3.5a" or incorrect wow version.

Edited by Porter
Link to comment
Share on other sites

  • 1 month later...

Can some one help me with map v1.8 plss i need map and i don't know haw to exract from mapextractor i try but i faild ! Pls help me ! Can someone help me with map v1.8 ? I use TrinityCore 3.3.5a !


I have done extractor but is missing :Map file './data/maps/5301243.map' does not exist!
Please place MAP-files (*.map) in the appropriate directory (./data/maps/), or correct the DataDir setting in your worldserver.conf file.
Unable to load critical files - server shutting down !!!

Help pls !

Link to comment
Share on other sites

Ok I've searched all over trying to figure this out, but I'm not getting anywhere. Let me apologize in advance if I'm posting this in the wrong area. I think I have the right place.

So I'm trying to install Trinity for the first time (have worked with Mangos in the past). Completely wiped my WoW client and reinstalled it. 

When I try to extract the maps I get "Data\common.mpq" does not exist. I looked in there and sure enough it isn't there. Now it's been YEARS since I did a map extraction, so obviously the client has been changed quite a bit too. Where is the common.mpq? I see a bunch of already seperated files in the data directory. It appears to me like they've completely restructured the client. Do I need to do an additional step to recreate the common.mpq for extraction? 



Edited by Shinzon
Link to comment
Share on other sites

--- Canned message start ---

If this is your 1st time with TrinityCore read http://collab.kpsn.org/display/tc/TrinityCore+Home

Also read http://www.trinitycore.org/f/topic/1518-trouble-with-your-trinity-install-readme-1st-faqs/

         and http://www.trinitycore.org/f/topic/10656-updating-or-starting-with-trinitycore-issues/

Since those threads are big, use control+f to find your keyword on them, also try different keywords.

Also please Look in upper right hand corner of the forum, there is a button labeled search field, feel free to search for your issues first before posting, most questions like this one have already been answered.

If you still cannot find the answers you seek feel free to make a post and tell us the steps you took to resolve this issue and we will do our best to help you.

--- Canned message end ---

Link to comment
Share on other sites

OK thanks i extracted vmaps files and, assembled them.


I have in my data dir:







Is it right? Do i have too much folders?



UPDATE: i think TrinityCore use vmaps and mmaps folder only, so i should delete the others. Am i right?

Link to comment
Share on other sites

They're extracted from your wow client using the "make" tools included with the core server. If you compiled it yourself, it'll compile those programs for you since they come with the server sources. There's a really good tutorial here on how to do everything needed to get it up and running, including creating those files.

  • Upvote 1
Link to comment
Share on other sites


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By WalkerSh
      I am going through a big problem.
      all maps in "BFa" are completely empty. (without "mobs", without "Npc's".
      how can I enable world missions and all the content in "BFa".  ??????????????????????
      I looked everywhere on this subject, but I was unsuccessful.
      I apologize, I am a beginner in the projects.

      I am currently using this project. 8.3.0 (33369)
      updated to 8.3.7 (35662)
      Source project

      My WorldServ.conf
      #    Expansion
      #        Description: Allow server to use content from expansions. Checks for expansion-related
      #                     map files, client compatibility and class/race character creation.
      #        Default:     7 - (Expansion 7)
      #                     6 - (Expansion 6)
      #                     5 - (Expansion 5)
      #                     4 - (Expansion 4)
      #                     3 - (Expansion 3)
      #                     2 - (Expansion 2)
      #                     1 - (Expansion 1)
      #                     0 - (Disabled, Ignore and disable expansion content (maps, races, classes)
      Expansion = 8
    • By reyne
      Hey there!

      I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
      After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

      `Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

      This repeats for every line in Expansion01, and then the extractor crashes.

      I'm not sure where else to go from here.

      Thanks for your help

      Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.
    • By Ithylis
      =====[ English ]=====
      First of all I'm sorry if my english is not good, it's the use of Mr Google translation
      That's after years I restart in a WoW private server.
      I thank everyone who gives their time to help TrinityCore evolve.
      I appeal to the community because I can not find the dbc-cameras-vmaps-maps-mmaps-gt files of master
      I have the official version of the game in 8.2.5 and going through Arctium I do not have the data to extract all that, or else I get it wrong.
      Would anyone be kind enough to share all these extracted files please?
      Thank you very much and have a good day / night
      =====[ Français ]=====

      Avant tout je suis désolé si mon anglais n'est pas bon, c'est l'utilisation de Monsieur Google traduction

      Voilà après des années je me relance dans un serveur privé WoW.
      Je remercie tout ceux qui donnent de leur temps pour faire évoluer TrinityCore.
      Je fais appel à la communauté, car je n'arrive pas à trouver les fichiers dbc-cameras-vmaps-maps-mmaps-gt de la version master
      J'ai la version officielle du jeu en 8.2.5 et en passant par Arctium je n'ai pas les données pour extraire tout cela, ou alors je m'y prends mal.

      Est-ce que quelqu'un aurait la bonté de partager tous ces fichiers extraits s'il vous plait ?

      Merci beaucoup et bonne journée/nuit
    • By roweqharoji
      Hi guys, this is my first post for help. I think this may be a really noob problem, but I just can't...... Sorry first if there's any mistakes.
      I tried to host 4.3.4 from https://gitlab.com/trinitycore/TrinityCore_434, but with no luck I keep recieving error like The `spell_proc` table entry for spellIdXXX has Attribute PROC_ATTR_REQ_SPELLMOD, but spell has no spell mods. Proc will not be triggered. Detailed log is attached below.
      I have host 3.3.5 without error, but when it comes to 4.3.4, I just can't figure out how to solve this situation. I've tried searching for similar problem, but they said it's client side issue. like this https://gitlab.com/trinitycore/TrinityCore_434/issues/165. I tried download different client data such as wowmortal, atlantiss, mangos wowregeneration...and other two client. But no luck with those...
      If anyone can show me any hint, I would really appreciate
    • By omgdior
      Hello user!  Help me please. How to extract the client DBC, Maps, VMaps & VMaps. I for some reason after 3.3.5 can not understand what to do in the new version. I hope for you.
  • Create New...