Jump to content
TrinityCore
Munga

Dbc, Maps, mmaps, Vmaps problems

Recommended Posts

Please put the source on C:/Source (or something, but the folder needs to be in root hard disk) and make new folder called "Build" (for example) on same place, like this:

C:/Source

C:/Build

Now try to "Configure" in cmake program, it will run all things without error, now mark "DTOOLS" for generating these tools, click on configure again, and then click on generate.

** Repeat configure if you have any table of config param in RED

Now follow the instructions what you can see in trinity core wiki, you now should build map tools without any error ;)

P.D. U only need dbc, map and vmap folders.

*ATTENTION* Without vmap folder your server cant have 100% experience of playing wow, without vmaps npcs and "monsters" run under the floor and dead corpses will go down and you will lost the drops (in some cases)

(Sorry if my english is bad or u cant understand me... and i dont use google translator.. lol)

Edited by DjYXA

Share this post


Link to post
Share on other sites

hello people. i've just compiled server on debian, but i have no client on server to extract vmaps...

vmaps from windows doesn't works..

Using DataDir /home/pro/trinity/server/

WORLD: VMap support included. LineOfSight:1, getHeight:1, indoorCheck:1 PetLOS:1

WORLD: VMap data directory is: /home/pro/trinity/server/vmaps

VMap file '/home/pro/trinity/server/vmaps/000.vmtree' is missing or points to wrong version of vmap file. R

edo vmaps with latest version of vmap_assembler.exe.

Correct *.map files not found in path '/home/pro/trinity/server/maps' or *.vmtree/*.vmtile files in '/home/

pro/trinity/server/vmaps'. Please place *.map/*.vmtree/*.vmtile files in appropriate directories or correct

the DataDir value in the worldserver.conf file.

got this error..

can someone share vmaps files for linux please?

3.3.5a client version

thanks

Edited by maxo-tt

Share this post


Link to post
Share on other sites

why does my build bin only have vmaps3 and not vmaps4 I updated it to the latest version of the client let me rephrase this if i go throught the cmake stuff again will this reset my database?I dont wanna lose my stuff lol

Share this post


Link to post
Share on other sites

--- Canned message start ---

I would love to be able to just say: "Look in upper right hand corner of the forum, there is a button labeled SEARCH, please use it", but I don't think that will be enough therefore I present to you:

searchbuttonfordummieslsq1.jpg

Please read it cover to cover, and don't bother posting again until you do!

--- Canned message end ---

Share this post


Link to post
Share on other sites

can someone share that v4 tools for windows(compiled)? i have no visual studio installed.

and no wow client on linux server to extract it :(

thanks for replay anyway

Edited by maxo-tt

Share this post


Link to post
Share on other sites

--- Canned message start ---

I would love to be able to just say: "Look in upper right hand corner of the forum, there is a button labeled SEARCH, please use it", but I don't think that will be enough therefore I present to you:

searchbuttonfordummieslsq1.jpg

Please read it cover to cover, and don't bother posting again until you do!

--- Canned message end ---

Share this post


Link to post
Share on other sites

because our genius moderator did a mistake and closed my topic, doesnt answers my message, think i can reopen it.

i need help here and not teach how to use search! i've already searched whole forum.

original post:

hello people. i've just compiled server on debian, but i have no client on server to extract vmaps...

vmaps from windows doesn't works..

Using DataDir /home/pro/trinity/server/

WORLD: VMap support included. LineOfSight:1, getHeight:1, indoorCheck:1 PetLOS:1

WORLD: VMap data directory is: /home/pro/trinity/server/vmaps

VMap file '/home/pro/trinity/server/vmaps/000.vmtree' is missing or points to wrong version of vmap file. R

edo vmaps with latest version of vmap_assembler.exe.

Correct *.map files not found in path '/home/pro/trinity/server/maps' or *.vmtree/*.vmtile files in '/home/

pro/trinity/server/vmaps'. Please place *.map/*.vmtree/*.vmtile files in appropriate directories or correct

the DataDir value in the worldserver.conf file.

got this error..

can someone share vmaps files for linux please?

3.3.5a client version

thanks

old thread link: http://www.trinitycore.org/f/topic/5620-vmaps-debian-335a/

Share this post


Link to post
Share on other sites

because our genius moderator did a mistake and closed my topic, doesnt answers my message, think i can reopen it.

i need help here and not teach how to use search! i've already searched whole forum.

original post:

hello people. i've just compiled server on debian, but i have no client on server to extract vmaps...

vmaps from windows doesn't works..

Using DataDir /home/pro/trinity/server/

WORLD: VMap support included. LineOfSight:1, getHeight:1, indoorCheck:1 PetLOS:1

WORLD: VMap data directory is: /home/pro/trinity/server/vmaps

VMap file '/home/pro/trinity/server/vmaps/000.vmtree' is missing or points to wrong version of vmap file. R

edo vmaps with latest version of vmap_assembler.exe.

Correct *.map files not found in path '/home/pro/trinity/server/maps' or *.vmtree/*.vmtile files in '/home/

pro/trinity/server/vmaps'. Please place *.map/*.vmtree/*.vmtile files in appropriate directories or correct

the DataDir value in the worldserver.conf file.

got this error..

can someone share vmaps files for linux please?

3.3.5a client version

thanks

old thread link: http://www.trinityco...ps-debian-335a/

god damn.

where did you guys find this moderator? let me know the source...

post-13636-0-54154100-1329470725_thumb.j

Share this post


Link to post
Share on other sites

to genius moderator: dont close my topic! i need help and i have a right to open a thread. while i cant find on forum!

i need vmap4extractor and assembler for windows...

someone share please

Share this post


Link to post
Share on other sites

to genius moderator: dont close my topic! i need help and i have a right to open a thread. while i cant find on forum!

No, you have no rights. This is a volunteer community of private members. Nobody guaranteed you help and support or even that you could create an account. Drop the entitlement attitude.

i need vmap4extractor and assembler for windows...

So compile it. It's included in the GitHub repository where you should have found all the rest of the core source. If you didn't compile it yourself you won't get any help here anyway.

someone share please

No.

  • Upvote 1

Share this post


Link to post
Share on other sites

Is it ok, if I get message

Processing Map 724

[################################################################]

Extracting GameObject models...Extracting World\Wmo\Band\Final_Stage.wmo

No such file.

Couldn't open RootWmo!!!

Done!


Extract V4.00 2012_02. Work complete. No errors.

during vmap4extractor? Will not miss anything?

Edited by chucky.black

Share this post


Link to post
Share on other sites

hello people. i've just compiled server on debian, but i have no client on server to extract vmaps...

vmaps from windows doesn't works..

Using DataDir /home/pro/trinity/server/

WORLD: VMap support included. LineOfSight:1, getHeight:1, indoorCheck:1 PetLOS:1

WORLD: VMap data directory is: /home/pro/trinity/server/vmaps

VMap file '/home/pro/trinity/server/vmaps/000.vmtree' is missing or points to wrong version of vmap file. R

edo vmaps with latest version of vmap_assembler.exe.

Correct *.map files not found in path '/home/pro/trinity/server/maps' or *.vmtree/*.vmtile files in '/home/

pro/trinity/server/vmaps'. Please place *.map/*.vmtree/*.vmtile files in appropriate directories or correct

the DataDir value in the worldserver.conf file.

got this error..

can someone share vmaps files for linux please?

3.3.5a client version

thanks

Share this post


Link to post
Share on other sites

Is it ok, if I get message

Processing Map 724

[################################################################]

Extracting GameObject models...Extracting World\Wmo\Band\Final_Stage.wmo

No such file.

Couldn't open RootWmo!!!

Done!


Extract V4.00 2012_02. Work complete. No errors.

during vmap4extractor? Will not miss anything?

You can ignore that message.

Indeed you can ignre it.

There is a Final_Stage.m2 that gets extracted but there is no corresponding .wmo. I even manually searched the MPQ files for it but it doesn't exist. The extractor did not miss anything.

Share this post


Link to post
Share on other sites

--- Canned message start ---

I would love to be able to just say: "Look in upper right hand corner of the forum, there is a button labeled SEARCH, please use it", but I don't think that will be enough therefore I present to you:

searchbuttonfordummieslsq1.jpg

Please read it cover to cover, and don't bother posting again until you do!

--- Canned message end ---

Share this post


Link to post
Share on other sites

I have compiled the vmap4assembler and vmap4extractor tools from source (I used the master branch) and when I run the makevmaps_simple.bat file it doesn't generate any vmaps and I get the following errors:

Extracting World\Wmo\Azeroth\Buildings\Gilneas\Gilneas_House_B_Closed.wmo

No such file.

Couldn't open RootWmo!!!

Extracting World\Wmo\Cataclysm\Tolvir\Tolvir_Central_Building_01.wmo

No such file.

Couldn't open RootWmo!!!

Extracting World\Wmo\Cataclysm\Tolvir\Tolvir_Central_Building_01_D.wmo

No such file.

Couldn't open RootWmo!!!

Extracting World\Wmo\Cataclysm\Tolvir\Tolvir_Central_Building_01_C.wmo

No such file.

Couldn't open RootWmo!!!

Extracting World\Wmo\Kalimdor\Lostisles\Goblinshipfinal.wmo

No such file.

Couldn't open RootWmo!!!

Extracting World\Wmo\Dungeon\Md_Mountaincave\Md_Mushroomcave06.wmo

No such file.

Couldn't open RootWmo!!!

Done!


E:\World of Warcraft>vmap4assembler.exe Buildings vmaps

using Buildings as source directory and writing output to vmaps

Could not read dir_bin file!

exit with errors

Is it be possible that the extractors from the Cataclysm branch may have been transfered into the master branch by mistake? If so this would explain why they don't work...

The only version of WoW installed on my computer is Wotlk 3.3.5a and I compiled the core and tools using the source from the master branch (https://github.com/TrinityCore/TrinityCore.git)

Share this post


Link to post
Share on other sites

Did you run WoW once after installing it?

Yes, I did. Also the old extractors compiled and worked flawlessly on the same setup. I began encountering the problems only with the v4 tools.

Edited by alexthecat

Share this post


Link to post
Share on other sites

Just compiled it, extracted data from base blizzard data (had all the needed files uploaded to the server), and extracted. Works like it should.

[[email protected] ~/dev/wow/tc]$ cat /etc/debian_version
6.0.4[/code]

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By roweqharoji
      Hi guys, this is my first post for help. I think this may be a really noob problem, but I just can't...... Sorry first if there's any mistakes.
      I tried to host 4.3.4 from https://gitlab.com/trinitycore/TrinityCore_434, but with no luck I keep recieving error like The `spell_proc` table entry for spellIdXXX has Attribute PROC_ATTR_REQ_SPELLMOD, but spell has no spell mods. Proc will not be triggered. Detailed log is attached below.
      I have host 3.3.5 without error, but when it comes to 4.3.4, I just can't figure out how to solve this situation. I've tried searching for similar problem, but they said it's client side issue. like this https://gitlab.com/trinitycore/TrinityCore_434/issues/165. I tried download different client data such as wowmortal, atlantiss, mangos wowregeneration...and other two client. But no luck with those...
      If anyone can show me any hint, I would really appreciate
      DBErrors.log
    • By omgdior
      Hello user!  Help me please. How to extract the client DBC, Maps, VMaps & VMaps. I for some reason after 3.3.5 can not understand what to do in the new version. I hope for you.
    • By JourneyJay
      So far, it appears to be irrelevant, since extraction continued, and I'm assuming the client will load. If not, I'll update this post.
       
      Map Extractor fails to find a series of files, but continues onward. A jpeg is linked via google drive below.
      https://drive.google.com/file/d/0By4quSN6E7RvTFhvdjZSS3JSZjQ/view

    • By hashimoff
      Hi Everybody I have problem with map extractors.
      When I run mapextractor.exe and vmapextractor.exe I got this error
      d:\Program Files\World of Warcraft>mapextractor.exe Map & DBC Extractor (vmaps too) =================== error opening casc storage 'd:/Program Files\World of Warcraft\Data': FILE_NOT_FOUND Can anyone Help ME?
    • By leandrod
      Hello guys , good night . I'm new here and I have a problem to extract the maps and vmaps and other game files version 3.3.5a , as created the server in a virtual machine and do not have much room to pass the entire game to the folder on Linux and why I need to do this process on windows and then move the files , but can not find the software to extract the files in windows . Someone would have these updated extractors to pass me ?
×
×
  • Create New...