Jump to content
TrinityCore

Dbc, Maps, mmaps, Vmaps problems


Munga
 Share

Recommended Posts

By the gods there's a lot of problems when you try to install trinity, this one is really strange tho, when I run the worldserver it doesn't seem to find the maps for some reason, it find the vmaps, dbc and mmaps just fine but not the maps for some reason, I have the files in the correct path but this is what shows up when I run the server:

ss+(2017-03-07+at+10.17.56).png

 

Running the server on Linux Debian 8 if anyone was wondering, on a system with a dual core processor and 4 gigs of ram.

Any help would be greatly appreciated.

Link to comment
Share on other sites

  • 3 weeks later...

Hello,
I would like to ask if can someone help me with fixing this issue.

I have problem when I start worldserver that says "map 0004331" is from v1.3 and 1.8 expected. Please if someone can post me some new download where map 0004331 is from v1.8 I would be happy. 

Or please help me how can I fix this issue.


Thank you all.

Link to comment
Share on other sites

  • 1 month later...

That's my trinity installation, WoW is both installed in Applications and game folders. When I try to run 3.3.5a (not launcher) it alerts some MPQ is missing, crashes but can be repaired. All locales are installed in data and enUS correctly.

iMac-di-user:~ user$ cd /Users/user/Trinity 
iMac-di-user:Trinity user$ ls -la
total 112
drwx------    25 user  staff     850  4 Mag 00:23 .
[email protected]   51 user  staff    1734  4 Mag 00:05 ..
[email protected]    1 user  staff   40964  4 Mag 00:24 .DS_Store
drwx---r-x    12 user  staff     408  4 Mag 00:01 bin
[email protected]    1 user  staff     888  4 Mag 00:23 bnetserver
[email protected]   14 user  staff     476  2 Mag 13:37 build
drwxr-xr-x     3 user  staff     102  3 Mag 23:46 data
drwxr-xr-x     4 user  staff     136  4 Mag 00:22 database
drwxr-xr-x   249 user  staff    8466  3 Mag 23:14 dbc
drwx---r-x     4 user  staff     136  2 Mag 10:56 doc
drwx---r-x     4 user  staff     136  3 Mag 23:46 etc
drwxr-xr-x     2 user  staff      68  4 Mag 00:21 game
[email protected]    7 user  staff     238  4 Mag 00:22 gz
drwx---r-x     6 user  staff     204  2 Mag 22:05 include
[email protected]   24 user  staff     816  3 Mag 09:27 lib
[email protected]    5 user  staff     170  4 Mag 00:21 logs
drwx------  5746 user  staff  195364 17 Feb  2016 maps
drwxr-xr-x  3645 user  staff  123930  3 Mag 23:16 mmaps
[email protected]   23 user  staff     782  1 Mag 18:23 repo
drwxr-xr-x    23 user  staff     782  3 Mag 20:23 repo-git-cloned
drwx---r-x     9 user  staff     306  2 Mag 18:20 share
[email protected]    1 user  staff     880  3 Mag 12:20 sql
[email protected]   42 user  staff    1428  3 Mag 23:42 tutorial-osx
drwxr-xr-x  9878 user  staff  335852  3 Mag 23:16 vmaps
[email protected]    1 user  staff     888  4 Mag 00:23 worldserver
iMac-di-user:Trinity user$ cd maps
iMac-di-user:maps user$ ls -la
total 528136
drwx------  5746 user  staff  195364 17 Feb  2016 .
drwx------    25 user  staff     850  4 Mag 00:23 ..
-rw-r--r--     1 user  staff      84 17 Feb  2016 0002035.map
-rw-r--r--     1 user  staff      84 17 Feb  2016 0002036.map
-rw-r--r--     1 user  staff      84 17 Feb  2016 0002037.map
-rw-r--r--     1 user  staff      84 17 Feb  2016 0002038.map
-rw-r--r--     1 user  staff      84 17 Feb  2016 0002039.map
-rw-r--r--     1 user  staff      84 17 Feb  2016 0002040.map
..
..
-rw-r--r--     1 user  staff   66630 17 Feb  2016 7242631.map
-rw-r--r--     1 user  staff   66118 17 Feb  2016 7242632.map
-rw-r--r--     1 user  staff   66118 17 Feb  2016 7242729.map
-rw-r--r--     1 user  staff   66118 17 Feb  2016 7242730.map
-rw-r--r--     1 user  staff   66118 17 Feb  2016 7242731.map
-rw-r--r--     1 user  staff   66118 17 Feb  2016 7242732.map
iMac-di-user:maps user$ 

Cannot extract maps, mmaps, vmaps with exe in bin, because of locale not found so tried everything even downloaded pre-extract with result

TrinityCore rev. 173db1f5498d+ 2017-05-01 00:25:13 +0200 (master branch) (MacOSX, Release, Static) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org                    \/__/

Using configuration file /Users/user/Trinity/etc/worldserver.conf.
Using SSL version: OpenSSL 1.0.2k  26 Jan 2017 (library: OpenSSL 1.0.2k  26 Jan 2017)
Using Boost version: 1.64.0
Updating Auth database...
>> Auth database is up-to-date! Containing 2 new and 97 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 1 new and 67 archived updates.
Updating World database...
>> World database is up-to-date! Containing 19 new and 1910 archived updates.
Updating Hotfixes database...
>> Hotfixes database is up-to-date! Containing 2 new and 104 archived updates.
Realm running as realm ID 1
Using World DB: TDB 720.00
Using enUS DBC Locale
Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
Using DataDir /Users/user/Trinity/data/
WORLD: MMap data directory is: /Users/user/Trinity/data/mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: /Users/user/Trinity/data/vmaps
Map file '/Users/user/Trinity/data/maps/0000_43_31.map' does not exist!
Please place MAP-files (*.map) in the appropriate directory (/Users/user/Trinity/data/maps/), or correct the DataDir setting in your worldserver.conf file.
Unable to load critical files - server shutting down !!!
 

Link to comment
Share on other sites

15 minutes ago, Aokromes said:

 

TrinityCore rev. 173db1f5498d+ 2017-05-01 00:25:13 +0200 (master branch) (MacOSX, Release, Static) (worldserver-daemon)
you are using 7.2.0 branch not 3.3.5a

Yes because worldserver wants 7.x.x full world sql, won't accept 3.x.x thats crazy. Will rename 7-->3 sql work?

Link to comment
Share on other sites

18 minutes ago, udumblamer said:

Yes because worldserver wants 7.x.x full world sql, won't accept 3.x.x thats crazy. Will rename 7-->3 sql work?

Just follow the wiki step by step sticking to the version you want, and in any case, do not mix both versions.

(Start over all the times you need, eventually you'll learn to do it easily without the wiki)

  • Upvote 2
Link to comment
Share on other sites

29 minutes ago, udumblamer said:

Yes because worldserver wants 7.x.x full world sql, won't accept 3.x.x thats crazy. Will rename 7-->3 sql work?

48 minutes ago, Aokromes said:

 

TrinityCore rev. 173db1f5498d+ 2017-05-01 00:25:13 +0200 (master branch) (MacOSX, Release, Static) (worldserver-daemon)
you are using 7.2.0 branch not 3.3.5a

Will download 3.3.5a, recompile and retry. Please specify if version is different for each version because following the guide exactly as it is only for master.

Link to comment
Share on other sites

The wiki for OS X lacks the steps to choose branch (master or 3.3.5a). Just take that part from the Linux section that is exactly the same.

You can do what the linux wiki says and use:

git clone -b 3.3.5 git://github.com/TrinityCore/TrinityCore.git

Or if you already have the repo cloned, simply switch to the 3.3.5 branch:

git checkout 3.3.5

Link to comment
Share on other sites

..

3 hours ago, udumblamer said:

Yes because worldserver wants 7.x.x full world sql, won't accept 3.x.x thats crazy. Will rename 7-->3 sql work?

One thing that I notice is that a lot of users keep trying to compare 3.3.5a and master. They are completely different. period.

 

6 hours ago, udumblamer said:

That's my trinity installation, WoW is both installed in Applications and game folders. When I try to run 3.3.5a (not launcher) it alerts some MPQ is missing, crashes but can be repaired. All locales are installed in data and enUS correctly.

^ this particular issue sounds like a client issue on your Mac and not a specific TC world/authserver issue.

This is very known for old clients running on newer MacOS. Everyone I know including myself can not run old clients on the MacOS. They just no longer work intentionally.

It's like trying to run a 64 bit application on a very very old Windows 32 bit OS. It just won't work. (except the other way around client is old and the OS is too new)

I hacked an old Mac version client (335a) to work on the latest Sierra, however it has video issues. It can't detect the screen and will not adapt to run the newer video library with MacOS (El Capitan / Sierra). I can't speak for older versions of MacOS.

Let me know if you have any more questions about old clients, running on newer versions of Mac.

Just run a Windows version on Wine within MacOS. You will have 0 issues.

Link to comment
Share on other sites

  • 2 weeks later...

Okay so I'm a tiny bit confused. Firstly I had no clue which client I was meant to get or where from, so I got the one from http://www.trinitywow.org/install/?page=install. Regardless, as you can see, the extractors are definitely in the same directory as my wow.exe:

Capture.PNG

But when I try to run them I get the following:

Capture.PNG

Why is it searching in my user directory instead of the directory it's in..? Also, on an unrelated note, I do not appear to have a realmlist table.

Link to comment
Share on other sites

2 minutes ago, LordKanelsnegle said:

Okay so I'm a tiny bit confused. Firstly I had no clue which client I was meant to get or where from, so I got the one from http://www.trinitywow.org/install/?page=install. Regardless, as you can see, the extractors are definitely in the same directory as my wow.exe:

Capture.PNG

But when I try to run them I get the following:

Capture.PNG

Why is it searching in my user directory instead of the directory it's in..? Also, on an unrelated note, I do not appear to have a realmlist table.

I'm not sure what that doc is...

This for 335a, correct?

Just use https://trinitycore.atlassian.net/wiki/display/tc/Installation+Guide

that sounds like a repack

 

Link to comment
Share on other sites

Just now, CDawg said:

I'm not sure what that doc is...

This for 335a, correct?

Just use https://trinitycore.atlassian.net/wiki/display/tc/Installation+Guide

that sounds like a repack

 

Oh sorry, I should've mentioned, this was pulled from the master branch so presumably  7.2.0.24015 - aaaaaand now that I've said that I realise it's probably because the client I tried using is 7.1.5 lol

If that is the case, can anyone please point me towards a working client for the build I'm trying to use? PM would be nice

Link to comment
Share on other sites

1 hour ago, CDawg said:

The reason I asked about 335a, was that doesn't look like 7.x version of WoW, my directory has like battle.net, wow-64, etc...

Yep, pretty sure the client I was trying to use is the issue. Would you be able to point me towards where you got yours? :P

Edited by LordKanelsnegle
Link to comment
Share on other sites

If you are talking about Blizzard's trial account it is all the same it is still the full version of world of warcraft client 7.2.0 it just means until you pay for it you only get a trial account the client is still the full version and is complete if that is what you mean.

  • Upvote 1
Link to comment
Share on other sites

7 hours ago, codeman8214 said:

If you are talking about Blizzard's trial account it is all the same it is still the full version of world of warcraft client 7.2.0 it just means until you pay for it you only get a trial account the client is still the full version and is complete if that is what you mean.

yeah thats what I meant, so I'd be able to use that to join my trinity server right? I'd just have to run the extractors and connection patcher?

Link to comment
Share on other sites

Hello,

i'm trying to get 7.2 TrinityCore working and i did everything according to the tutorial.

My last step was to place TDB_hotfixes.sql and TDB_world.sql in my folder and to start worldserver.exe. It didnt ask me to update the database, it just just seemed to do it automatically. However, after the autopopulating the window just closed itself. I started bnetserver, waited a few seconds and tried to start worldserver again but it always closes itself.

What did i do wrong?

 

 

Server.log

Link to comment
Share on other sites

I think you skipped this step

Extractors

Trinity requires certain files obtained from client. You must compile the core with tools and put them on the same directory your wow binary is, after that you must run the tools.

Some are optional but highly recommended, the files are:
 

Directory Branch  
dbc all Mandatory
maps all Mandatory
vmaps all HIGHLY Recommended
mmaps all HIGHLY Recommended
cameras all Recommended

gt

master only Mandatory

Then you must copy them to the directory you have configured on the DataDir value on your worldserver.conf, to avoid errors you can simply copy all the directories on the same directory has worldserver binary without modify worldserver.conf

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By WalkerSh
      Friends,
      I am going through a big problem.
      all maps in "BFa" are completely empty. (without "mobs", without "Npc's".
      how can I enable world missions and all the content in "BFa".  ??????????????????????
      I looked everywhere on this subject, but I was unsuccessful.
      I apologize, I am a beginner in the projects.

      ====================================================================
      I am currently using this project. 8.3.0 (33369)
      http://www.ac-web.org/forums/showthread.php?237071-World
       
      updated to 8.3.7 (35662)
      https://mega.nz/file/0dpmla4Q#4tKwrc-G9uhyxCkJozNwZp8Pr0ArgZmwO-ay7OCMvGw
      Source project
      https://github.com/TrinityCore/TrinityCore

      ====================================================================
      My WorldServ.conf
      #    Expansion
      #        Description: Allow server to use content from expansions. Checks for expansion-related
      #                     map files, client compatibility and class/race character creation.
      #        Default:     7 - (Expansion 7)
      #                     6 - (Expansion 6)
      #                     5 - (Expansion 5)
      #                     4 - (Expansion 4)
      #                     3 - (Expansion 3)
      #                     2 - (Expansion 2)
      #                     1 - (Expansion 1)
      #                     0 - (Disabled, Ignore and disable expansion content (maps, races, classes)
      Expansion = 8
      #
    • By reyne
      Hey there!

      I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
      After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

      `Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

      This repeats for every line in Expansion01, and then the extractor crashes.

      I'm not sure where else to go from here.

      Thanks for your help

      Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.
    • By Ithylis
      =====[ English ]=====
      Hello,
      First of all I'm sorry if my english is not good, it's the use of Mr Google translation
      That's after years I restart in a WoW private server.
      I thank everyone who gives their time to help TrinityCore evolve.
      I appeal to the community because I can not find the dbc-cameras-vmaps-maps-mmaps-gt files of master 8.2.0.31478.
      I have the official version of the game in 8.2.5 and going through Arctium I do not have the data to extract all that, or else I get it wrong.
      Would anyone be kind enough to share all these extracted files please?
      Thank you very much and have a good day / night
      Regards,
      Ithylis
      =====[ Français ]=====
      Bonjour,

      Avant tout je suis désolé si mon anglais n'est pas bon, c'est l'utilisation de Monsieur Google traduction

      Voilà après des années je me relance dans un serveur privé WoW.
      Je remercie tout ceux qui donnent de leur temps pour faire évoluer TrinityCore.
      Je fais appel à la communauté, car je n'arrive pas à trouver les fichiers dbc-cameras-vmaps-maps-mmaps-gt de la version master 8.2.0.31478.
      J'ai la version officielle du jeu en 8.2.5 et en passant par Arctium je n'ai pas les données pour extraire tout cela, ou alors je m'y prends mal.

      Est-ce que quelqu'un aurait la bonté de partager tous ces fichiers extraits s'il vous plait ?

      Merci beaucoup et bonne journée/nuit
      Cordialement,
      Ithylis
    • By roweqharoji
      Hi guys, this is my first post for help. I think this may be a really noob problem, but I just can't...... Sorry first if there's any mistakes.
      I tried to host 4.3.4 from https://gitlab.com/trinitycore/TrinityCore_434, but with no luck I keep recieving error like The `spell_proc` table entry for spellIdXXX has Attribute PROC_ATTR_REQ_SPELLMOD, but spell has no spell mods. Proc will not be triggered. Detailed log is attached below.
      I have host 3.3.5 without error, but when it comes to 4.3.4, I just can't figure out how to solve this situation. I've tried searching for similar problem, but they said it's client side issue. like this https://gitlab.com/trinitycore/TrinityCore_434/issues/165. I tried download different client data such as wowmortal, atlantiss, mangos wowregeneration...and other two client. But no luck with those...
      If anyone can show me any hint, I would really appreciate
      DBErrors.log
    • By omgdior
      Hello user!  Help me please. How to extract the client DBC, Maps, VMaps & VMaps. I for some reason after 3.3.5 can not understand what to do in the new version. I hope for you.
×
×
  • Create New...