Jump to content

Dbc, Maps, mmaps, Vmaps problems


Recommended Posts

Hi, i tried to make my first little 3.3.5a server, i compiled trinity but when i start the server i get:

VMap file '../data/vmaps/000.vmtree' couldn't be loaded
This is because the version of the VMap file and the version of this module are different, please re-extract the maps with the tools compiled with this module.
Unable to load critical files - server shutting down !!!

i think the problem is that i downloaded the vmaps from a forum instead of extracting it.

any help is appreciated,


Link to comment
Share on other sites

Actually i got the same error and others,what i did  was deleted my cache folder this time. i then went and login to retail and swap to a few toons, logout and redid extraction. All extraction extracted as it should be with no errors. My worldserver core starts OK now.

Link to comment
Share on other sites

Well then tell me how they can be so fucked up if I redid everything from start, the only thing I didn't do was vmaps and mmaps but everything else is from the start and is fresh. The error sounds like it is coming from the dbc files but I did those fresh too so not sure if you say core from master is running great then there really is a problem somewhere not sure where. I am reinstalling the client too just to cover everything this time as well.

I can ensure you I did everything properly this isn't my first time doing this. I agree though I cannot find anything code wise that this would be. I'm doing vmaps and mmaps now just to make sure everything is done from fresh build. I wonder is there a way to rebuild the gt folder in wow because it sounds like that is where the error is coming from since it is not from the dbc files, I am going to try and re-scan the client for changes or to force changes made to it.

  • Upvote 1
Link to comment
Share on other sites

Here is mine, core is working and i attach the gt folder zipped .


TrinityCore rev. cf5aa01be7ee+ 2017-06-18 22:17:48 +0200 (master branch) (Win64, Release, Static) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org                    \/__/

Using configuration file C:/TCSPLegion/worldserver.conf.
Using SSL version: OpenSSL 1.0.2j  26 Sep 2016 (library: OpenSSL 1.0.2j  26 Sep 2016)
Using Boost version: 1.63.0
Process priority class set to HIGH
Opening DatabasePool 'tdb_auth'. Asynchronous connections: 1, synchronous connections: 1.
DatabasePool 'tdb_auth' opened successfully. 2 total connections running.
Opening DatabasePool 'tdb_characters'. Asynchronous connections: 1, synchronous connections: 2.
DatabasePool 'tdb_characters' opened successfully. 3 total connections running.
Opening DatabasePool 'xworld'. Asynchronous connections: 2, synchronous connections: 2.
DatabasePool 'xworld' opened successfully. 4 total connections running.
Opening DatabasePool 'xhotfixes'. Asynchronous connections: 1, synchronous connections: 1.
DatabasePool 'xhotfixes' opened successfully. 2 total connections running.
Updating Auth database...
>> Auth database is up-to-date! Containing 6 new and 97 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 5 new and 67 archived updates.
Updating World database...
>> World database is up-to-date! Containing 83 new and 1910 archived updates.
Updating Hotfixes database...
>> Hotfixes database is up-to-date! Containing 6 new and 104 archived updates.
Realm running as realm ID 1
Using World DB: TDB 720.00
Added realm "Trinity" at
Using enUS DBC Locale
BaseMapLoadAllGrids enabled, but GridUnload also enabled. GridUnload must be disabled to enable base map pre-loading. Base map pre-loading disabled
Missing name MonsterSight in config file C:/TCSPLegion/worldserver.conf, add "MonsterSight = 50.000000" to this file
Will clear `logs` table of entries older than 600 seconds every 2 minutes.
Using DataDir f:\legiondata/
WORLD: MMap data directory is: f:\legiondata/mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 0
VMap data directory is: f:\legiondata/vmaps
Missing name Guild.SaveInterval in config file C:/TCSPLegion/worldserver.conf, add "Guild.SaveInterval = 15" to this file
Loading Trinity strings...
>> Loaded 1065 trinity strings in 2 ms
Initialize data stores...
>> Initialized 213 DB2 data stores in 4088 ms
Loading hotfix info...
>> Loaded 0 hotfix info entries.
Closing down DatabasePool 'xhotfixes'.
Asynchronous connections on DatabasePool 'xhotfixes' terminated. Proceeding with synchronous connections.
All connections on DatabasePool 'xhotfixes' closed.
>> Loading Cinematic Camera files
>> Loaded 34 cinematic waypoint sets in 4 ms
>> Initialized 27 GameTables in 8 ms
Loading SpellInfo store..


  • Upvote 1
Link to comment
Share on other sites


I tried to extract the mmaps vmap etc... but no one seems to work under windows 10 for now, I got some error message (and maps folder isn't created, even if I create it there is nothing on it the message keep to say "maps folder doesn't exist or is empty)

On the previous core I haven't got any problem

Link to comment
Share on other sites


I am on Windows 7, after running just the mapextractor.exe I can see the errors. Are you receiving the same ones? I just compiled the core yesterday and also haven't been able to extract.


My Error:

error opening casc storage 'D:/WowLK\Data' locale enUS
Error opening casc storage 'D:/WowLK\Data': FILE_NOT_FOUND

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By WalkerSh
      I am going through a big problem.
      all maps in "BFa" are completely empty. (without "mobs", without "Npc's".
      how can I enable world missions and all the content in "BFa".  ??????????????????????
      I looked everywhere on this subject, but I was unsuccessful.
      I apologize, I am a beginner in the projects.

      I am currently using this project. 8.3.0 (33369)
      updated to 8.3.7 (35662)
      Source project

      My WorldServ.conf
      #    Expansion
      #        Description: Allow server to use content from expansions. Checks for expansion-related
      #                     map files, client compatibility and class/race character creation.
      #        Default:     7 - (Expansion 7)
      #                     6 - (Expansion 6)
      #                     5 - (Expansion 5)
      #                     4 - (Expansion 4)
      #                     3 - (Expansion 3)
      #                     2 - (Expansion 2)
      #                     1 - (Expansion 1)
      #                     0 - (Disabled, Ignore and disable expansion content (maps, races, classes)
      Expansion = 8
    • By reyne
      Hey there!

      I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
      After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

      `Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

      This repeats for every line in Expansion01, and then the extractor crashes.

      I'm not sure where else to go from here.

      Thanks for your help

      Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.
    • By Ithylis
      =====[ English ]=====
      First of all I'm sorry if my english is not good, it's the use of Mr Google translation
      That's after years I restart in a WoW private server.
      I thank everyone who gives their time to help TrinityCore evolve.
      I appeal to the community because I can not find the dbc-cameras-vmaps-maps-mmaps-gt files of master
      I have the official version of the game in 8.2.5 and going through Arctium I do not have the data to extract all that, or else I get it wrong.
      Would anyone be kind enough to share all these extracted files please?
      Thank you very much and have a good day / night
      =====[ Français ]=====

      Avant tout je suis désolé si mon anglais n'est pas bon, c'est l'utilisation de Monsieur Google traduction

      Voilà après des années je me relance dans un serveur privé WoW.
      Je remercie tout ceux qui donnent de leur temps pour faire évoluer TrinityCore.
      Je fais appel à la communauté, car je n'arrive pas à trouver les fichiers dbc-cameras-vmaps-maps-mmaps-gt de la version master
      J'ai la version officielle du jeu en 8.2.5 et en passant par Arctium je n'ai pas les données pour extraire tout cela, ou alors je m'y prends mal.

      Est-ce que quelqu'un aurait la bonté de partager tous ces fichiers extraits s'il vous plait ?

      Merci beaucoup et bonne journée/nuit
    • By roweqharoji
      Hi guys, this is my first post for help. I think this may be a really noob problem, but I just can't...... Sorry first if there's any mistakes.
      I tried to host 4.3.4 from https://gitlab.com/trinitycore/TrinityCore_434, but with no luck I keep recieving error like The `spell_proc` table entry for spellIdXXX has Attribute PROC_ATTR_REQ_SPELLMOD, but spell has no spell mods. Proc will not be triggered. Detailed log is attached below.
      I have host 3.3.5 without error, but when it comes to 4.3.4, I just can't figure out how to solve this situation. I've tried searching for similar problem, but they said it's client side issue. like this https://gitlab.com/trinitycore/TrinityCore_434/issues/165. I tried download different client data such as wowmortal, atlantiss, mangos wowregeneration...and other two client. But no luck with those...
      If anyone can show me any hint, I would really appreciate
    • By omgdior
      Hello user!  Help me please. How to extract the client DBC, Maps, VMaps & VMaps. I for some reason after 3.3.5 can not understand what to do in the new version. I hope for you.
  • Create New...