Jump to content
TrinityCore
MrSmite

[HowTo] Patch from 3.3.5.12340 to 4.3.4.15595 (UPDATED 2014-01-24)

Recommended Posts

For the enGB client you should be able to follow the same instructions if you have all the patches. Either that or Google for a full enGB torrent but I won't be able to support those.

 

If you're seeing the Launcher start after each patch, you might want to modify your hosts file to temporarily redirect the blizzard servers to 127.0.0.1 so it can never connect. I use a firewall so I simply blocked all outbound connections.

 

Just don't forget to reset the hosts file if you ever decide to play on retail.

Share this post


Link to post
Share on other sites

at last I've found a torrent for a 4.3.4 client and I'm in the process of downloading it (takes time) and I hope it will solve some problems.

I have followed your instructions, but as said in a previous post at the second update everything is struck.

will try again for the x time, but I don't think I'll have a different result. anyway, I'll write updates about the update!

thank you.

Share this post


Link to post
Share on other sites

Where did you download that patch that is supposedly corrupt? Before you download the torrent, try using a different mirror.

 

wowwiki has a few GB mirrors for the patch you mentioned. Open the page and search for "patches to build 13164" and pick a download mirror. I usually have good luck with Atomicgamer.

Share this post


Link to post
Share on other sites

unfortunately, on wowwiki, only 4 out of 11 link lead to a downloadable file, and I have tried all of them, including Atomicgamer.

I am currently redownloading from Atomicgear and wow-latest, hoping that the first time both resulted in a corrupted file and this time I'll have better luck.

Share this post


Link to post
Share on other sites

unfortunately, on wowwiki, only 4 out of 11 link lead to a downloadable file, and I have tried all of them, including Atomicgamer.

I am currently redownloading from Atomicgear and wow-latest, hoping that the first time both resulted in a corrupted file and this time I'll have better luck.

 

I found this around page 32 after searching "world of warcraft" on patches-scrolls. Click "download" next to your language, click "download" on the next page, wait for the timer and click "download" again.

 

It's a bit convoluted but I've had good luck with them too. Their old site was better, IMO. They simply listed all the patches on a single page for you to scroll through.

Share this post


Link to post
Share on other sites

thank you for the link, I'm now downloading that too!

just finished download from a link and applying the first 5+gb patch for the second time (first time returned a new error on a music file.mpq)

in about 4 hours I should have the full 4.3.4 and in 8+ hours should have 2 more 2nd patches to try if the one just downloaded doesn't work,

thank you!

Share this post


Link to post
Share on other sites

OK! maybe I'm just tired and it's night here (I live in thailand).

one of the new downloads worked fine, but now I'm struck at update 4.0.1-13205 to 4.0.3-13287.

my archive (zip) contains ONLY wow-update-13287, I copy that file to the root and launch Blizzard Updater... nothing "there is no patch file to apply"... am I missing something?

 

tried to put the file in the data folder as well, but when I get to the next exe update, it says that my wow.exe file is not the right one, but a version older than it should be (obviously...)

 

tried also to rename the file to wow-patch-13287

tried to rename the file to wow-patch.mpq and the blizzard updater gives an error 2 suggesting to reinstall everything (!!!)

 

thank you! and sorry!

 

EDIT: added some informations

Share this post


Link to post
Share on other sites

UPDATE

don't know how, I have reached 4.0.3-13329.

as said, it's late and my brain is not fully working! I think I tried changing the file wow.tfil with another one downloaded from the net (an us one) and trying copying that wow-update-13287.mpq in update + data + root folder and renamed it. tried background updater and BNUpdate.exe too. suddenly blizzard updater worked.

now same situation, with the wow-update-13596.mpq file.

this time I have also the correct tfil file, but all the previous steps don't work.

background downloader starts for a seconds and then it tells me that it is a not an authorized download, blizzard updater says there is no patch file to apply, and BNUpdate gives me a "Localization.xml file cannot be loaded" error.

it seems to me that a file named "wow-13329-13596-win-final.mpq" is missing, but searching around I cannot find it. I downloaded several updates, and none of them included it.

 

next update later.

Share this post


Link to post
Share on other sites

You can't run the blizzard updater directly or it will tell you "nothing to update". You need to provide commandline switches to get it to work properly.

 

You should download the files at the top of the guide. I can't remember if the BAT file I used is in those but there's a section in the guide that talks about that:

 


"Blizzard Updater.exe" --skippostlaunch=1 --patchlist="Updateswow-0-xxxxx-Win-final.MPQ"

Share this post


Link to post
Share on other sites

tried last night at 3am! maybe didn't do it right, but I am missing some "xxx-win-final.mpq" files. will try again today.

anyway, I downloaded successfully a 4.3.4 client and I'm working on it now.

but I MUST make the updates work... now it's a declared war!

will give updates... and I hope solutions!

thank you

 

EDIT: update

 

tried again with commandline and I still get this error "The file "Localization.xml" could not be loaded."

the downloaded 4.3.4 client works, but cannot extract maps & c.

maps extractor starts the process but suddenly interrupt with "cannot find" errors

vmaps starts and after a while stops and vmaps assembler don't even starts

 

I can guess this client is not a "full" client.

Share this post


Link to post
Share on other sites

UPDATE

got through the 13329-13596 update. I downloaded your collection of xxx-final.mpq files and updated from the corresponding file.

even if it was enUS, I have been able to update by just changing the name to wow-patch.mpq, no need to run the commandline version of blizzard updater.

after that I'm slowly going through because of MANY corrupted archives downloaded from internet, and "lucky" me they were the 400mb, 500mb and 800mb ones! had to download from two or even three hosts (!!!) to make them work.

until now the only obscure point is the 4.0.3-13287 to 4.0.3-13329, which I don't know how I have been able to do.

after I end up to a usable 4.3.4 client, I'll try to repeat the process on another computer and try to figure that out.

 

EDIT:

finally reached 4.3.4-15595!

now the background downloader is downloading a whopping 14.8gb of files... completing in about 194 hours (!!!) wow 4.2.0a.14480 to 4.2.2.14545. time will tell.

Share this post


Link to post
Share on other sites

finished downloading those 14.8gb, restarting the background downloader gives no other options.

I start the client and get the error message "cannot stream required archive data. please check the network connection".

needless to say that the connection is working, I just don't allow the game to connect to the blizz servers by changing the realmlist file avoiding any dangerous update to a 4.3.4+ version.

mapextractor doesn't work, except for the dbc folder.

what am I missing?

thank you for your help!

Share this post


Link to post
Share on other sites

Delete (or move elsewhere) the MPQ listed in the error and restart the client. I was able to extract maps, and vmaps with the following files (after patching and letting the client finish downloading).

 

These are the MPQ files in my "Data" folder:

  • art.MPQ
  • base-Win.MPQ
  • expansion1.MPQ
  • expansion2.MPQ
  • expansion3.MPQ
  • sound.MPQ
  • world.MPQ
  • world2.MPQ
  • wow-update-base-15211.MPQ
  • wow-update-base-15354.MPQ
  • wow-update-base-15595.MPQ

 

These are the MPQ files in my "DataenUS" folder

  • expansion1-locale-enUS.MPQ
  • expansion1-speech-enUS.MPQ
  • expansion2-locale-enUS.MPQ
  • expansion2-speech-enUS.MPQ
  • expansion3-locale-enUS.MPQ
  • expansion3-speech-enUS.MPQ
  • locale-enUS.MPQ
  • speech-enUS.MPQ
  • wow-update-enUS-15211.MPQ
  • wow-update-enUS-15354.MPQ
  • wow-update-enUS-15595.MPQ
     

Share this post


Link to post
Share on other sites

ouch! my folders are not quite the same... have all those files except world2.mpq, but have many more wow-update-base-xxxxx.mpq and wow-update-enGB-xxxxx.mpq !!! I also have alternate.mpq + alternate.mpq.lock files.

I tried removing some and copying the world2 I have from a downloaded cata client, but what I get now is a new error message!

the error I got before (no world2 file) is just a plain window with written "cannot stream required archive data. please check the network connection".

if I copy the world2 file I have from a downloaded cata client, I also get an error from the wowerror.exe: 

This application has encountered a critical error:

 
---
ERROR #134 (0x85100086) Fatal condition!
 
Program: H:TEMP GAMESWorld of Warcraft 4.3.4Wow.exe
ProcessID: 4812
 
Failed to read file from local.
 
Details: (Streaming Status: Enabled / Mfil Not Rdy / Data Not Rdy, Build: 15595)
[6] err=0 text=SFileReadFile - signaturefile - Data/wow-update-base-15595.MPQ
[5] err=-2062548861 text=System_Mopaq::delta_open - error and close
[4] err=1006 text=System_Mopaq::DeltaData::OpenSrcFile - fail to open signaturefile - Data/wow-update-base-15211.MPQ 
[3] err=2 text=SFileOpenFileEx - signaturefile
[2] err=-2062548861 text=System_Mopaq::delta_open - error and close
[1] err=1006 text=System_Mopaq::DeltaData::OpenSrcFile - fail to open signaturefile - Data/wow-update-base-15211.MPQ 
[0] err=2 text=SFileOpenFileEx - signaturefile
Storm Error Msg:The system cannot find the file specified.
 
 
 
WoWBuild: 15595
Version: 4.3.4
Type:  WoW
Platform: X86
 
Patch data download failed.
Error downloading patch data from server 'http://127.0.0.1' , error code : cannotConnectError
Error downloading patch data from server 'http://127.0.0.1' , error code : cannotConnectError
---
after removing some x.mpq files (those I have more than you) and copying the world2.mpq file I have, if I start the background downloader, it starts from the beginning, teying to download all the 14.8Gb, but after less than a minute it reaches 12.8Gb and start downloading at normal speed...
I'll see in few hours what is going to happen.
thank you for your help!

Share this post


Link to post
Share on other sites

too many troubles! started again all the update process!

even the three downloaded clients are not good for extracting maps, vmaps & c.

EDIT:

doing all the update process again! following your guide step by step!

after the very first update, WoW, refused to start giving errors... I started again with same result, then bored, I kept going on with the second update and so on... at every update, wow never wanted to start giving errors...

arrived at the 4.2.0-14333 version and now wow starts normally! (cannot login to any server though)

in the data folder I am still missing the world2.mpq file.

I tried background downloader at wow-4.0.6.13596-to-4.0.6.13623 and no updates were available.

I tried now and 14.8Gb are available.

finish in about 7 hours.

what do you think?

the updates I have found starting from now, require to copy a bunch of files, including wow.exe wow.tfil/mfil battle.net and some MPQ to be put inside data and data/enGb, but NO win-final files (I already downloaded yours)

I'm not sure, should I run the update with those files? I just did the 14333 update by just copying that bunch of files and didn't run any update. wow starts and seems working, but I still have to run the batch updater files pointing at win-final.mpq!!! (the wow.exe is already updated since I copied from the archive, so there should not be any need to run the file... or am I wrong)

I wait for a sufggestion before proceeding... too scared!!!

Share this post


Link to post
Share on other sites

Why are you trying to start WoW after each update? You should just move from one update to another, stopping to run backgrounddownloader.exe after the specified updates.

 

You should also be patching either with your internet disabled or WoW servers blocked so the Launcher which runs automatically after some patches won't bork you to 5.x. Only allow internet connections when running backgrounddownloader.exe.

 

This is a high level description of how I patched:

 

  • Started with 3.3.5.12340
  • Patched to 4.0.0.12911 using Cata DVD (iso)
  • Patched to 4.3.4.15595 manually
  • Ran BackgroundDownloader.exe after
    • wow-4.0.6.13596-to-4.0.6.13623 (downloaded 7 GB)
    • wow-4.3.0.15050-to-4.3.2.15211 (downloaded 7 GB)
    • wow-4.3.3.15354-to-4.3.4.15595 (downloaded 4 GB using TFIL 1D5153E3CE003B4734AF95852EA119AA)

After this I extracted maps / vmaps and then logged into a compiled TrinityCore. I allowed wow.exe through my firewall to let it finish streaming whatever data was left.

 

I kept the game from timing out and logging me off by using a program I whipped up in Visual Basic 6 to send the jump (space) key to wow.exe every few seconds. I left it running for 24 hours though I don't know how much time it actually took. The lag meter on the action bar tells you how much has been downloaded.

Share this post


Link to post
Share on other sites

run wow after each update for no specific reason, just wanted to check if working or not... taking a NO as a wrong made update.

launcher is not allowed to connect to internet at all! once it screwed up everything and since that time it is blocked, so no worry for that!

at the first background downloader step, nothing has been found to be downloaded. so I tried now and is downloading 4.1.0.14007 to 4.2.0.14333.

after finished, I'll go on with the updates and see if it has some more to download after 4.3.2.15211 update, and then hope to reach the final step.

thank you!

Share this post


Link to post
Share on other sites

This thread almost makes me want to stay with 3.3.5a forever...

 

Indeed. The problem is that 4.x development was largely hidden from the general public and when it finally became confirmed that Trinity will develop for 4.3.4.15595, Blizzard had already started changing over the update servers for 5.x.

 

It has become increasingly harder for people now to find a working 4.3.4 client and by the time that branch goes to full active development, the Trinity userbase will shrink considerably.

 

run wow after each update for no specific reason, just wanted to check if working or not... taking a NO as a wrong made update.

launcher is not allowed to connect to internet at all! once it screwed up everything and since that time it is blocked, so no worry for that!

at the first background downloader step, nothing has been found to be downloaded. so I tried now and is downloading 4.1.0.14007 to 4.2.0.14333.

after finished, I'll go on with the updates and see if it has some more to download after 4.3.2.15211 update, and then hope to reach the final step.

thank you!

 

You shouldn't be running wow.exe at all until you're done. It will try to optimize things and screw up your patching.

Share this post


Link to post
Share on other sites
It has become increasingly harder for people now to find a working 4.3.4 client and by the time that branch goes to full active development, the Trinity userbase will shrink considerably.

 

From what I've seen, the Eternal-WoW client for 4.3.4 seems to be the closest to being complete. It seems to have things that the Monster-WoW client lacks, but I may be remembering wrong. All I can say for sure is that the extractors work perfectly with the Eternal-WoW version of the 4.3.4 client.

 

Oddly, the Monster-WoW client for 4.3.4 seems to be complete enough to run as the game client for both Windows and Mac.

Share this post


Link to post
Share on other sites

ok... did it again for the third time! nothing, nothing, nothing!

still the same result: start wow and get the error message: "cannot stream required archive data. please check the network connection"

no wowerror.exe started, just a plain window from wow.exe!

mapextractor doesn't work: except for the dbc folder, doesn't even create the maps folder.

one of the next days will try from another computer under windows xp pro 32bit. all my tests until now have been done on win7 64bit.

Share this post


Link to post
Share on other sites

I have no explanation to this... but now wow.exe starts! it took a while to open because it had to perform some optimization tasks (no, not the launcher).

after that I noticed it "combined" some files in data and dataengb folders and the world2.mpq file I was missing it "magically" appeared.

the reason wow.exe didn't start for quite a few times before realizing it has to merge those files is unclear to me...

now I started the background downloader and it still has to download about 14gb (again!) of data, but now it says that the file is 4.3.3.15354 to 4.3.4.15595.

from the connection info panel, it seems to me that half or so of data has been already downloaded, so maybe it will just download the remaining and then jump at the end.

tomorrow will give more info on this.

while waiting I tried to download the monster-wow and the eternal-wow clients... too bad they will be ready in about 7 weeks or so!

Share this post


Link to post
Share on other sites

while waiting I tried to download the monster-wow and the eternal-wow clients... too bad they will be ready in about 7 weeks or so!

 

Is your Internet service that slow?

Share this post


Link to post
Share on other sites

I live in thailand, and funny thing! if I download using jdownloader, emule or http links, I can sometimes reach 1.3Mb/s, but usually never under 400/500kb/s, but for some strange reason utorrent & co. are very slow! I have never seen anything over 100/150kb/s.

those wow clients "run" at no more than 10kb/s!

the wow patch of 14.8Gb has been downloaded (the first time) in about 5/6 hours!

note: stll have to check the last attempt of wow 4.3.4 update. will update later.

Share this post


Link to post
Share on other sites

I still think it would be best if someone was to capture these patches, etc. while doing the update and figure out how to apply them without streaming, etc., or, how to set up a local repository for it...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×