Jump to content
Sign in to follow this  

Professions completely broken in master?

Recommended Posts

So - I don't know if I did something wrong or what.


Let me first describe the issue, and then describe my setup.

1. The problem

When I learn a profession (have not tried all, but have tried tailoring, enchanting, mining and blacksmithing), the skill appears on the professions pane, and the skill becomes 0/0.

Tailoring is impossible to level, as the initial 3 recipes (of greatest importance is Bolt of Linen Cloth) are missing.

Mining is impossible to level, because mining doesn't grant any levels, and the pick shows red text indicating mining skill is missing.  However, if I click on a mineral node, (copper - have not tried other minerals), it does mine!

Have not tried to actually make something with blacksmithing and enchanting.


2. The setup

My setup is fresh - I only started with Trinity Core yesterday, so it was a matter of following the instructions on the wiki page.

I am running a debian 10 buster server.

I followed the linux / debian instructions to download the latest code in the master branch from git, and then compile it, etc.

I used the data files generated from the current version of World of Warcraft retail.

I used the database files that were in the wiki... TDB830.20061


3. According to the issues board, there seems to be a similar sounding issue, but not identical to my symptoms - about tailoring at a much higher level than mine.


It said that this was caused by the DB values being wrong.

If that is so, I assume there's a disconnect between the DB script I used, and the code I am running (830 for the sql file; vs 837 being the latest code version).

Is this what is causing my problem?

How do we keep the DB and code in sync?

And where can we get the older client from?


4. So after I posted this thread, I went digging into the DB.

Lo and behold, I found that the values in character_skills table seem off, and aligned with what I was seeing on the screen.

 i.e. character_skills table contains the following entry (character level 8):

1, 186, 1, 40

According to Wowhead, mining is skill id 186, so this should be something like: 1, 186, 1, 75 or 1, 186, 1, 300

Furthermore, 186 doesn't exist in the table skill_tiers, which I assume is necessary to learn the correct profession, given the data of the other entries.

So I think this confirms that TDB830.20061 is the issue.

Line 5459 of TDB_full_world_830.20061_2020_06_17.sql - There's no skill 186 in this table, hence the skill is being treated as some combat skill (5 x char level).

Now I'd like to ask where I can find an ERD of the db, so I can try to fix it myself.

I'll contribute back once I have fixed it.






Thanks in advance


Edited by fatotaku

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...