Jump to content
TrinityCore

I'm trying to make a WotLK local LAN server but it doesn't work. It work, by default, on the computer where server is installed but not on the other PCs.


Francisca
 Share

Recommended Posts

Hello everyone, I hope you can help me with my problem.

I have downloaded this ready-to-use "World of Warcraft WoTLK + Private Server Emulator" from 1377x and seems to work really well on the computer where is installed. Is based on Trinity and provide both server and the game.
If I want the game to be "opened", the readme tell me to edit authserver.conf but not much else. And I don't think is the right way to proceed.

Now, let's say that all local IPs are static.
The server (MySQL, Authserver, Worldserver) is located on 192.168.0.17 connected to my router via WiFi.
The game is located on 192.168.0.20 and connected directly to my router with a ethernet cable (this PC do not have WiFi).

I start the server programs (1st MySQL.bat, then authserver.exe and last worldserver.exe) with all default options, everything load fine.
In the game PC I changed the realmlist.wtf in "set realmlist 192.168.0.17"

I can connect from game computer with the default credentials provided (admins/admins) and WoW show me the server list (just one, Trinity). If I click Trinity it says "Logging in to game server" but then return to server list.

I read/watch maaaany tutorials and they show me that I should modify, with HeidiSQL, the auth>realmslist>address from 127.0.0.1 to the server IP: 192.168.0.17. LocalAddress and LocalSubnetMask leave as default: 127.0.0.1 and 255.255.255.0

Then, always on server PC, I port forwarded the TCP 3724 and 8085. Not sure if was necessary as I found that Trinity had already opened many ports on server PC.

I also port forwarded the same 3724 and 8085 ports on my router with the server PC address.
I even tried to disable (temporarily) server firewal!

Nothing has changed. I can login, credentials were accepted, but can't access the world. As always it says "Logging in to game server" but then return to server list.

I'm out of ideas, any help? ^^'

Edited by Francisca
Link to comment
Share on other sites

I DID IT!!!

Din't know that I had to modify also the DATA window in auth>realmslist>address. I Write there the 192.168.0.17 and the last row of autserver confirm me that the Trinity server was opened on 192.168.0.17:8085.

Everything works fine now!

Thank you all anyway! <3

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...