Jump to content
TrinityCore

jerrytt

Plebs
  • Posts

    3
  • Joined

  • Last visited

Everything posted by jerrytt

  1. really? i was told 3.35a client only works with RC4 encryption which is delete after openssl 1.0.
  2. I can make compile works , not sure what will dmg to the server. I can login and play the game now! cmake ../ -DOPENSSL_SSL_LIBRARY=/usr/lib/openssl-1.0/libssl.so -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0/ -DCMAKE_INSTALL_PREFIX=/home/jerry/wow -DOPENSSL_CRYPTO_LIBRARY=/usr/lib/openssl-1.0/libcrypto.so diff --git a/src/common/Cryptography/HMAC.h b/src/common/Cryptography/HMAC.h index 4f58f57c94..45398d3bb9 100644 --- a/src/common/Cryptography/HMAC.h +++ b/src/common/Cryptography/HMAC.h @@ -89,7 +89,7 @@ namespace Trinity::Impl int result = EVP_MD_CTX_copy_ex(_ctx, right._ctx); ASSERT(result == 1); _key = right._key; // EVP_PKEY uses reference counting internally, just copy the pointer - EVP_PKEY_up_ref(_key); // Bump reference count for PKEY, as every instance of this class holds two references to PKEY and destructor decrements it twice + //EVP_PKEY_up_ref(_key); // Bump reference count for PKEY, as every instance of this class holds two references to PKEY and destructor decrements it twice _digest = right._digest; return *this; } diff --git a/src/server/authserver/Main.cpp b/src/server/authserver/Main.cpp index 33d5007114..0aac6bb739 100644 --- a/src/server/authserver/Main.cpp +++ b/src/server/authserver/Main.cpp @@ -123,7 +123,7 @@ int main(int argc, char** argv) []() { TC_LOG_INFO("server.authserver", "Using configuration file %s.", sConfigMgr->GetFilename().c_str()); - TC_LOG_INFO("server.authserver", "Using SSL version: %s (library: %s)", OPENSSL_VERSION_TEXT, OpenSSL_version(OPENSSL_VERSION)); + //TC_LOG_INFO("server.authserver", "Using SSL version: %s (library: %s)", OPENSSL_VERSION_TEXT,OpenSSL_version(OPENSSL_VERSION)); TC_LOG_INFO("server.authserver", "Using Boost version: %i.%i.%i", BOOST_VERSION / 100000, BOOST_VERSION / 100 % 1000, BOOST_VERSION % 100); } ); diff --git a/src/server/worldserver/Main.cpp b/src/server/worldserver/Main.cpp index 9f601f8ceb..f9a2f35b5e 100644 --- a/src/server/worldserver/Main.cpp +++ b/src/server/worldserver/Main.cpp @@ -206,7 +206,7 @@ extern int main(int argc, char** argv) []() { TC_LOG_INFO("server.worldserver", "Using configuration file %s.", sConfigMgr->GetFilename().c_str()); - TC_LOG_INFO("server.worldserver", "Using SSL version: %s (library: %s)", OPENSSL_VERSION_TEXT, OpenSSL_version(OPENSSL_VERSION)); + //TC_LOG_INFO("server.worldserver", "Using SSL version: %s (library: %s)", OPENSSL_VERSION_TEXT, OpenSSL_version(OPENSSL_VERSION)); TC_LOG_INFO("server.worldserver", "Using Boost version: %i.%i.%i", BOOST_VERSION / 100000, BOOST_VERSION / 100 % 1000, BOOST_VERSION % 100); } );
  3. ARCHLINUX /usr/sbin/ld: warning: libssl.so.3, needed by /usr/lib/libmariadb.so, may conflict with libssl.so.1.0.0 /usr/sbin/ld: warning: libcrypto.so.3, needed by /usr/lib/libmariadb.so, may conflict with libcrypto.so.1.0.0 /usr/sbin/ld: ../../common/libcommon.a(BigNumber.cpp.o): undefined reference to symbol '[email protected]@OPENSSL_3.0.0' /usr/sbin/ld: /usr/lib/libcrypto.so.3: error adding symbols: DSO missing from command line openssl 3.0.7-4 openssl-1.0 1.0.2.u-4 cmake ../ -DOPENSSL_SSL_LIBRARY=/usr/lib/openssl-1.0/libssl.so -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0/openssl/ -DCMAKE_INSTALL_PREFIX=/home/jerry/wow -DOPENSSL_CRYPTO_LIBRARY=/usr/lib/openssl-1.0/libcrypto.so -DOPENSSL_VERSION=1.0 btw , I don't know why this cmd can't locate openssl 1.0 : cmake ../ -DOPENSSL_SSL_LIBRARIES=/usr/lib/openssl-1.0/ -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0/openssl/
×
×
  • Create New...