Jump to content

Trinitycore as Debian 9 Daemon including shutdown and restart

Sandra Kaimraptor

Recommended Posts

Dear Community,

currently I am using screen to manage the daily restart of that server to prevent overloads. But screen is not a clean solution for that. I want to integrate the worldserver and authserver as services to my system. Unfortunately I do not know how I can write into the running daemon any command via Bash shell? sighup shutdown via killall is no option because I need to shutdown the server with 5 minutes delay and informing all players about the shutdown.

Has anyone any idea how to resolve that issue?

Kind Regards

Sandra Kaimraptor

Edited by Sandra Kaimraptor
Link to comment
Share on other sites

  • 2 weeks later...

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Atréalis
      When taking quests, NPC text is in French (witch is what I want) but when checking or completing, text become in English.
      screens: quest proposal - quest validation
      Does anyone have a clue how to change it to French only? (and what in the world have I done for it to be like this?)
    • By Bhalandros
      I know this question has been asked many times, but I've seen some of the topics and none seem to really explain how to do it.
      My question is simple. How can I make so that multiple servers, with different world databases (In fact, completely different versions, a master branch server and a 3.3.5 branch server) I don't really want them to be RUNNING at the same time, Just that if I go to the folder where I have the server for the master branch, it opens without problems, and then if I open the server on the 3.3.5 branch, they don't affect each other.
      So how would I do it? New MySQL connection? Rename databases? (as in, Auth335 or something like that, on the same MySQL connection)
      I figured it'd be renaming databases, but I don't know exactly all I have to change, and where. Is it enough if I change it on the .conf files or do I have to change something pre-compile?
      Thanks in advance to everyone.
      (I hope I made myself clear, it cost me a lot to write this down for some reason)
    • By blkht
      The worldserver crashes whenever I create a character. Seems like there is an issue with mysql, but I have no idea what the issue is. Anybody knows what`s happening here?

    • By skeezix
      Hello -
      Does anyone mess with this particular flavor? I installed a new Debian 8.5 server, nothing but the basics. I installed the needed packages, setup a git clone for brand trinity-wotlk-ai (3.3.5), and tried to compile. I can compile this on Windows, but not linux. I can, though, compile the normal trinity build. I tried this a few days ago but not sure which commit/build as I deleted it once I knew I could at least compile it. (sorry!)
      I didn't really look through the build logs on Windows since it compiled fine, but I assume the issues below are existent there as well, but just don't stop it from finishing. In linux, I'll see warnings from compiling some of it, but then it gets all the way to 100% progress then dumps the whole thing.
      Here's the output of cmake - http://pastebin.com/c96LMDBE
      Here's the output of make (errors/warnings only) - http://pastebin.com/tUH1L0bn
      This server is a virtual machine, 22 cores and 32GB memory. The commit I'm grabbing for mangosbot is 9fefd30dabd9d5e8be82651e288feeb9b5025c22 and I also tried the previous, which is 55b583d1726fe70d55c4b9efab476d3fa0710ae4 and got the same errors.
      The directions for mangosbot were to clone whatever branch you want for it, then follow the same directions for compiling/installing TrinityCore. I went through these step-by-step and cannot find anything else I could do. Anyone have any ideas? I'm with limited coding knowledge.
      Note - I also tried Ubuntu 16.04, as well as Fedora (23 I think? whatever is the latest at this point) and got the same compile errors on those as well.
    • By KevinC.
      Hey guys,
      I've got the following errors during compiling TrinityCore 6.x on a debian 8.4 machine.
      [ 24%] Building CXX object src/server/scripts/CMakeFiles/scripts.dir/Commands/cs_list.cpp.o In file included from /root/wow-source/trinitycore_6.x/TrinityCore/src/server/game/Achievements/AchievementMgr.h:22:0,                  from /root/wow-source/trinitycore_6.x/TrinityCore/src/server/scripts/Commands/cs_guild.cpp:25: /root/wow-source/trinitycore_6.x/TrinityCore/src/server/game/Achievements/CriteriaHandler.h:65:32: error: declaration of ‘const Criteria* CriteriaTree::Criteria’ [-fpermissive]      Criteria const* Criteria = nullptr;                                 ^ compilation terminated due to -Wfatal-errors. src/server/scripts/CMakeFiles/scripts.dir/build.make:468: recipe for target 'src/server/scripts/CMakeFiles/scripts.dir/Commands/cs_guild.cpp.o' failed make[2]: *** [src/server/scripts/CMakeFiles/scripts.dir/Commands/cs_guild.cpp.o] Error 1 make[2]: *** Waiting for unfinished jobs....  error: declaration of ‘const Criteria* CriteriaTree::Criteria’ [-fpermissive] error: declaration of ‘const Criteria* CriteriaTree::Criteria’ [-fpermissive]CMakeFiles/Makefile2:1246: recipe for target 'src/server/scripts/CMakeFiles/scripts.dir/all' failed make[1]: *** [src/server/scripts/CMakeFiles/scripts.dir/all] Error 2 Makefile:117: recipe for target 'all' failed make: *** [all] Error 2  
      Installed compiler:
      ii g++ 4:4.9.2-2 amd64 GNU C++ compiler ii g++-4.9 4.9.2-10 amd64 GNU C++ compiler ii gcc 4:4.9.2-2 amd64 GNU C compiler ii gcc-4.9 4.9.2-10 amd64 GNU C compiler using the following cmake command:
      cmake ../ -DTOOLS=1 -DUSE_COREPCH=0 -DUSE_SCRIPTPCH=0 -DSERVERS=1 -DSCRIPTS="static" -DCMAKE_INSTALL_PREFIX=/root/wow-build/trinitycore_6.x_latest -DWITH_WARNINGS=1
      surely using make -j 4
  • Create New...