Jump to content
TrinityCore

Worldserver missing maps with up-to-date 9.0.2. client | SOLVED


Recommended Posts

Hello,

I am having trouble with running worldserver.exe after having extracted the maps and placing the folders in the RelWithDebInfo binary.

1) I use Wow client 9.0.2.37474_enus_minimal
2) The missing files mentioned by Server.log have all been extracted and I have placed the extracted map folders within the worldserver binary directory (RelWithDebInfo)


During map extraction I got these errors. Is this significant/how do I solve this?
Can't open FILE000306EF.xxx, failed to get size: BAD_FORMAT


Worldserver log
[ unrelated stuff before, I guess]

>> Hotfixes database is up-to-date! Containing 22 new and 301 archived updates.
Realm running as realm ID 1
Using World DB: TDB 837.20101
Using enUS DBC Locale
Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
Client cache version set to: 20101
Using DataDir ./
WORLD: MMap data directory is: ./mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: ./vmaps
Missing name Guild.SaveInterval in config file D:/Build/bin/RelWithDebInfo/worldserver.conf, add "Guild.SaveInterval = 15" to this file
VMap file './vmaps/0530.vmtree' does not exist
Please place VMAP files (*.vmtree and *.vmtile) in the vmap directory (./vmaps/), or correct the DataDir setting in your worldserver.conf file.
Unable to load critical files - server shutting down !!!


I use in worldserver.conf:
#    DataDir
#        Description: Data directory setting.
#        Important:   DataDir needs to be quoted, as the string might contain space characters.
#        Example:     "@[email protected]/share/trinitycore"
#        Default:     "."


My absolute path would be:
D:\Build\bin\RelWithDebInfo

I have tried:
D:/Build/bin/RelWithDebInfo
@[email protected]/Build/bin/RelWithDebInfo


But to no avail.
If the DataDir path is the issue then what should It look like?
I have no clue as to what I am doing wrong. :/

Thank you so much in advance!

 

picture.png

Edited by Harrkyotiej
Last edit!
Link to post
Share on other sites
  • Harrkyotiej changed the title to Worldserver missing maps with up-to-date 9.0.2. client
Posted (edited)

SOLVED
Anyone having this issue should use the extractor.bat in the contrib file of the trinitycore_master folder to extract maps.
That solved the problem, it had nothing to do with the maps not being there but them not being extracted properly.

Edited by Harrkyotiej
Link to post
Share on other sites
  • Harrkyotiej changed the title to Worldserver missing maps with up-to-date 9.0.2. client | SOLVED

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...