Jump to content

915 cannot connect to server on windows (local for server/client) or linux(local client, remote server) BLZ51900003

Barry Zhang

Recommended Posts

On 1/10/2022 at 3:47 AM, Barry Zhang said:

WorldSocket::InitializeHandler ByteBufferException Invalid string value () found in ByteBuffer occured while parsing initial packet from

console print this.




I have the same error.

I have test to use an other client or update sources but always the same error.

Link to comment
Share on other sites

On 1/11/2022 at 10:55 PM, Askanat said:


I have the same error.

I have test to use an other client or update sources but always the same error.

you need Arctium WoW Launcher.exe to launch wow.exe

and set port

wtf like this:

SET portal ""


Link to comment
Share on other sites

TrinityCore branch master rev aa742c8752d35f3d1a216a4a8ac6a4987cc4da7e

Compiles and runs fine in both debian amd windows 10. both x64. I am using arctium launcher thingy. when I log in, no matter what settings I put anywhere, I get a

we can't log you in with what you just entered.


I did bnetaccount create [email protected] test

I have tried, when on windows for server and client, and

with in all the places... auth.realmlist and in config file


it should allow me to connect, but it does not. also, in config.wtf I have:

SET portal ""

but I have tried ports 8085, 8092, 1119... and nothing. 8092 is what I put for LoginREST.Port though I have tried 8086 etc.

if I put a wrong IP in config.wtf, such as it will time out and give me another error, so at least I know it is trying to connect to my server. Here is the connection log:

1/21 10:21:03.351  Connection Initialize
1/21 10:21:12.702  Glue Start Login
1/21 10:21:12.702  BattleNet Attempt Logon
1/21 10:21:12.802  BattleNet Front Disconnected
1/21 10:21:12.802  Glue Fatal Error: 3
1/21 10:21:12.810  BattleNet Defer Disconnect
1/21 10:21:17.145  Connection Destroy


I have searched all over this site for 2 days, and all I found was 2 bits of info. first was to add the port in config.wtf and the second was nonsense, something about using 192.168.0.x instead of 192.168.1.x but that doesn't seem like it would be a problem. really don't want to redo my network to test that.

I have a TC 335a realm running perfectly fine on my linux machine. I can connect. My friend in Canada can connect (I am in texas) so I know it isn't a firewall thing, especially since my windows firewall is disabled.

I can give any information requested, except my passwords, of course :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...