Jump to content
TrinityCore

oXL0C0Xo

Members
  • Content Count

    30
  • Joined

  • Last visited

Community Reputation

2 Neutral

About oXL0C0Xo

  • Rank
    Advanced Member

Recent Profile Visitors

238 profile views
  1. oXL0C0Xo

    [INVALID]Auth server Error

    what happens if you try right clicking authserver.exe and run as administrator?
  2. oXL0C0Xo

    [INVALID]Auth server Error

    well if you had it running before, i would say change the configuration back to how you had it running, and then the only thing you should need to change is in the auth database, in the realmlist table in the address column of the row your server is on, change that to your hamachi ip, leave the local ip alone. that you do in navicat. you also may need to play with your client realmlist.wtf and change it to your hamachi ip on both yours and your friends client.
  3. oXL0C0Xo

    [INVALID]Auth server Error

    well I can tell you this, it's probably killing the authserver because the database tables aren't set up. Your authserver.conf doesn't contain the previous settings I mentioned, because it is an older version of the core. I would suggest checking where the LogsDir is set to, you should find a file named Auth.log there to give you a better explanation of why the server is exiting. as far as the db goes, i think you'll have to manually import the sql db creation file, which i believe is called create_mysql.sql (dont forget to modify the user and password for every query in the file before importing it). Tough to know what is changed in a repack.
  4. oXL0C0Xo

    [INVALID]Auth server Error

    are you using a repack?
  5. oXL0C0Xo

    [INVALID]Auth server Error

    # AUTH SERVER SETTINGS # # LogsDir # Description: Logs directory setting. # Important: LogsDir needs to be quoted, as the string might contain space characters. # Logs directory must exists, or log file creation will be disabled. # Default: "" - (Log files will be stored in the current path) LogsDir = "../logs"
  6. oXL0C0Xo

    [SOLVED]Change .Conf location

    what happens if you check the advanced checkbox? Sorry, I dont have a windows box
  7. oXL0C0Xo

    [INVALID]Auth server Error

    and 218 to 1, if not already Updates.EnableDatabases = 1
  8. oXL0C0Xo

    [INVALID]Auth server Error

    I'm assuming you are using windows. whats the logs say? you may need to change line 226 to Updates.AutoSetup = 1
  9. oXL0C0Xo

    [INVALID]Auth server Error

    autherserver.conf needs to be edited. Line 185 LoginDatabaseInfo = "127.0.0.1;3306;dbuser;dbpass" and Line 63 should remain BindIP = "0.0.0.0" unless you have some special configuration where your core and db are on separate machines or VMs mysql only allows local connections, unless you specifically enable remote connections for specific ip's
  10. oXL0C0Xo

    [SOLVED]Change .Conf location

    first off, are you on windows or linux? on linux, i think you define -DCONF_DIR=/home/trinitycore/conf to whatever directory you want them to be built in. ref: https://trinitycore.atlassian.net/wiki/spaces/tc/pages/10977309/Linux+Core+Installation pretty sure in windows, you just change the location of the same cmake flag
  11. oXL0C0Xo

    [INVALID]Auth server Error

    Try using 127.0.0.1 for the db IP's in worldserver.conf if its all installed on the same machine. Also make sure BindIP still 0.0.0.0
×