Jump to content
TrinityCore

A problem with Keira2


UncleChristiof
 Share

Recommended Posts

Hi everyone. I have a problem with Keira2: after editing all requied files in API folder and Keira folder i run server mysql (6.x) and open index file in keira2 folder. But it wroks very slowly and loading bar on the top of the page is freezing in the end of the loading.In .env file i've changed only db_password. In Keira - path to API index.php. What i'm doing wrong?)

I don't know what I should see when I go to http://localhost/TC-JSON-API/public/index.php, but there is only white page without anything. 

Link to comment
Share on other sites

On 10/12/2015, 13:08:42, UncleChristiof said:

I don't know what I should see when I go to http://localhost/TC-JSON-API/public/index.php, but there is only white page without anything. 

Ok so the problem is not Keira2 bu the API. Did you read the instructions ? Pay attention also to Requirements and Troubleshooting, they should help you a lot:

Quote

Requirements:

In order to install this API, your system must have:

  • TDB 335.59 or newer
  • PHP 5.4 or newer
  • Mcrypt PHP Extension
  • PHP Sqlite driver (php5-sqlite)

Troubleshooting:

  • Ensure that the entire folder TC-JSON-API (including all its files and subfolders) have the proper file permissions.

  • If you get white page or any error, check storage/logs to understand what happens.

  • If for some reasons the API is not able to read from .env file, you have to configure database manually in config/database.php file.

Link to comment
Share on other sites

11 hours ago, UncleChristiof said:

There is no any quick and easy way to install php without editing a huge amount of files?

Of course there is, there is LAMP on Linux and WAMP on Windows. And Mac there is already PHP installed, you have just to enable it.

E.g. it's very easy to install everything needed to run the TC-JSON-API on Ubuntu, just by installing LAMP and enabling MCRYPT.

You just need to google these things, feel free to ask if you are in trouble.

Link to comment
Share on other sites

On 15/12/2015, 19:33:47, UncleChristiof said:

I've installed WAMP, but there is no mcrypt extension. How i can install it? :3

To be honest I don't use Windows so I don't know how to enable MCRYPT on WAMP.

Let's google it, I'm sure you will find a lot of answers about it:

https://www.google.it/webhp?q=enable+mcrypt+wamp+server#safe=off&q=enable+mcrypt+wamp+server

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...