Jump to content
TrinityCore
Sign in to follow this  
foxnstuff

SOAP Issues Trinity Core 3.3.5a

Recommended Posts

Operating System: Windows 10

Here's what I did:

Enabled SOAP & Ra
Downloaded PuTTy.exe as a Telnet source.
Port forwarded 7878
Port Forwarded 3443

Tried Telnetting to 7878, DOES NOT CONNECT - attempts but closes immediately when it tries to.
Tried Telnetting to 3443 CONNECTS no issues.

Setting up Azer-Cms OR MangosWeb, using Ra does NOT connect to the server and fails delivery on web shop items.
Setting up Both on SOAP and it still does not connect.

Soap is ALSO enabled on Webhost.

SOAP is binding on 0.0.0.0
RA is binding on 0.0.0.0

Edited by foxnstuff

Share this post


Link to post
Share on other sites

1st thing. We don't support repacks or other sources outside of TC.

 

Have the machine bind on the actual IP. or try 127.0.0.1

RA Port is not the same as SOAP. so you can throw out 3443. Just worry about HOW you are connecting to 7878

If your server is something like 192.168.1.20 <- then use that if 127.0.0.1 does not work. Also you only need to whitelist (internally) from one machine to the other if you are using SOAP.

Again... assuming you are trying to use a web host to connect (not on the same machine), then you need to whitelist that on your router to handle the (external) connection.

 

Default Example:

SOAP.Enabled = 1

#
#    SOAP.IP
#        Description: Bind SOAP service to IP/hostname.
#        Default:     "127.0.0.1" - (Bind to localhost)

SOAP.IP = "127.0.0.1"

#
#    SOAP.Port
#        Description: TCP port to reach the SOAP service.
#        Default:     7878

SOAP.Port = 7878

Share this post


Link to post
Share on other sites

It's not a repack, and for other help I understand I'm just trying to show that for some reason telnetting is not working on SOAP.


Well I tried using the same machine AND a webhost to use soap and I can't connect.

 

I have tried 0.0.0.0 and 127.0.0.1 and nothing has worked. I have NOT tried 192.168.1.XXX to connect and I'll try that next.

I have also enabled the ports so I don't know possibly what else I can do to enable both internally or externally to connect to SOAP

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...