Jump to content
TrinityCore

Recommended Posts

Hello communities after some research I found this brief statement on how to apply a possible lock to the auto-rotate Script that is being widely used on today's servers. [PQR SCRIPT]

I ask everyone's help to be able to make this block and apply it correctly.

Discord
: vhiper#7085

PQR ->>  https://www.youtube.com/watch?v=_TGiJBLiA_k

1. Make sure AddonChannel logging is set to 1 in your config (We will use the WoW LUA API SendAddonMessage to return information when warden runs our custom LUA detections, The results will be stored here, so we will need to parse this log for them)
2. Open WardenWin.cpp , scroll down to line 119(Request.Function2), replace with Request.Function2 = 0x00819210; // Changed from FrameScript::GetText to FrameScript::Execute (Note, the old offset wasn't even for 3.3.5a since it was for a different version of WoW)
3. Open warden_checks database table, add a new entry using type 139 and using str "if(PQR_EventFrame~=nil)then SendAddonMessage('xPcW',"e7BeIAPMLTP9",'WHISPER','l0l')end" How this works Framescript::GetText is the original scan included in warden, it just reads from the client frame, we change the offset for that scan to point to FrameScript::Execute It's bascially what DoString() calls(Protected LUA Function) Once the offset is changed, we add our custom scan, and it will run the LUA on the client, but WOTLK warden doesn't support returns, so we need a way to get that data back. That's why we use SendAddonMessage, we can then check the addonchannel logs via a parse and take action


some related links.

https://paste2.org/VNyeUnkU
https://pastebin.com/BZJ2QNAM
https://www.ownedcore.com/forums/world-of-warcraft/world-of-warcraft-bots-programs/wow-bot-maps-profiles/656619-warmane-pqr-bans-2.html

Edited by VhiperDEV

Share this post


Link to post
Share on other sites

 Hi, thanks for the post, amazing research, I want to make it work here. 
 I did every steps, but the client is not running any lua script.
 
 TC_LOG_DEBUG("warden", "%s", stream.str().c_str());
Shows that the request is being send

But the Lua code is not running on the client, I've tried:
 print('Hello World')
 SendChatMessage('Hello World, 'SAY'')
 SendAddonMessage('xPcW','e7BeIAPMLTP9','WHISPER','Tester')

INSERT INTO `warden_checks` (`id`,`type`,`data`,`str`,`address`,`length`,`result`,`comment`) VALUES
(787,139,'',"print('Hello World')",0,0,'','');

What could be wrong?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...