Jump to content
TrinityCore
Sign in to follow this  
Sale

Multiple problems core, cmake, openSSL....

Recommended Posts

First time setting this up, I want to help server I am playing on to fix more issues.

But since yesterday I bump from problem to problem and it is just setup....

 

I have downloaded 3 versions of openSSL and all 3 are installed, I had manually to change location but still do not accept it.

1.1.1c, 1.1.0k and 1.0.2s

I have wasted 2 days so far, and I would really appreciate some help to set this up and start learning actual fixing.

 

I had some help from another developer, but he is busy with solving issues so he dont have time to fully guide me to set everything up.

 

I did follow steps from trinitycore requirement and I hope I did not missed anything but I dont know where is problem.

 

 

 

Selecting Windows SDK version 10.0.17763.0 to target Windows 6.1.7601.

CMake Deprecation Warning at CMakeLists.txt:22 (cmake_policy):
The OLD behavior for policy CMP0005 will be removed from a future version
of CMake.

The cmake-policies(7) manual explains that the OLD behaviors of all
policies are deprecated and that a policy should be set to OLD only under
specific short-term circumstances. Projects should be ported to the NEW
behavior and not rely on setting a policy to OLD.

 

CMake Deprecation Warning at CMakeLists.txt:24 (cmake_policy):
The OLD behavior for policy CMP0043 will be removed from a future version
of CMake.

The cmake-policies(7) manual explains that the OLD behaviors of all
policies are deprecated and that a policy should be set to OLD only under
specific short-term circumstances. Projects should be ported to the NEW
behavior and not rely on setting a policy to OLD.

 

Detected 32-bit platform

MSVC: Enabled large address awareness

MSVC: Enabled SSE2 support

MSVC: Disabled Safe Exception Handlers for debug builds

MSVC: Enabled increased number of sections in object files

MSVC: Overloaded standard names

MSVC: Disabled NON-SECURE warnings

MSVC: Disabled POSIX warnings

MSVC: Disabled generic compiletime warnings

cotire 1.7.10 loaded.

Found MySQL library: C:/Program Files/MySQL/MySQL Server 5.6/lib/libmysql.lib

Found MySQL headers: C:/Program Files/MySQL/MySQL Server 5.6/include

Found MySQL executable: C:/Program Files/MySQL/MySQL Server 5.6/bin/mysql.exe

Found git binary : C:/Program Files/Git/cmd/git.exe

 

* TrinityCore revision : 3510c222209e+ 2019-06-26 09:43:35 +0200 (master branch)

 

* Install core to : C:/Program Files (x86)/TrinityCore

 

* Build world/auth : Yes (default)

* Build with scripts : Yes (static)

* Build map/vmap tools : Yes (default)

* Build core w/PCH : Yes (default)

* Build scripts w/PCH : Yes (default)

* Show compile-warnings : No (default)

* Use coreside debug : No (default)

* Show source tree : Yes (hierarchical)

* Use GIT revision hash : Yes (default)

 

CMake Warning (dev) at dep/boost/CMakeLists.txt:50 (find_package):
Policy CMP0074 is not set: find_package uses <PackageName>_ROOT variables.
Run "cmake --help-policy CMP0074" for policy details. Use the cmake_policy
command to set the policy and suppress this warning.

Environment variable Boost_ROOT is set to:

C:/local/boost_1_66_0

For compatibility, CMake is ignoring the variable.
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Error at cmake/macros/FindBoost.cmake:1233 (message):
Unable to find the requested Boost libraries.

Boost version: 1.66.0

Boost include path: C:/local/boost_1_66_0

Could not find the following static Boost libraries:

boost_system
boost_filesystem
boost_thread
boost_program_options
boost_iostreams
boost_regex

No Boost libraries were found. You may need to set BOOST_LIBRARYDIR to the
directory containing Boost libraries or BOOST_ROOT to the location of
Boost. If you still have problems search on forum for TCE00020.
Call Stack (most recent call first):
dep/boost/CMakeLists.txt:50 (find_package)

 

Found OpenSSL library: optimized;SSL_EAY_RELEASE-NOTFOUND;LIB_EAY_RELEASE-NOTFOUND;debug;SSL_EAY_DEBUG-NOTFOUND;LIB_EAY_DEBUG-NOTFOUND

Found OpenSSL headers: C:/Program Files/OpenSSL3-Win64

CMake Error at cmake/macros/FindOpenSSL.cmake:198 (file):
file STRINGS file "C:/Program Files/OpenSSL3-Win64/openssl/opensslv.h"
cannot be read.
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

 

CMake Error at cmake/macros/FindOpenSSL.cmake:210 (list):
list GET given empty list
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

 

CMake Error at cmake/macros/FindOpenSSL.cmake:211 (list):
list GET given empty list
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

 

CMake Error at cmake/macros/FindOpenSSL.cmake:212 (list):
list GET given empty list
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

 

CMake Error at cmake/macros/FindOpenSSL.cmake:213 (list):
list GET given empty list
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

 

CMake Error at cmake/macros/EnsureVersion.cmake:76 (MATH):
MATH cannot parse the expression: "..`*10000 + ..`*100 + 0": syntax error,
unexpected exp_TIMES, expecting exp_PLUS or exp_MINUS or exp_OPENPARENT or
exp_NUMBER (4).
Call Stack (most recent call first):
cmake/macros/EnsureVersion.cmake:111 (NORMALIZE_VERSION)
cmake/macros/FindOpenSSL.cmake:231 (ENSURE_VERSION_RANGE)
dep/openssl/CMakeLists.txt:16 (find_package)

 

CMake Error at cmake/macros/FindOpenSSL.cmake:233 (message):
TrinityCore needs OpenSSL version 1.0 but found too new version ..`.
TrinityCore needs OpenSSL 1.0.x or 1.1.x to work properly. If you still
have problems please install OpenSSL 1.0.x if you still have problems
search on forum for TCE00022
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

 

Configuring incomplete, errors occurred!

See also "C:/Users/Zix/Documents/WoW server/Build/CMakeFiles/CMakeOutput.log".

See also "C:/Users/Zix/Documents/WoW server/Build/CMakeFiles/CMakeError.log".

Share this post


Link to post
Share on other sites

I also installed 1.0.2s 32-bit in root and also I did change path in CMake to openSSL and openSSL/include

issue persist. 

Share this post


Link to post
Share on other sites

 

Detected 32-bit platform

 

* Install core to : C:/Program Files (x86)/TrinityCore

file STRINGS file "C:/Program Files/OpenSSL3-Win64/openssl/opensslv.h"

you cannot use 32 bits platform and 64 bits libs, also avoid to install trinitycore to directories with spaces.

Share this post


Link to post
Share on other sites

I think I solved issue, I removed space in folder menu, deleted cashe and chosen visual studio x64 instead leaving empty, formated and generated without errors.

ty Aokromes

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...