Jump to content
TrinityCore
Sign in to follow this  
src

Compilation with debug mode is impossible

Recommended Posts

Hello,

I am trying to compile master branch cloned today but I get the Following error. I am on Debian latest release.
This error appear only when the cmake option -DWITH_COREDEBUG is set at TRUE. Otherwise no problem if the debug mode is disabled the compilation is done correctly.

image.thumb.png.ade9be08a867633fc09058bf268a6fb4.png

 

Here my cmake configuration

git clone -b master https://github.com/trinitycore/trinitycore.git && mkdir build && cd build
&& declare -x CXXFLAGS="-m64 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O0 -g3 -ggdb3 -pipe -msse3 -fno-strength-reduce -fno-delete-null-pointer-checks -fno-strict-aliasing -frename-registers -rdynamic"
&& declare -x CFLAGS="-m64 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O0 -g3 -ggdb3 -pipe -msse3 -fno-strength-reduce -fno-delete-null-pointer-checks -fno-strict-aliasing -frename-registers -rdynamic"
&& cmake ../ -DSCRIPTS="dynamic" -DTOOLS=false -DWITH_COREDEBUG=true -DCMAKE_BUILD_TYPE=RelWithDebug -DCMAKE_CXX_FLAGS="-std=c++11 -O0" -DCMAKE_C_FLAGS="-msse3 -O3"
&& make install -j 40 

Share this post


Link to post
Share on other sites
7 hours ago, src said:

Hello,

I am trying to compile master branch cloned today but I get the Following error. I am on Debian latest release.
This error appear only when the cmake option -DWITH_COREDEBUG is set at TRUE. Otherwise no problem if the debug mode is disabled the compilation is done correctly.

image.thumb.png.ade9be08a867633fc09058bf268a6fb4.png

 

Here my cmake configuration

git clone -b master https://github.com/trinitycore/trinitycore.git && mkdir build && cd build
&& declare -x CXXFLAGS="-m64 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O0 -g3 -ggdb3 -pipe -msse3 -fno-strength-reduce -fno-delete-null-pointer-checks -fno-strict-aliasing -frename-registers -rdynamic"
&& declare -x CFLAGS="-m64 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O0 -g3 -ggdb3 -pipe -msse3 -fno-strength-reduce -fno-delete-null-pointer-checks -fno-strict-aliasing -frename-registers -rdynamic"
&& cmake ../ -DSCRIPTS="dynamic" -DTOOLS=false -DWITH_COREDEBUG=true -DCMAKE_BUILD_TYPE=RelWithDebug -DCMAKE_CXX_FLAGS="-std=c++11 -O0" -DCMAKE_C_FLAGS="-msse3 -O3"
&& make install -j 40 

you don't compile on debug mode with DWITH_COREDEBUG

Share this post


Link to post
Share on other sites
13 hours ago, Aokromes said:

you don't compile on debug mode with DWITH_COREDEBUG

Ok but is it normal than we can't compile with DWITH_COREDEBUG option set at true ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...