Jump to content
TrinityCore

ipreferpapaya

Members
  • Content Count

    17
  • Joined

  • Last visited

Community Reputation

0 Neutral

About ipreferpapaya

  • Rank
    Member
  1. nevermind, I've figured it out. Thanks for the tip Paradox! I was able to figure out my versions and apply the correct updates to the characters datababase.
  2. gotcha, that makes sense. When I wipe everything and install fresh, everything starts up great and I can create a new account and login. The problem however, is that I still have my old character and auth DB, which I would like to preserve. Unfortunately, I wasn't very diligent about keeping track of my versions, and now TC does not start. Is there an easy way to figure out which version my characters and auth DB are on, so I can apply the necessary patches to get things working again? Thanks!
  3. How do I tell what version of the "characters" database I am on? My world database updated fine from 10818 to 10925, but when I run the script "10828_characters_character_queststatus.sql", I get the following error: "ERROR 1054 (42S22) at line 8: Unknown column 'rewarded' in 'where clause'"
  4. Thanks for the link. I swear I'd already read that whole page, but I guess I missed that section.
  5. I finally got a recent version of the core to compile and install on a mac, but now I need to apply SQL updates to my databases. Can someone remind me how to tell which sql updates I need to apply from the git source? Thanks for the help!
  6. ipreferpapaya

    Compile or cmake problems

    alright, the version I had from git builds, after applying the mac patch. Wahoo!
  7. ipreferpapaya

    Compile or cmake problems

    I'll take a look. I also missed the part where the repo switched over to git. I switched over and am now on commit 8d59953f9372c6876e0cd8078b44de6893082cbe. (How do I get the version number from git? I think this commit is version 11009, but I'm not 100% sure). Interestingly, my build still fails, but I get a different error: ~/source/TrinityCore/build/src/server/worldserver/Debug/worldserver Undefined symbols: "_Gestalt", referenced from: G3D::System::init() in libg3dlib.a(System.o) G3D::System::init() in libg3dlib.a(System.o) (maybe you meant: typeinfo name for ACE_Intrusive_Auto_Ptr<ACE_Service_Gestalt>, ld: symbol(s) not found collect2: ld returned 1 exit status This is definitely the dreaded G3D bug. I'll try applying my trusty mac patch now, and see if it builds. diff -r cbe929b901f8 dep/g3dlite/include/G3D/platform.h --- a/dep/g3dlite/include/G3D/platform.h Wed Aug 25 23:21:53 2010 +0300 +++ b/dep/g3dlite/include/G3D/platform.h Thu Aug 26 02:14:42 2010 +0200 @@ -51,7 +51,7 @@ #elif defined(__linux__) #define G3D_LINUX #elif defined(__APPLE__) - #define G3D_OSX + #define G3D_LINUX
  8. ipreferpapaya

    Compile or cmake problems

    No patches, nothing fancy. I ran "hg pull" then "hg update." I run "hg summary," which tells me "parent: 10868:2279a6653bea tip" I use this command for cmake: cmake ../ -GXcode \ -DMYSQL_ADD_INCLUDE_PATH=/usr/local/mysql \ -DREADLINE_INCLUDE_DIR=/opt/local/include \ -DREADLINE_LIBRARY=/opt/local/lib/libreadline.dylib \ -DACE_INCLUDE_DIR=/opt/local/include \ -DACE_LIBRARY=/opt/local/lib/libACE.a \ -DPREFIX=/opt/trinitycore \ -DWARNINGS=0 and then open the xcode solution and type command-B to compile. After a few minutes we've got an error: File:source/trinitycore/src/server/authserver/Main.cpp Line 101: sLog->outString("%s (realm-daemon)", _FULLVERSION); Error: expected `)' before 'Debug' I suspect this might be the dreaded gd3 bug... I know someone on the gd3 should fix this "soon" , but until then is there something I can hack together that will make TC compile? I love this project, and I want to keep using it...
  9. ipreferpapaya

    Compile or cmake problems

    I just want to confirm for version 10840:d1040972f9c0. I'll update my source and see if it's fixed.
×